NSA 310 Linux debian OMV 5.2.4-1 + OMV-Extras 5.2.2 - 502 Bad Gateway

  • Hello.


    I`m using NSA310 with Linux debian 5.4.2-kirkwood-tld-1 and have successfull installed openmediavault 5.2.4-1 with openmediavault-omvextrasorg 5.2.2, but when I connect to NSA i have ngix 502 Bad Gateway.


    I look on the web and find a command:


    omv-salt stage run deploy


    Result of use is on attachments file.


    Errors.txt


    I think there is somthing not configured - can I ask for help.


    Sorry for my bad English - i post with file because it to many word to post.

  • The most important code in three post:


  • And the secont post of the source code:


  • An te last post of the source code:


  • I tride to install many version, but nothing work`s (i use http://davidegironi.blogspot.c…-zyxtel.html#.Xi_yvEdKiUn) - then i find there is on nameserver config and there successfuly installed:


    https://forum.openmediavault.o…OMV5-on-Debian-10-Buster/


    An in next step install omvextras.


    There is result of your command:



    Code
    root@debian:~# omv-confdbadm migrate "conf" "5.0.0"
    Running migration conf_5.0.0
    Running migration conf_5.0.3
    Running migration conf_5.2.0
    root@debian:~#

    Reboot o run omv-salt stage run deploy?

  • I reboot and run command omv-salt stage run deploy:


  • Please post your network interface configuration. There seems to be multiple interfaces with the same name which shouldn't be possible.


    Bash
    # ip addr show
    # omv-confdbadm read --prettify conf.system.network.interface
  • That is the result of command:





    Source Code


    • root@debian:~# ip addr show
    • 1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    • link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    • inet 127.0.0.1/8 scope host lo
    • valid_lft forever preferred_lft forever
    • inet6 ::1/128 scope host
    • valid_lft forever preferred_lft forever
    • 2: enp1s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    • link/ether 00:00:00:00:00:30 brd ff:ff:ff:ff:ff:ff
    • inet 192.168.1.12/24 brd 192.168.1.255 scope global enp1s0
    • valid_lft forever preferred_lft forever
    • root@debian:~# omv-confdbadm read --prettify conf.system.network.interface
    • [
    • {
    • "address": "192.168.1.12",
    • "address6": "",
    • "bonddowndelay": 0,
    • "bondmiimon": 0,
    • "bondmode": 1,
    • "bondprimary": "",
    • "bondupdelay": 0,
    • "comment": "",
    • "devicename": "enp1s0",
    • "dnsnameservers": "192.168.1.1 8.8.8.8",
    • "dnssearch": "",
    • "gateway": "192.168.1.1 onlink ",
    • "gateway6": "",
    • "method": "static",
    • "method6": "manual",
    • "mtu": 0,
    • "netmask": "255.255.255.0",
    • "netmask6": 64,
    • "slaves": "",
    • "type": "ethernet",
    • "uuid": "42b5d982-1ff8-4b37-b019-edb51dd61220",
    • "vlanid": 1,
    • "vlanrawdevice": "",
    • "wol": false,
    • "wpapsk": "",
    • "wpassid": ""
    • },
    • {
    • "address": "192.168.1.12",
    • "address6": "",
    • "bonddowndelay": 0,
    • "bondmiimon": 0,
    • "bondmode": 1,
    • "bondprimary": "",
    • "bondupdelay": 0,
    • "comment": "",
    • "devicename": "enp1s0",
    • "dnsnameservers": "192.168.1.1 8.8.8.8",
    • "dnssearch": "",
    • "gateway": "192.168.1.1",
    • "gateway6": "",
    • "method": "static",
    • "method6": "manual",
    • "mtu": 0,
    • "netmask": "255.255.255.0",
    • "netmask6": 64,
    • "slaves": "",
    • "type": "ethernet",
    • "uuid": "c8f5be00-c1dc-446b-99bc-f6af9e6512c4",
    • "vlanid": 1,
    • "vlanrawdevice": "",
    • "wol": false,
    • "wpapsk": "",
    • "wpassid": ""
    • },
    • {
    • "address": "192.168.1.12",
    • "address6": "",
    • "bonddowndelay": 0,
    • "bondmiimon": 0,
    • "bondmode": 1,
    • "bondprimary": "",
    • "bondupdelay": 0,
    • "comment": "",
    • "devicename": "enp1s0",
    • "dnsnameservers": "192.168.1.1 8.8.8.8",
    • "dnssearch": "",
    • "gateway": "192.168.1.1",
    • "gateway6": "",
    • "method": "static",
    • "method6": "manual",
    • "mtu": 0,
    • "netmask": "255.255.255.0",
    • "netmask6": 64,
    • "slaves": "",
    • "type": "ethernet",
    • "uuid": "18e4d48a-d3f8-450e-9f21-fe1855b40829",
    • "vlanid": 1,
    • "vlanrawdevice": "",
    • "wol": false,
    • "wpapsk": "",
    • "wpassid": ""
    • },
    • {
    • "address": "192.168.1.12",
    • "address6": "",
    • "bonddowndelay": 0,
    • "bondmiimon": 0,
    • "bondmode": 1,
    • "bondprimary": "",
    • "bondupdelay": 0,
    • "comment": "",
    • "devicename": "enp1s0",
    • "dnsnameservers": "8.8.8.8 192.168.1.1",
    • "dnssearch": "",
    • "gateway": "192.168.1.1",
    • "gateway6": "",
    • "method": "static",
    • "method6": "manual",
    • "mtu": 0,
    • "netmask": "255.255.255.0",
    • "netmask6": 64,
    • "slaves": "",
    • "type": "ethernet",
    • "uuid": "c5d58521-9ec9-46df-91ba-8812097720fb",
    • "vlanid": 1,
    • "vlanrawdevice": "",
    • "wol": false,
    • "wpapsk": "",
    • "wpassid": ""
    • }
    • ]

    I see ther is what you think: multiple interfaces - what can i do to delete them?

  • I use command:


    omv-confdbadm delete conf.system.network.interface


    Then i run:


    omv-firstaid


    And configure network interfaces and when I run omv-confdbadm read --prettify conf.system.network.interface there was only one interfaces.


    I reboot and run command omv-salt stage run deploy:


    Summary for debian
    ------------
    Succeeded: 2 (changed=1)
    Failed: 0
    ------------
    Total states run: 2
    Total run time: 561.854 s


    OMV is working - thanks for help.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!