postfix/smtpd error since OMV5 upgrade

  • I was inspecting the syslog after the OMV5 upgrade, and the only task which is giving errors is the postfix/smtpd service.

    In OMV4 I got all the notifications working (plus a telegram channel to replicate them with a bot), but in OMV5 I cannot make them to work, except the "Your user account was used to log in to the openmediavault control panel via a web browser" which works like a charm.

    I have the SMTP settings well configured (, username without the domain and password) as the login email gets sent correctly. But the rest of notifications (disk resources, cpu usage, smart...) does not get sent.

    I tried to reinstall and restart postfix, and clean, save, fill in and save the notifications dialog in the GUI.

    These are the errors related in syslog:

    postfix/smtpd[20056]: warning: dict_nis_init: NIS domain name not set - NIS lookups disabled
    postfix/smtpd[20056]: fatal: in parameter smtpd_relay_restrictions or smtpd_recipient_restrictions, specify at least one working instance of: reject_unauth_destination, defer_unauth_destination, reject, defer, defer_if_permit or check_relay_domains
    postfix/master[7274]: warning: process /usr/lib/postfix/sbin/smtpd pid 20056 exit status 1
    postfix/master[7274]: warning: /usr/lib/postfix/sbin/smtpd: bad command startup -- throttling
    monit[1557]: Cannot create socket to []:25 -- Connection timed out
    monit[1557]: Cannot open a connection to the mailserver -- Operation now in progress
    monit[1557]: Mail: Delivery failed -- no mail server is available
    monit[1557]: Alert handler failed, retry scheduled for next cycle

    Thanks in advance.

    omv 5.5.23-1 usul arm64

    omv 5.5.23-1 usul x64

  • Does omv-salt deploy run postfix fix that issue?

    Looks good now. An amount of monit messages arrived in my mailbox.
    Thank you.

    jfromeo: If that fix resolves your problem also, the thread can be marked "solved".

    OMV 5.6.16 Usul | omvextrasorg 5.6.2 | Kernel Linux 5.10.60-mvebu | Armbian Buster 21.08.3 | Hardware Helios 4

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!