[SOLVED] Headless on Asus P5Q-E

  • Hi!


    To save a bit of power, I would like to run my server with no GPU. I installed and configured OMV 5 with a GPU installed. If I remove the GPU, the motherboard (Asus P5Q-E) beeps the No-VGA sequence and shortly after, the distinctive OMV joyful beep sings, as usual.
    Everything seems fine, but the WebUI is not accessible and the PC is not seen at all on the network. What's weird is that I can type (blindly) and login to root, type my password then type any commands (poweroff works fine).


    I would assume that this motherboard can't live without a GPU, but I don't understand why OMV boot correctly and LAN is not working ?(



    Any clues on what's happening?



    P.-S.: The motherboard doesn't have VGA output

    • Official Post

    I would try a reinstall with static ip configuration on the server not the router. Also check the manual of the board in regards of the gpu.


    My guess is that when you remove the card the nic changes name since is also Pcie based(it shouldn’t, like systemd introduced predictable hw name but rarely works).


    Reinstall with gpu, use a udev rule to set a fixed name for the nic, then try again without the gpu.

    • Official Post

    Are you sure the system is actually booting without the GPU? Looking at the pic of the motherboard, it doesn't have integrated graphics and a lot of desktop boards will not boot without a gpu.

    omv 6.2.0-1 Shaitan | 64 bit | 6.1 proxmox kernel

    plugins :: omvextrasorg 6.1.1 | kvm 6.2.8 | compose 6.6.1 | cputemp 6.1.3 | mergerfs 6.3.5 | zfs 6.0.12


    omv-extras.org plugins source code and issue tracker - github


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • Are you sure the system is actually booting without the GPU?

    Yes it is booting. Without a GPU, the OMV boot up chime rings and it is possible to use blindly the console with a keyboard plugged in. I logged in as root then issued the poweroff command, and the server powered off normally (with the poweroff chime of OMV).


    i used to use that board headless under win7 without a grafix card and there was a setting in the bios that you need to enable to stop it 'halting on errors' or something along those lines

    Good to know it should works! "Halt on error" is disabled in the BIOS, it boots fine but the LAN isn't working without a GPU.




    Long story short: without a GPU the systems boots fine, but onboard LAN is not working.
    I'll try using a wifi PCIE card out of curiosity.

    • Official Post

    Long story short: without a GPU the systems boots fine, but onboard LAN is not working.

    Do you still have the GPU card? if so stick it in, boot to the OS. As I mentioned before use udev rules, but reading docs seems like is deprecated. So you have to use systemd .link unit to set a fix name.


    https://wiki.debian.org/NetworkInterfaceNames read custom schemes using .link section


    https://www.freedesktop.org/so…emd/man/systemd.link.html


    As i said before nic name shouldn't change but my guess is changing here every time you pull the GPU

  • So you have to use systemd .link unit to set a fix name.[...]
    As i said before nic name shouldn't change but my guess is changing here every time you pull the GPU


    Thank you for the info. I will be looking into the systemd and .link files, the solution might be there.

  • PROBLEM SOLVED! :D


    I edited /etc/systemd/network/10-openmediavault-enp2s0.network
    Changed the match section from
    [Match]Name=enp2s0
    to
    [Match]MACAddress=00:23:54:27:40:35


    So now the nic name can't change without a problem.


    I did not touch the 10-openmediavault-enp2s0.link file because I did not know what to change in it, it seemed fine to me (but I might be wrong since I'm inexperienced with Linux and servers).


    Thank you!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!