OMV on a QNAP TS-210 and others.

  • Hi there,


    I would like to install OMV on my QNAP NAS, can anybody tell me where there is a guide for this (if it can be done). Its a small NAS with no monitor output. I am using a a Mac but happy to use Windows if needs be.


    Also, I have been lucky enough to have been given the following servers and I will one day be using these for my storage solutions, can anybody tell me if they can run OMV?


    2 X Dell PowerEdge R210 II
    1 X Dell PowerEdge R310
    1 X HP ProLiant DL380 Generation 6 Server


    Thanks very much,
    Nick.

  • I would skip the TS-210. Too slow and armel architecture.


    The other servers will definitely run OMV. I would use OMV 5.x though.

    omv 5.3.9 usul | 64 bit | 5.3 proxmox kernel | omvextrasorg 5.2.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • OK, so I made bootable media on both CD-ROM and USB. I put both of them in.


    On startup, I am doing:


    • F11 = Boot Menu
    • F11 again for default boot override options
    • Then option 1) One time boot to CD-ROM


    The first time I did this, it started installing OMV but then encountered a problem so I had to reboot.


    Now, after step 3, above, I get:


    Attempting boot from CD-ROM
    Attemting boot from USB Drivekey


    Non-system disk, press any key to reboot.


    And around in circles I go! Any ideas would be welcomed.


    Thank you,
    Nick.

  • OK, so I re created the USB disk and set the internal USB ports to boot first, now it boots from the USB and all goes well until i hit the networking bit where it tries to setup DHCP. I think this is because I am using dd-wrt on my router to run a VPN, so i say that I will set the nestwork up later.


    All good then until we get to partitioning the disk (setup is running on a 4GB, and the install disk (destination for OMV) is a 16GB USB).


    Error says:


    Failed to partition the selected disk
    This probably happened because the selected disk or free space is too small to be automatically partitioned


    Thanks,
    Nick.


    EDIT: OK, so I am looking at this guide now!


    MORE EDITS: Well, I tried what the guide said, using g-parted live disk and I had to put sudo in front of the second command for it to work, as it moaned about permissions. The disk still gave the same error regarding partitioning, so I grabbed myself a 128GB SSD that I had laying around and it went through without issue.


    Next up was the network, DHCP could not be set up, so i skipped it after spending ages trying to set it up manually. Then the package updater couldn't run, so I skipped that. Then I got an error about a disk outside of HDD0 trying to boot, so I shut it down altogether.


    At this rate, I'll just install it on an old desktop PC as that always works for me. Grrr. Time for bed.

  • so i say that I will set the nestwork up later.

    OMV needs network connection during installation.

    This probably happened because the selected disk or free space is too small to be automatically partitioned

    One reason for this could be, that the standard installer wants to create a swap partition. The size is calculated based on the RAM you have installed. If you have lots of RAM the target drive will be too small.
    A work around it to install Debian first and then install OMV on top. The installer of Debian is more flexible and you are able to install with smaller or no swap partition.
    For installation use the net inst installer of Debian and do not install a desktop environment (you will be asked in the middle of the installation what you want to install).
    But also in this case you need network connection.
    You can follow this guide. Just use a amd64 iso instead of the i386 iso of debian netinst. And you need to adjust the partitioning due to swap.


    Other approach:
    If you have installed OMV successfully on the old desktop PC you might be able to move the installation to the other devices. Just grab the OS drive and plug it in. You should do this before you have done any configuration within OMV.
    If that is working you can setup the network connection.

  • OK, many thanks.


    I ended up just reverting to OMV 4 on another desktop - the servers will have to wait but I am planning to return to this thread and finish the job. I just don't have the time to mess about with it at the moment.


    I now have two desktops running OMV, I will use these for backups for now.


    I did manage to install OMV 5 on that SSD, which was obviously bigger then tha RAM, but I still got the error about a disk outside of HDD0 trying to boot.


    Thanks again for your patience and I'll be back soon. First a new thread as I cannot get FTP to work on the new setup!


    Ta,
    Nick.

  • FYI, I am using OMV5 on my QNAP TS-210 without problem. Once booted, OMV5 is not slower than OMV4.


    Of course this is old hardware and not the fastest but it is enough for a basic usage like in my case:
    - 2 or 3 simultaneous clients (over wifi so no point in having a gigabit capable read/write speed ;))
    - SMB shares incl. TimeMachine backups and win10 backups
    - minidlna share
    - occasional download using aria2


    No need to throw away working and possibly sufficient HW. The planet says thanks! :)


    If you want to try the adventure you will need the information from Martin in order to install Debian:
    https://cyrius.com/debian/kirkwood/qnap/ts-219/


    You will also find some tips I gathered for OMV on the Qnap forum (these were for OMV4 but I believe most of it is still valid):
    https://forum.qnap.com/viewtopic.php?f=147&t=142098


    One more thing, the flash for the initrd started becoming small with Buster but unlike what's stated on Martin's website, it still works fine using the trick at the end of the page:


    https://cyrius.com/debian/kirk…p/ts-119/troubleshooting/

  • Hi there,


    Wow, that's great - thank you for that! I did offer the NAS to somebody I work with as he had expressed an interest in having one, so I thought a charitable donation would be good! Now I am thinking that I'd like this project for myself though, so i will see. Maybe I'll install it before I give it to him :)


    Anyway, thanks for posting all of this info, its very much appreciated!


    Cheers,
    Nick.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!