remotemount plugin - WD MY CLOUD HOME

  • Hi everyone,


    I'm setting up my OMV 5 on my raspberry Pi 4 and i want to mount a shared folder from my WD CLOUD HOME NAS.


    I did the following steps:


    1. install the remote mount plugin on OMV5 and on Remote mount option i did the following:
    Mount type: SMB/CIFS
    Server: (ip address from my WD CLOUD HOME NAS)
    Share: INBOX (the folder name that i want and exists on the public folder path: \\192.168.1.5\Public\INBOX)
    Username: Nothing here
    Password: Nothing here
    Options: _netdev,iocharset=utf8,vers=3.0,nofail (it is de default)


    2. shared folder tab added the device and folder


    3. SMB/CIFS tab i added the share:
    Public: Only Guests
    and Enable permission ineritance "yes" and everything else as default


    My testing:
    - I can find the shared path on my windows machine but i dont have any permitions to create folders inside, etc.
    - I setup a portainer with qbitorrent with a stack and i setup the path for the download folders with the absolute path given from OMV5 and nothing happens
    - On my step 1 i tried to setup with different users and password created on OMV (example: admin, or jr) but i have the same issue.


    I dont understand too much about networking but it seems to me that the issue here is some sort of permition on my WD CLOUD HOME NAS, with sMB/CIFS protocol or something like that.


    Any help will be appreciated.

  • On my step one I've found the following
    Options: _netdev,iocharset=utf8,vers=3.0,nofail (it is de default)


    That have this link: https://linux.die.net/man/8/mount.cifs


    Can any one explain what options should i use?


    Or is it a WD my cloud home permitions thing?


    I've tried to change public folder permitions (it has special permitions as default) but when I appy it doesn't change anything.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!