Error install iSCSI plugin

  • Hello everyone.


    I require your assistance. I try since 4 days to install iSCSI plugin on my OMV, but I just can't. When I try to verify the plugins list, I get an loooong error :

    Code
    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; apt-get update 2>&1' with exit code '100': Get:1 file:/var/cache/openmediavault/archives InRelease Ign:1 file:/var/cache/openmediavault/archives InRelease Get:2 file:/var/cache/openmediavault/archives Release Ign:2 file:/var/cache/openmediavault/archives Release Get:3 file:/var/cache/openmediavault/archives Packages Ign:3 file:/var/cache/openmediavault/archives Packages Get:4 file:/var/cache/openmediavault/archives Translation-en Ign:4 file:/var/cache/openmediavault/archives Translation-en Get:3 file:/var/cache/openmediavault/archives Packages Ign:3 file:/var/cache/openmediavault/archives Packages Get:4 file:/var/cache/openmediavault/archives Translation-en Ign:4 file:/var/cache/openmediavault/archives Translation-en Get:3 file:/var/cache/openmediavault/archives Packages Ign:3 file:/var/cache/openmediavault/archives Packages Get:4 file:/var/cache/openmediavault/archives Translation-en Ign:4 file:/var/cache/openmediavault/archives Translation-en Get:3 file:/var/cache/openmediavault/archives Packages Ign:3 file:/var/cache/openmediavault/archives Packages Get:4 file:/var/cache/openmediavault/archives Translation-en Ign:4 file:/var/cache/openmediavault/archives Translation-en Get:3 file:/var/cache/openmediavault/archives Packages Ign:3 file:/var/cache/openmediavault/archives Packages Get:4 file:/var/cache/openmediavault/archives Translation-en Ign:4 file:/var/cache/openmediavault/archives Translation-en Get:3 file:/var/cache/openmediavault/archives Packages Ign:3 file:/var/cache/openmediavault/archives Packages Get:4 file:/var/cache/openmediavault/archives Translation-en Ign:4 file:/var/cache/openmediavault/archives Translation-en Get:3 file:/var/cache/openmediavault/archives Packages Get:4 file:/var/cache/openmediavault/archives Translation-en Ign:4 file:/var/cache/openmediavault/archives Translation-en Get:5 http://deb.debian.org/debian buster InRelease [122 kB] Ign:6 https://packages.openmediavault.org/public usul InRelease Ign:7 https://deb.debian.org/debian buster-backports InRelease Err:8 https://packages.openmediavault.org/public usul Release Certificate verification failed: The certificate is NOT trusted. The certificate chain uses not yet valid certificate. Could not handshake: Error in the certificate verification. [IP: 178.254.11.33 443] Get:9 http://deb.debian.org/debian-security buster/updates InRelease [65.4 kB] Err:10 https://deb.debian.org/debian buster-backports Release Certificate verification failed: The certificate is NOT trusted. The certificate chain uses not yet valid certificate. Could not handshake: Error in the certificate verification. [IP: 151.101.122.133 443] Get:11 http://deb.debian.org/debian buster-updates InRelease [49.3 kB] Reading package lists... E: The repository 'https://packages.openmediavault.org/public usul Release' does not have a Release file. E: Release file for http://deb.debian.org/debian/dists/buster/InRelease is not valid yet (invalid for another 359d 0h 32min 46s). Updates for this repository will not be applied. E: The repository 'https://deb.debian.org/debian buster-backports Release' does not have a Release file. E: Release file for http://deb.debian.org/debian-security/dists/buster/updates/InRelease is not valid yet (invalid for another 361d 3h 7min 5s). Updates for this repository will not be applied. E: Release file for http://deb.debian.org/debian/dists/buster-updates/InRelease is not valid yet (invalid for another 360d 22h 0min 35s). Updates for this repository will not be applied.

    I tried to purge and reinstall OMV, I tried ton manually install the plugin, but nothing works.


    I need your help please.

  • Your system clock needs to be set. Enable ntp.


    And it looks like you are on OMV 5.x. Just to double check you are actually trying to install the tgt plugin?

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Ho.....
    Ahem...
    Yeah, I turn on NTP and... Well... It works.
    I feel kind of stupid rn.


    Thanks.


    But, when I make a uname -a, to get the version of OMV, I get :

    Code
    Linux openmediavault.HyperV.local 4.19.0-5-amd64 #1 SMP Debian 4.19.37-5+deb10u2 (2019-08-08) x86_64 GNU/Linux

    Which, I guess, means that OMV is 4.x version.

  • Which, I guess, means that OMV is 4.x version.

    Nope. That is the standard kernel for Debian 10 Buster which is OMV 5.x. To get that kernel on OMV 4.x, it would have bpo in the version string. To get the OMV version, dpkg -l openmediavault

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • By tgt you mean ? target plugin ? If yes, indeed. I want to install iscsitarget plugin

    openmediavault-tgt is the name of the plugin and is the target plugin. The openmediavault-iscsitarget plugin wasn't available after OMV 3.x. Just wanted to clear up what you were looking for.

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Hooo, didn't know about that.
    But, how can I download this plugin ?
    I try to find out on internet (github, bintray...) but nothing return, and apt search don't find tgt.


    sorry if my question seems a bit sketchy / obvious.

  • But, how can I download this plugin ?

    If you installed omv-extras, it will show in the plugin list on the Plugins tab in the OMV web interface.

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!