FTP not working for no reason at all.

  • Hello all,


    I have two install os OMV, both version 4, both updated through the web interface, both configured the same way.


    I can connect via FTP to one, but not the other (both through a browser and FileZilla.)


    I have the two installs in seperate tabs and I have been switching between them to see what's different and I can't see anything! Am I missing something really obvious?


    Thanks,
    Nick.


    EDIT: Here is the error from FileZilla:
    Connecting to 192.168.1.99:21...Status: Connection attempt failed with "ECONNREFUSED - Connection refused by server".Error: Could not connect to server

  • You need to explain exactly how and from where you ate testing this.

    --
    Google is your friend and Bob's your uncle!


    RAID - Its ability to disappoint is inversely proportional to the user's understanding of it.


    OMV 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • OK, apologies - let me try to be a bit clearer.


    So, a while ago I installed OMV 4 on an old desktop, and I have recently been given a few servers that I am trying to get OMV working on, but that's another story.


    The desktop install of OMV has been working well, and I have it doing everything I want (FTP included), apart from backing up files, so this is why I have installed OMV on the second machine. This is an interim measure until I get the proper servers working, then I will look into RAID.


    It's all on a LAN, I have a cellular router on 4G (192.168.0.1), that connects to a router flashed with DDWRT, running OpenVPN (192.168.1.1), both OMV desktops are wired off of the DDWRT router using TPLink Powerline adapters. Both OMV machines can connect to the internet and I have made sure that they are up-to-date in the update management section.


    The OMV install that FTP is working on is on 192.168.1.98, and the other one is on 192.168.1.99. My router starts handing out IP addresses from 192.168.1.100 to 192.168.1.150.


    In setting up FTP, I have created shares, added a user with access to those shares, added the shares to the FTP application within OMV and then tested them through a browser window (ftp://192.168.1.xx), and using FileZilla. I have been through all of the sections that I think are relevant on the working install of OMV and compared these to the sections on the one where FTP will not connect, I can't see where I am going wrong.


    I hope this is enough information and thanks for your help!


    Nick.

  • hi,


    have you set the privileges to the user & share too?


    that was my fail ... i set the share, i set a user for ftp, in user grp, all nice - but didn't work .. just have forgot to set privileges. so maybe it helps.


    if you can't even connect, try to change Passive FTP - never used filezilla so don't know what its need, to just connect with firefox Passive FTP have to be activ.

  • Hi draddy,


    Thanks - I thought you'd solved things for me, but sadly not!


    I took a look at shared folder privileges and my username didn't have access (nothing ticked), so i went ahead and ticked Read/Write. Sadly, this hasn't fixed things. Passive mode isn't needed for FTP on the other OMV setup so I doubt this one needs it either.


    Thanks again,
    Nick.

  • so you just cant connect or you connect and see nothing?


    connect extern or just internal (with local ip)?


    can you connect to that shared folder with other services like smb? (if you add the share to smb)

  • I am connecting with a local IP.


    I can't connect at all, I just get the error message below from FileZilla:
    "ECONNREFUSED - Connection refused by server".


    If I try ftp in a browser, I get an 'Unable to Connect' message.


    I have just tries to ssh into it and I get this:
    Mac-Pro:~ nick$ ssh root@192.168.1.99@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@ WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED! @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@IT IS POSSIBLE THAT SOMEONE IS DOING SOMETHING NASTY!Someone could be eavesdropping on you right now (man-in-the-middle attack)!It is also possible that a host key has just been changed.The fingerprint for the RSA key sent by the remote host isSHA256:7UDg3YkHdsfk9Wm1y5iv7C5Kao9NMJV0pPKIoIlWTCU.Please contact your system administrator.Add correct host key in /Users/nick/.ssh/known_hosts to get rid of this message.Offending RSA key in /Users/nick/.ssh/known_hosts:4RSA host key for 192.168.1.99 has changed and you have requested strict checking.Host key verification failed.Mac-Pro:~ nick$


    Could this be it?


    Thanks again,
    Nick.

  • hi


    in your dashboard: FTP is enable + running (two green dots)?


    that ssh is normal massage at the first time - maybe you have ever connect to that ip with ssh bevor you install that new omv? usually (in putty) you just click once to accept the new key and can connect to.


    in a quick google search i just read filezilla would be use passive mode as default - give it a try and enable it.

  • ok
    something went totaly wrong ^^



    in my case i just create a user called ftpuser and set a shared folder, lets say ftp
    acl for the user ftpuser on share ftp and privileges as well


    go over to ftp section, enable it port to 21, max clients i limit to 5, connections pert host 2 max login attempts 1 timeout 1200, no anonymous ftp and passive ftp (cause i like to have the ability to just connect with firefox to download something. save + apply


    on shares i add the ftp share. save + apply


    if you only want to connect in you local lan - you will not have to do some forwards in your router, that forwards are needed if you want to connect from the internet to your ftp server.


    can u try to enable SMB, add the ftp share here, press on a windows PC the Windowskey + R --> in "run" you enter \\192.168.1.99 - a "username + password" request should appear enter your ftpuser and password --> work?

  • Sorry but it is saying that the syntax is wrong if I just type in the IP address.


    EDIT: Okay, I gave up and reinstalled and then:


    Set static IP address of 192.168.1.99
    Set DNS of 192.168.1.1 (router)
    Create user (ftpuser)
    Mount disk
    Create share (backup)
    Apply privileges to share
    Go to user privileges and check that share is Read Write (it was)
    Enable FTP
    Add share to FTP


    Login using FileZilla - SUCCESS!


    Who knows why it didn't work before but thanks for all the help here, thanks for your patience.


    I just wanted to document things for anybody that wants to set up FTP on a clean install.


    Cheers,
    Nick.

  • ehm, ok - so it works, right?


    good job ;)


    and like someone told me years ago "you do everything right, but it don't work, just start over, do it right again, and it will work, thats working with computers" xD

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!