(Solved) Option not saved in webui for system backup

  • Hi,
    In OMV 4., whenever I change in the webUI the schedule for system backup from daily to anything else (e.g. monthly), then the usual Save + Apply, and then go back to the "Create Schedule backup job", it again show Daily. In /etc/openmediavault/config.xml, I get this:

    XML
    <backup>
    <sharedfolderref>723dd3b2-f9ae-464b-8ddb-99070cd01311</sharedfolderref>
    <method>fsarchiver</method>
    <root></root>
    <extraoptions></extraoptions>
    <keep>2</keep>
    <passwd></passwd>
    </backup>


    Do I miss something or is it a bug? What should be the correct XML for 2 monthly backups? (I couldn't find the script reading and using that).
    Thank you!

  • Do I miss something or is it a bug? What should be the correct XML for 2 monthly backups? (I couldn't find the script reading and using that).

    The plugin ONLY creates a daily backup - https://github.com/OpenMediaVa…ackup/SystemBackup.js#L46. If you want monthly, the keep number of copies won't work. But you should create the backup and then edit the job in the Scheduled Jobs tab. Then never use the Scheduled Backup button again.

    omv 5.3.9 usul | 64 bit | 5.3 proxmox kernel | omvextrasorg 5.2.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!