Docker and ZFS

  • Hello all,
    I have some issues with ZFS and Docker.
    Tried to install Nextcloud Docker image and de-installed all of it but I somehow ended up with orphans in Docker and ZFS:
    1) under Docker GUI it shows 2 containers / images as "removal in progress" but they cannot be removed
    2) Docker container ls -a shows the same output in command line; I tried docker image prune but they are still there
    6d9fd9adf55c 4a1ec410d93d "/init" 3 months ago Removal In Progress nextcloud
    f0f3b8a60ea6 9877cdd9debc "/init" 3 months ago Removal In Progress nextclouddb

    3) in ZFS I have 2 data pools which look random and I did not create them by hand.

    Pool1/LiveZ/2538ae67fb85d2f816a7edb5200d54cb611265fd47ab8388d8e303e97b3150c2 78.8M 2.49T 78.8M legacy
    Pool1/LiveZ/76839ca8491f7bca13226a91aee0b50fe68a18fe47965e8483b17e3d83c480d6 6.96M 2.49T 6.96M legacy

    Can anyone help me remove these images/containers.

    OMV4 on ProLiant N54L + 5 x 3.5'' WD/Seagate HDs

    OMV5 on Raspberry Pi4

  • There are issues with docker containers located on ZFS file system. Please search the forum for related threads. The docker containers should be located on a file system other then ZFS.

    OMV 3.0.100 (Gray style)

    ASRock Rack C2550D4I C0-stepping - 16GB ECC - 6x WD RED 3TB (ZFS 2x3 Striped RaidZ1) - Fractal Design Node 304 -

    3x WD80EMAZ Snapraid / MergerFS-pool via eSATA - 4-Bay ICYCube MB561U3S-4S with fan-mod

  • thanks. I am aware of that issue. But I still have these orphan containers and datasets.
    Any ideas how I can remove them?

    OMV4 on ProLiant N54L + 5 x 3.5'' WD/Seagate HDs

    OMV5 on Raspberry Pi4

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!