openVPN or?

  • hi guys ,running 5.3.4.1 , Tried installing transmission + vpn but no luck. i manage to install transmission by it self ...but still having problems installing openVPN.
    What version of openVPN or transmission+vpn are you guys running ? cannot find any tutorials to install in portainer. thanx

  • this is the ;og for transmission + vpn



    Using OpenVPN provider: PIA,
    No VPN configuration provided. Using default.,
    Setting OPENVPN credentials...,
    adding route to local network 192.168.1.0/24 via 172.17.0.1 dev eth0,
    RTNETLINK answers: Operation not permitted,
    Wed Mar 4 21:52:48 2020 OpenVPN 2.4.4 x86_64-pc-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [PKCS11] [MH/PKTINFO] [AEAD] built on May 14 2019,
    Wed Mar 4 21:52:48 2020 library versions: OpenSSL 1.1.1 11 Sep 2018, LZO 2.08,
    Wed Mar 4 21:52:48 2020 NOTE: the current --script-security setting may allow this configuration to call user-defined scripts,
    Wed Mar 4 21:52:48 2020 TCP/UDP: Preserving recently used remote address: [AF_INET]172.98.67.142:1198,
    Wed Mar 4 21:52:48 2020 UDP link local: (not bound),
    Wed Mar 4 21:52:48 2020 UDP link remote: [AF_INET]172.98.67.142:1198,
    Wed Mar 4 21:52:48 2020 WARNING: this configuration may cache passwords in memory -- use the auth-nocache option to prevent this,
    Wed Mar 4 21:52:49 2020 [af04f2a38eb3d850263c4f67f011c479] Peer Connection Initiated with [AF_INET]172.98.67.142:1198,
    Wed Mar 4 21:52:50 2020 ERROR: Cannot ioctl TUNSETIFF tun: Operation not permitted (errno=1),
    Wed Mar 4 21:52:50 2020 Exiting due to fatal error,
    Using OpenVPN provider: PIA,
    No VPN configuration provided. Using default.,
    Setting OPENVPN credentials...,
    adding route to local network 192.168.1.0/24 via 172.17.0.1 dev eth0,
    RTNETLINK answers: Operation not permitted,
    Wed Mar 4 22:00:04 2020 OpenVPN 2.4.4 x86_64-pc-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [PKCS11] [MH/PKTINFO] [AEAD] built on May 14 2019,
    Wed Mar 4 22:00:04 2020 library versions: OpenSSL 1.1.1 11 Sep 2018, LZO 2.08,
    Wed Mar 4 22:00:04 2020 NOTE: the current --script-security setting may allow this configuration to call user-defined scripts,
    Wed Mar 4 22:00:04 2020 TCP/UDP: Preserving recently used remote address: [AF_INET]172.98.67.6:1198,
    Wed Mar 4 22:00:04 2020 UDP link local: (not bound),
    Wed Mar 4 22:00:04 2020 UDP link remote: [AF_INET]172.98.67.6:1198,
    Wed Mar 4 22:00:04 2020 WARNING: this configuration may cache passwords in memory -- use the auth-nocache option to prevent this,
    Wed Mar 4 22:00:04 2020 [230be89028b12a840bc13a3cfb2f26d1] Peer Connection Initiated with [AF_INET]172.98.67.6:1198,
    Wed Mar 4 22:00:06 2020 ERROR: Cannot ioctl TUNSETIFF tun: Operation not permitted (errno=1),
    Wed Mar 4 22:00:06 2020 Exiting due to fatal error,
    Using OpenVPN provider: PIA,
    No VPN configuration provided. Using default.,
    Setting OPENVPN credentials...,
    adding route to local network 192.168.1.0/24 via 172.17.0.1 dev eth0,
    RTNETLINK answers: Operation not permitted,
    Wed Mar 4 22:00:39 2020 OpenVPN 2.4.4 x86_64-pc-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [PKCS11] [MH/PKTINFO] [AEAD] built on May 14 2019,
    Wed Mar 4 22:00:39 2020 library versions: OpenSSL 1.1.1 11 Sep 2018, LZO 2.08,
    Wed Mar 4 22:00:39 2020 NOTE: the current --script-security setting may allow this configuration to call user-defined scripts,
    Wed Mar 4 22:00:39 2020 TCP/UDP: Preserving recently used remote address: [AF_INET]172.98.67.34:1198,
    Wed Mar 4 22:00:39 2020 UDP link local: (not bound),
    Wed Mar 4 22:00:39 2020 UDP link remote: [AF_INET]172.98.67.34:1198,
    Wed Mar 4 22:00:39 2020 WARNING: this configuration may cache passwords in memory -- use the auth-nocache option to prevent this,
    Wed Mar 4 22:00:40 2020 [0195d7159dd5e3c495e4dffb60368068] Peer Connection Initiated with [AF_INET]172.98.67.34:1198,
    Wed Mar 4 22:00:41 2020 ERROR: Cannot ioctl TUNSETIFF tun: Operation not permitted (errno=1),
    Wed Mar 4 22:00:41 2020 Exiting due to fatal error,

  • I was never able to get this working either in OMV 5 with Portainer. I tried all kinds of different combinations based on the OMV 4 TechnoDadLIfe video but never got it working. I was able to get this deluge with vpn docker working though:
    https://hub.docker.com/r/binhex/arch-delugevpn/
    You have to get an ovpn file from your vpn provider and put it in the right folder as noted but otherwise it's working great. I don't think the Privoxy part is working correctly but deluge is definitely running through my IPVanish vpn.

  • I was never able to get this working either in OMV 5 with Portainer. I tried all kinds of different combinations based on the OMV 4 TechnoDadLIfe video but never got it working. I was able to get this deluge with vpn docker working though:
    https://hub.docker.com/r/binhex/arch-delugevpn/
    You have to get an ovpn file from your vpn provider and put it in the right folder as noted but otherwise it's working great. I don't think the Privoxy part is working correctly but deluge is definitely running through my IPVanish vpn.

    Thanks for your reply, not just me then having problems with it. Will look at the link you posted and will try ...other then that I was thinking at my old unused router and making it as a dedicated hardware VPN.
    Silly question... Where is this line going in portainer ... --cap-add=NET_ADMIN.
    Thanks


    Sent from my GM1913 using Tapatalk

  • Thanks for your reply, not just me then having problems with it. Will look at the link you posted and will try ...other then that I was thinking at my old unused router and making it as a dedicated hardware VPN.Silly question... Where is this line going in portainer ... --cap-add=NET_ADMIN.
    Thanks


    Sent from my GM1913 using Tapatalk

    It feels a little silly to me to give you any type of advice or guidance given how much of a novice I am with this stuff :) But what I did was in the Capabilities tab in the container create screen in Portainer, there's a list of switches you can enable/disable. The second column has a NET_ADMIN switch and I enabled it.


    Another common Portainer option I've had to use is enabling Privileged Mode which it appears you can do in the Runtime & Resources tab.


    Hope that helps!

  • It feels a little silly to me to give you any type of advice or guidance given how much of a novice I am with this stuff :) But what I did was in the Capabilities tab in the container create screen in Portainer, there's a list of switches you can enable/disable. The second column has a NET_ADMIN switch and I enabled it.


    Another common Portainer option I've had to use is enabling Privileged Mode which it appears you can do in the Runtime & Resources tab.


    Hope that helps!

    Very helpful...will let you know if I am successful. A lot of us learning from eachother ✌️


    Sent from my GM1913 using Tapatalk

  • I am in the exact same spot and I've spent a few days messing with this!


    Trying to run openvpn and transmission. I sat down with the TechnoDadLife video a few nights ago but his directions did not work.

    Thanks for your reply, not just me then having problems with it. Will look at the link you posted and will try ...other then that I was thinking at my old unused router and making it as a dedicated hardware VPN.Silly question... Where is this line going in portainer ... --cap-add=NET_ADMIN.
    Thanks


    Sent from my GM1913 using Tapatalk

    I tried using an Asus router to work as a hardware VPN but it was a nightmare. You have to put the hardware router on a different subnet so no other devices in the house can access it. No luck with this for me.


    At present I'm getting an openvpn client up and running via SSH terminal through directions from the surfshark website: https://support.surfshark.com/…nVPN-using-Linux-Terminal


    So with this setup I have the transmission app running through OMV 4 and then the VPN client running through OMV via SSH terminal.


    The only problem I'm facing now is trying to get openvpn to autoconnect at reboot. I will make another post and see if anyone can help with this.


    Also, I might try the docker idea with delugevpn.


    I'll let you guys know how it goes.

  • still no luck with delugevpn, i have added the PIA ovpn file in the folder to ,it is running but no web ui on :8112 X(X(


    ,
    [info] ca-montreal.privateinternetaccess.com,
    [info] ca-vancouver.privateinternetaccess.com,
    [info] de-berlin.privateinternetaccess.com,
    [info] de-frankfurt.privateinternetaccess.com,
    [info] sweden.privateinternetaccess.com,
    [info] swiss.privateinternetaccess.com,
    [info] france.privateinternetaccess.com,
    [info] czech.privateinternetaccess.com,
    [info] spain.privateinternetaccess.com,
    [info] ro.privateinternetaccess.com,
    [info] israel.privateinternetaccess.com,
    [info] Attempting to get dynamically assigned port...,
    ,
    2020-03-05 20:35:36,192 DEBG 'start-script' stdout output:,
    [info] Attempting to curl http://209.222.18.222:2000/?cl…fba02af49415d24202068c13d...,
    ,
    2020-03-05 20:35:36,963 DEBG 'start-script' stdout output:,
    [info] Curl successful for http://209.222.18.222:2000/?cl…fba02af49415d24202068c13d, response code 200,
    ,
    2020-03-05 20:35:37,047 DEBG 'start-script' stdout output:,
    [info] Successfully assigned incoming port 48399,
    ,
    2020-03-05 20:35:37,049 DEBG 'start-script' stdout output:,
    [info] Checking we can resolve name 'www.google.com' to address...,
    ,
    2020-03-05 20:35:37,088 DEBG 'start-script' stdout output:,
    [info] DNS operational, we can resolve name 'www.google.com' to address '216.58.213.132',
    ,
    2020-03-05 20:35:37,091 DEBG 'start-script' stdout output:,
    [info] Attempting to get external IP using Name Server 'ns1.google.com'...,
    ,
    2020-03-05 20:35:37,227 DEBG 'start-script' stdout output:,
    [info] Successfully retrieved external IP address 194.99.106.149,
    ,
    2020-03-05 20:35:37,635 DEBG 'watchdog-script' stdout output:,
    [info] Deluge listening interface IP 0.0.0.0 and VPN provider IP 10.31.10.6 different, marking for reconfigure,
    ,
    2020-03-05 20:35:37,643 DEBG 'watchdog-script' stdout output:,
    [info] Deluge not running,
    ,
    2020-03-05 20:35:37,650 DEBG 'watchdog-script' stdout output:,
    [info] Deluge Web UI not running,
    ,
    2020-03-05 20:35:37,658 DEBG 'watchdog-script' stdout output:,
    fo] Privoxy not running,
    ,
    2020-03-05 20:35:37,659 DEBG 'watchdog-script' stdout output:,
    [info] Deluge incoming port 6890 and VPN incoming port 48399 different, marking for reconfigure,
    ,
    2020-03-05 20:35:37,660 DEBG 'watchdog-script' stdout output:,
    [info] Attempting to start Deluge...,
    [info] Removing deluge pid file (if it exists)...,
    ,
    2020-03-05 20:35:38,170 DEBG 'watchdog-script' stdout output:,
    [info] Deluge key 'listen_interface' currently has an undefined value,
    [info] Deluge key 'listen_interface' will have a new value '10.31.10.6',
    [info] Writing changes to Deluge config file '/config/core.conf'...,
    ,
    2020-03-05 20:35:38,964 DEBG 'watchdog-script' stdout output:,
    [info] Deluge key 'outgoing_interface' currently has an undefined value,
    [info] Deluge key 'outgoing_interface' will have a new value 'tun0',
    [info] Writing changes to Deluge config file '/config/core.conf'...,
    ,
    2020-03-05 20:35:39,781 DEBG 'watchdog-script' stdout output:,
    [info] Deluge process started,
    [info] Waiting for Deluge process to start listening on port 58846...,
    ,
    2020-03-05 20:35:40,357 DEBG 'watchdog-script' stdout output:,
    [info] Deluge process listening on port 58846,
    ,
    2020-03-05 20:35:45,444 DEBG 'watchdog-script' stdout output:,
    Setting "random_port" to: False,
    Configuration value successfully updated.,
    ,
    2020-03-05 20:35:50,844 DEBG 'watchdog-script' stdout output:,
    Setting "listen_ports" to: (48399, 48399),
    Configuration value successfully updated.,
    ,
    2020-03-05 20:35:56,363 DEBG 'watchdog-script' stdout output:,
    [info] No torrents with state 'Error' found,
    ,
    2020-03-05 20:35:56,364 DEBG 'watchdog-script' stdout output:,
    [info] Starting Deluge Web UI...,
    ,
    2020-03-05 20:35:56,364 DEBG 'watchdog-script' stdout output:,
    [info] Deluge Web UI started,
    ,
    2020-03-05 20:35:56,367 DEBG 'watchdog-script' stdout output:,
    [info] Configuring Privoxy...,
    ,
    2020-03-05 20:35:56,409 DEBG 'watchdog-script' stdout output:,
    [info] Attempting to start Privoxy...,
    ,
    2020-03-05 20:35:57,423 DEBG 'watchdog-script' stdout output:,
    [info] Privoxy process started,
    [info] Waiting for Privoxy process to start listening on port 8118...,
    ,
    2020-03-05 20:35:57,434 DEBG 'watchdog-script' stdout output:,
    [info] Privoxy process listening on port 8118,


    ,

  • If you can't get VPN to work, then use a Socks5 Proxy with plain deluge instead. All decent VPN providers also give access to a socks5 proxy. Works for me for the last five years.

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • If you can't get VPN to work, then use a Socks5 Proxy with plain deluge instead. All decent VPN providers also give access to a socks5 proxy. Works for me for the last five years.

    ok ...all working and behind the vpn ...yeaaaaaaa, does deluge have a rss feed feature? thanx to all for the help

  • In the download preference I add the folder download as target... But refuse to download on that folder. ,the folder is the same that I added the into the container

    There are frequently seen problems in this area.


    The two most common ones are using a directory that is not exactly properly specified. The other is incorrect permissions on the target directory.


    You really need to post screenshots.

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • ok all good , i did to have to add a /downloads Host/volume and and add /downloads in to the deluge settings to make it work ,
    Regarding the plugin ....i have downloaded the YaRSS2-1.4.3-py2.7.egg and moved to the plugin folder but the plugin doesnt show on the list of plugins. Ideas? thanx

    Files

    • deluge.PNG

      (24.02 kB, downloaded 164 times, last: )
    • deluge 2.JPG

      (47.99 kB, downloaded 165 times, last: )
    • deluge 3.JPG

      (39.89 kB, downloaded 157 times, last: )
  • You don't say what version of Deluge you are running. Plugins for v 1.x will not run on v 2.x.

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • You don't say what version of Deluge you are running. Plugins for v 1.x will not run on v 2.x.

    Deluge version 2.0.4.dev23 ....The python version is 2.7.16 ...and I have tried all the 2.7.egg files available.
    when i select the egg files it shows ""[object FileList]" . as you can see in the photo but it will not install. thanx


    Sent from my GM1913 using Tapatalk

    Files

    • egg.JPG

      (37.33 kB, downloaded 140 times, last: )
    • egg1.JPG

      (39.09 kB, downloaded 146 times, last: )

    Edited once, last by Meguinness ().

  • Copy the egg file to the plugins directory located within the container's config directory.


    Make sure the owner and group for the egg file are the same as the PUID and PGID the container is running as.

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • Copy the egg file to the plugins directory located within the container's config directory.


    Make sure the owner and group for the egg file are the same as the PUID and PGID the container is running as.

    How do I check the owner and group of the egg files? Thanks


    Sent from my GM1913 using Tapatalk

  • I am using this container since two years, I can try to help if you still want to use Transmission (I prefer it to Deluge).
    There is something wrong with the tun device here.


    Ensure you have the following:


    - The container is NET_ADMIN
    - You have set the environment value CREATE_TUN_DEVICE=true

    OMV BUILD - MY NAS KILLER - OMV 5.x + omvextrasorg


    Core i3-8300 - ASRock H370M-ITX/ac - 8GB RAM - Sandisk Ultra Flair 32GB (OMV), 256GB NVME SSD (Docker), 3x4TB HDD (Data) - Fractal Design Node 304 - Be quiet! Pure Power 11 350W

  • How do I check the owner and group of the egg files? Thanks

    In the shell:


    ls -al filename. Like so:


    fred@omv:/srv/dev-disk-by-label-d0/docker/docker-config/deluge/plugins$ ls -al YaRSS2-1.4.3-py2.7.egg
    -rw-rw-rw- 1 fred users 1146728 Jan 7 2018 YaRSS2-1.4.3-py2.7.egg

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!