[RESOLED] Owncloud Plugin made it in 0.5.25

  • Code
    apt-get clean
    apt-get update


    Should be gone after that, maybe another reboot is neccessary.


    Greetings
    David

    "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"


    Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.

    Upload Logfile via WebGUI/CLI
    #openmediavault on freenode IRC | German & English | GMT+1
    Absolutely no Support via PM!

  • Quote from "NAST"

    The system remain in the state of wanting me to apply the configuration - which not work - it does not matter, if I enable the owncloud plugin or not.


    Even the removal/purging of the plugin does not change this - every 'apply action' results in:


    Code
    Error #4000: exception 'OMVException' with message 'Failed to execute command 'export LANG=C; invoke-rc.d 'apache2' graceful 2>&1': Syntax error on line 7 of /etc/apache2/openmediavault-webgui.d/owncloud.conf: Wrapper /var/www/owncloud/php-fcgi cannot be accessed: (2)No such file or directory Action 'configtest' failed. The Apache error log may have more information. failed! invoke-rc.d: initscript apache2, action "graceful" failed.' in /usr/share/php/openmediavault/initscript.inc:169 Stack trace: #0 /usr/share/openmediavault/engined/module/apache.inc(59): OMVSysVInitScript->invoke('graceful') #1 /usr/share/openmediavault/engined/rpc/config.inc(198): OMVModuleApache->startService() #2 [internal function]: OMVRpcServiceConfig->applyChanges(Array, Array) #3 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array) #4 /usr/share/openmediavault/engined/rpc/config.inc(247): OMVRpcServiceAbstract->callMethod('applyChanges', Array, Array) #5 [internal function]: OMVRpcServiceConfig->applyChangesBg(Array, Array) #6 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array) #7 /usr/share/php/openmediavault/rpc.inc(62): OMVRpcServiceAbstract->callMethod('applyChangesBg', Array, Array) #8 /usr/sbin/omv-engined(495): OMVRpc::exec('Config', 'applyChangesBg', Array, Array, 1)


    The /var/www/owncloud/php-fcgi permission problem will be fixed in the next version.

  • Doh, well I got around the php-fcgi issue, but can't seem to pull up the interface itself.
    Granted, I did all this before I even knew about this thread, and the in-dev state of the plugin.


    Guess I'll wait for a bit to see how it progresses.

  • With the update of OMV to 0.5.25 and the recent update of the plug in - the installation went fine - no error messages.
    But i have to say - that I have not tried much yet.


    See the recent blog entry
    http://blog.openmediavault.org/?p=1124


    After the installation - you are supposed to find owncloud here:

    Code
    http(s)://xxx.xxx.xxx.xxx/owncloud.


    where 'xxx.xxx.xxx.xxx' has to be replaced by the IP address of your OMV installation.


    NAST

  • Hello,


    Installed this just now.


    Added a Share folder called test to the OMV Owncloud GUI then went to the xxx.xxx.xxx.xxx/owncloud address. It immediately logs in as admin and I can instantly see that all users already in OMV have owncloud accounts. This is great! However even though i've given Read/Write access to one of those users for the test share... it doesn't show up in Files in Owncloud.


    Any tips on configuring this thing for certain people to be able to see certain files? :?


    The bigger issue for me also is that the users Owncloud area seems to be on the save drive as the OS. A very small drive. It needs to be possible to narrow down the usable space to only those selected in the Shares setting in the OMV GUI otherwise there is no control.

  • Hi guys,
    my compliments for the excellent work you do on OMW. This is a great system. I have tried to install in the past weeks "Owncloud" plugin and I have had some problems and I have chosen to remove it. Today I saw is available the final version of "Owncloud" and I installed it. After this I went in the "Owncloud" tab and I tried to activate it but I received this error message when I press the button to apply the new configuration:


    Code
    Failed to execute command 'omv-mkconf owncloud 2>&1': /usr/share/openmediavault/mkconf/owncloud: 187: cannot create /var/www/owncloud/config/config.php: Directory nonexistent Broken pipe: fflush()
    Error #4000: exception 'OMVException' with message 'Failed to execute command 'omv-mkconf owncloud 2>&1': /usr/share/openmediavault/mkconf/owncloud: 187: cannot create /var/www/owncloud/config/config.php: Directory nonexistent Broken pipe: fflush()' in /usr/share/openmediavault/engined/module/owncloud.inc:59 Stack trace: #0 /usr/share/openmediavault/engined/rpc/config.inc(178): OMVModuleOwnCloud->applyConfig()
    #1 [internal function]: OMVRpcServiceConfig->applyChanges(Array, Array)
    #2 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
    #3 /usr/share/openmediavault/engined/rpc/config.inc(253): OMVRpcServiceAbstract->callMethod('applyChanges', Array, Array)
    #4 [internal function]: OMVRpcServiceConfig->applyChangesBg(Array, Array)
    #5 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
    #6 /usr/share/php/openmediavault/rpc.inc(62): OMVRpcServiceAbstract->callMethod('applyChangesBg', Array, Array)
    #7 /usr/sbin/omv-engined(495): OMVRpc::exec('Config', 'applyChangesBg', Array, Array, 1)
    #8 {main}


    Any idea about why this happens?


    Thanks in advanced for your support.

  • Execute the following commands and then try again to access the OwnCloud Tab in the WebGUI. Clear your browsercache before you try to access it again!


    Code
    dpkg --purge openmediavault-owncloud
    apt-get clear
    apt-get update
    apt-get install openmediavault-owncloud


    Greetings
    David

    "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"


    Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.

    Upload Logfile via WebGUI/CLI
    #openmediavault on freenode IRC | German & English | GMT+1
    Absolutely no Support via PM!

  • Even after a purge an update I'm still seeing:



    Any other ideas ?

  • Quote from "nikcoultas"

    Even after a purge an update I'm still seeing:



    Any other ideas ?


    Does the directory /var/www/owncloud exist? If not, then you have to reinstall the owncloud package


    Code
    apt-get install --reinstall owncloud openmediavault-owncloud
  • OK.. I'm testing .5 in Vbox in hopes of moving my NAS over to it tomorrow (or maybe Monday).. I've got owncloud installed and have uploaded some small files as a test. It seems to be working fine, with 1 minor hitch. I know I've saw this mentioned, but I can't find it for the life of me.


    I created a folder "Test"(/media/uuid/Test) on my data partition. I then added this partition to the owncloud plugin shares on the OMV webui. When I upload data it goes to /var/www/owncloud/user/files instead of the "Test" folder I added in the OMV webUI. Obviously, that folder is on my OS drive, which isn't where I want uploaded data.


    Thanks

    Air Conditioners are a lot like PC's... They work great until you open Windows.


  • I think I figured it out, I didn't have the "external" plugin enabled under the apps. I'm trying to figure the rest of it out now.

    Air Conditioners are a lot like PC's... They work great until you open Windows.


  • Quote from "nikcoultas"

    Anyone having problems getting a Windows Client to connect using the App ?


    Web login is all good, buy Windows client = no no :(


    That bug is fixed, update the plugin and save the configuration in OMV again. That will create a correct config to make it work.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!