After recent update, WebGUI stuck in endless Login Loop

  • I'm running the omv on RaspberryPi4 (raspbian buster) and for the last five days I have been unable to login onto the WebGUI as it is stuck in what I can only describe as a Login Loop. (it's a thing, right?)


    Shares work just fine.

    There is plenty of space on both boot SD card and two attached HDDs (over 80% empty)

    SSH works just fine.

    WebGUI loads the login page, accepts my login credentials - then reloads the login page.


    I tried logging in with false credentials - i get a proper error, so my login works.

    I tried logging on 3 different accounts, including one with super-simple password, they all do the same login loop.

    For a while I would even get email notifications of successful logins (ha-ha-very-funny-omv :cursing:) - a feature I never enabled. They seem to have now stopped.


    Attempts to sudo apt update, sudo apt upgrade, sudo apt full-upgrade all succeed, though there are no new modules to install.


    I have restarted a couple dozen times, attempted omv-firstaid, poked around directories (but stopped, since I didn't know what I was doing).


    Very confused. Very lost. Would love the things to not be broken.

  • Worked, at least for me (OMV 5.3.8-1 on a standard x64 installation).


    The code is (formatted):

    chmod 777 /var/lib/php/sessions


    Call it from root user.


    Then, from web GUI, go to general settings and change Autologout time, as like port number.


    Thanks Apophis_93 for the solution

    Best regards

    duffr


    OMV 5.x & OMV extras on NanoPi Neo 2

    OMV 5.x & OMV extras on x64 (AMD) custom build

    Edited once, last by duffr ().

  • OMG, I was so scared, I cannot handle another full-blown installation. Thank god I found your comment. Everything works now. Thanks Apophis_93 too

    Best to you

  • QubaVR

    Added the Label resolved
  • Hey guys, new to OMV forums, and time for a first post!


    I had the same infinite login to the web interface issue after upgrading the flashmemory plugin. I tried everything without success (though the things recommended within the past day weren't known to me as the forum had been down for maintenance when I upgraded the flashmemory plugin.


    Fortunately, I had recently had a mind to geek out and figure out the clonezilla alternative kernel plugin, and had made a clone of my sda1. I couldn't have picked a better time to have done so. It saved my butt. I know some linux, but not enough to have the first idea what commands/locations etc. to try/inspect. I could SSH in successfully, but until I become linux CLI savvy [working on it, but it's a steep learning curve] I'll still probably be screwed. OMV-firstaid > reset web password did not help.


    Though I had to put a head back on my server temporarily, and boot from a rescue thumbdrive I made that had clonezilla on it, I was back up and running less than 15 minutes later. I HIGHLY recommend other people new to OMV/Debian/Linux spend the time to:


    A. Login to OMV Web management interface > OMV Extras > Kernel > Scroll down to Clonezilla > Click Install Clonezilla

    B. Go to

    > Options > Subtitles > Autotranslate > Learn OMV Clonezilla

    C. Grab a disk (USB or Small Hard Drive) > Create directory for OMV OS Clone Image Backups

    D. OMV Web Interface > OMV Extras > Kernel > Reboot to clonezilla once > Copy/paste notes for SSH login to clonezilla

    E. Wait for OMV to reboot to clonezilla > Use router DHCP table to identify OMV > SSH/Putty to OMV ip > login/pw user/live

    F. sudo clonezilla > follow instructions in video in step B to make a backup.


    Might as well backup your whole OS disk (unless you are on a single disk OMV install). Clonezilla will compress your install a lot. I picked maximum compression, and it didn't take that much extra time. Make sure you check the "Check to verify image is restorable" so you can have peace of mind.


    Side notes:

    A. I just had to do the "add the head (monitor/keyboard) back to the headless server" thing again, and restore the OMV clone backup again. I guess I must have attempted to update the flashmemory plugin a second time. Just now tonight figured out others were having the same problem. Anybody know if the bugs in the update to flashmemory plugin have been fixed? A big thank you to those who maintain the flashmemory plugin. Your efforts are not taken for granted.


    B. For those who are unfamiliar with clonezilla - If you add the head back to your OMV server (connect monitor/keyboard temporarily), and you've previously installed clonezilla through the OMVextras > Kernel controls, you don't need the rescue clonezilla thumbdrive! There is a brief screen during debian bootup that lets you pick a kernel. Just pick clonezilla live. This is awesome. Thank you to upstream debian people who made this possible! Because of clonezilla, I'll try things in linux that might break things... after I make a fresh backup!

  • The problem still existis in OMV4xx , the above fix is a permission issue caused by ....( I do not know..) but affects Nginx configuration when phpxx-fpm runs...!!! THE PROBLEM IS that if you reboot the system , you will have the same loop again.! The permissions are changing on every boot over and over again. Please check and respond. Thank you.

  • I had the same login loop problem, but unfortunately I upgraded the flashmemory plugin before I saw this fix and it made things worse: now I no longer have SSH access to my OMV device. More details in this thread: WebGUI login not working: returns to login screen after authorizing credentials


    Any ideas what went wrong? I can edit the contents of the boot drive SD card on a different system, but other than that I can't seem to do much. I'm hoping to avoid a reinstall.

  • I have changed the ower of /var/lib/php/sessions/ from root to openmediavault-webui.

    Do you have the full permissions of that folder before you changed?

    In my case the folder is owned by root:root, but world has write access. GUI is working as expected.

    drwx-wx-wt 1 root root 124 Mar 21 08:35 sessions

  • Do you have the full permissions of that folder before you changed?

    In my case the folder is owned by root:root, but world has write access. GUI is working as expected.

    drwx-wx-wt 1 root root 124 Mar 21 08:35 sessions

    I did that via ssh, and i have the full permissions after su root.

    #chown openmediavault-webgui:root sessions


    after i did this, it looks like that blow:

    drwxr-xr-x 2 openmediavault-webgui root 12K Mar 21 xx:xx sessions


    I think that you should add read permission to folder sessions.

  • I think that you should add read permission to folder sessions.

    Ah no, my OMV is working perfectly well.


    In my case world (other) has write permissions to the folder. That permission seems to be missing on your installation.


    Remains your question:


    But how this happened?

  • Hi there,

    Same big Problem here:


    - Logging in is no longer possible after the last update (OMV4 on raspberry Pi 4).

    - SSH via putty also does not work.

    - Logging via the terminal (on the TV) also not working: No home directory, logging in with HOME = /

    - Reading the SD card does not work: Path "/ var / lib / php / sessions /" does not exist


    Please, does anyone have a solution?

    THX

  • SSH terminal login:

    • Are you trying to log in as root? Login as root is disabled on RPi by default. You have to manually enable it. Search the internet how to do it; as you do not have access to the GUI of OMV and no ssh or terminal access you need to make needed changes by editing the files on the SD card on another computer.
      https://raspberrypi.stackexcha…to-login-as-root-remotely
    • Are you trying to log in as another user? User must be member of the ssh group. In addition he should be member of the sudo group so that you can give him super power

    reading the SD card

    • do you have /var/lib/php? Then you could create the sessions folder and change permissons as described above


    Could be your system is totally messed then you need to resinstal.

  • I tried all the proposals from here, and nothing saved my server. I have tears in my eyes to imagine having to reinstall all of them. Too much permission, too much to put back in place. And above all, fear of having to format certain discs. If a person has a quick fix that works. Thank you

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!