What is the method to upgrade OMV 4.x to OMV 5 (actual) ?

  • Hi,


    i 'm wondering where i could find the method to migrate/upgrade OMV 4 to 0MV 5 ? if it exists.


    I remember that i asked same question about 3.x to 4.x upgrade, but really, in this forum, even in pinned topic, i didn't found my subject.

    in 4.x, i had to reinstall from scrath all my OMV systems.


    in omv-extras plugin, upgrade does not the job i want. all my 6 systems are up-to-date, in this openmediavault 4.1.35 version. they work fine.


    Before migrating, i would like to test one of them to 5, without re-installing all.


    i read this read-me-upgrading-to-a-new-major-version-of-openmediavault and this documentation


    Do i need to upgrade Debian 1st, 9.x to 10 ?


    i apologize, if it is about my english understanding.


    thanks again.


    :)

  • thanks gderf

    So, maybe the best way, actually, to have OMV 5.x is to install OMV 5 on new partition/drive from iso/usb stick, as a new drive and then mount volumes.

    I use on most of my systems, raid card like lsi or HP. In fact, installing a new OS is not a problem for shared volumes.

    thanks.

    i will use your method on a test system.

  • i have followed those instrunctions from the other thread, first got a blank page, than purged a lot of plugins, now i am getting this, even after autoshutdown plugin was purges


    edit: had to remove omv-extras will all the plugins alltogether and reinstall them

    HP Proliant Microserver Gen8, E3-1265Lv2, 16 GB ECC RAM, 3x WD RED 3TB + 1x WD RED 4TB + Crucial MX300 525 GB SSD.

    Powered by Proxmox VE

    Edited 3 times, last by molnart ().

  • If it can help, here's the procedure i followed to upgrade from an up-to-date ovm 4 to 5.

    There's a few differences with the one i found on this forum :

    The only issue i had after that, is related to my ftp client which wasn't correctly detecting the encoding announced by proftpd, and wasn't able to enter any folder with special character in its name. I fixed it by forcing (in my ftp client) the connection to utf-8.

  • Thanks for this cook book. For me were there some little changes necessary.


  • For me were there some little changes necessary.

    Your changes will remove the keyring (as your later instructions show) and other plugins that do not need to be removed since they have 5.x equivalents. There is no need to purge every plugin. If you do, you might as well install fresh since you will have to reconfigure all of them. I also have never had to purge php7.0. The only this would need to be done is if you are using an app that relies on php7.0.

    omv 5.5.17-2 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • ryecoaaron is the reply from Shadok the correct way to upgrade from OMV 4 to OMV 5? just noticed my OMV boot/OS drive is almost full, and OMV 4 reaching EOL soon.

    OMV1: OMV 4.1.35-1 - Intel Xeon "E5530" @ 2.4 GHz - 48 GB DDR3 ECC 800 - 18.19 TB Software Raid 5


    Desktop:
    Win 10 Pro - AMD A10-5800 APU @ 3.8 GHz - 16 GB DDR 3 1866 - 600 GB

    Win 10 Pro - I7-4770k @ 4.3 GHz - 16 GB DDR 3 1600 Samsung 960 Evo 500 (X2) Raid-0

  • If it can help, here's the procedure i followed to upgrade from an up-to-date ovm 4 to 5.

    There's a few differences with the one i found on this forum :

    The only issue i had after that, is related to my ftp client which wasn't correctly detecting the encoding announced by proftpd, and wasn't able to enter any folder with special character in its name. I fixed it by forcing (in my ftp client) the connection to utf-8.


    is the purge command at the top just your installed plugins or are there more listed there that need the purge?

  • is the purge command at the top just your installed plugins or are there more listed there that need the purge?

    According to Ryecoaaron, the official correct thread is here:
    RE: OMV 5.0 - finally out! :-)

    OMV1: OMV 4.1.35-1 - Intel Xeon "E5530" @ 2.4 GHz - 48 GB DDR3 ECC 800 - 18.19 TB Software Raid 5


    Desktop:
    Win 10 Pro - AMD A10-5800 APU @ 3.8 GHz - 16 GB DDR 3 1866 - 600 GB

    Win 10 Pro - I7-4770k @ 4.3 GHz - 16 GB DDR 3 1600 Samsung 960 Evo 500 (X2) Raid-0

  • UGH...it's 14 pages long. Forums are great sometimes...but it's nice to have a synopsis instead of having to read through everything.

    The link brings you directly to the important post of the thread. It is #38.


    is the purge command at the top just your installed plugins or are there more listed there that need the purge?

    In the original post #38 the command purges all plugins that have not been ported to OMV5. They are all listed, so that you don't have to select the correct one. Just run the command as is.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!