"omv-salt deploy run nginx" rewrite ssl cert and keys with spaces

  • I upgraded from OMV4.X to 5.X using the TDL video.

    As I have a simple configuration it globally it went well.

    • ii openmediavault 5.3.8-1 all openmediavault - The open network attached storage solution
    • ii openmediavault-backup 5.1 all backup plugin for OpenMediaVault.
    • ii openmediavault-clamav 5.0.9-1 all openmediavault ClamAV plugin
    • ii openmediavault-diskstats 5.0.4-1 all openmediavault disk monitoring plugin
    • ii openmediavault-fail2ban 5.0.4 all OpenMediaVault Fail2ban plugin
    • ii openmediavault-keyring 1.0 all GnuPG archive keys of the OpenMediaVault archive
    • ii openmediavault-omvextrasorg 5.2.5 all OMV-Extras.org Package Repositories for OpenMediaVault
    • ii openmediavault-usbbackup 5.0.3-1 all openmediavault USB/eSATA backup plugin
    • and docker

    Except once I tried to connect to the web gui.

    I connected to it once and then I was kick out.

    I tried to uninstall and reinstall several component, I tried the first aid kit, and I tried the omv-salt deploy run nginx comman.

    It crashed when testing nginx config.


    After many investigation I tried these 2 command (I found it on stack overflow when looking for this SSL: error:0908F070:PEM routines:get_header_and_data:short header)


    Code
    openssl x509 -noout -text -in /etc/ssl/certs/openmediavault-XXXXXXXXX.crt
    openssl rsa -noout -text -in /etc/ssl/private/openmediavault-XXXXXXXXX.key


    These files are the ones causing the errors.

    I do not known how but during the upgrade process it appears that before each lines spaces were added which creates a get_header_and_data:short header error.

    And the omv-salt deploy run nginx rewrites openmediavault-XXXXXXXXX.key and add space at the beginning of each lines.

    I edited manually the 2 files and started nginx using systemctl start nginx.service.

    Nginx started with no error.


    After getting through this, I can now connect to the webgui.

    But it tells me that configuration has changed and ask me to apply them.

    When I do it, I got this error message ( I cannot show all the log here ) :


    Code
    Error #0:
    OMV\ExecException: Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; omv-salt deploy run nginx 2>&1' with exit code '1'



    Back to the beginning.

    For now the gui is still working but how can I finish my upgrade?


    Thx

  • I've been invastigating and I open an issue #660.


    It seems to e related to issue #352.


    I manage to bypass it deactivating ssl features and running omv-salt deploy run nginx.

    I steel have to reactivate it an see what happens.


    bye

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!