Snapraid Parity drive doesn't go to sleep

  • Hi guys,

    I have a strange issue with SnapRAID: the parity drive doesn't spindown when I issue the command to do so.

    I have a parity+content disk, and two data+content disks. There's a script which runs every day at midday, performs sync and scrub, then spins down drives using the snapraid down command. There is nothing else accessing the parity drive other than this script/snapraid.

    When this command is executed, the parity disk spins down, but then it immediately spins up again.

    So I reproduced the issue with the command snapraid down -d parity to play only with this drive, and as expected the same thing happens.

    I have installed fatrace and issued the command at the same time.

    What you see in the screenshot below are two terminal windows:

    • the upper part is the session that successfully issued the command
    • the lower part is fatrace running. I generated the first events for sanity check by updating the root folder of the drive in WinSCP ls(3328): RO /srv/dev-disk-by-label-HDD1 but the last two events are generated as you see by snapraid immediately after I send the spindown command, causing the device to spin up. Obviously after there is no more access to the drive. If I try again, the same happens.

    Did I made a mistake enabling the content flag on the parity drive? According to the SnapRAID docs I didn't, but this .lock file is accessed anyway.

    PS: The drive spins down if hd-idle is used. I took a while to write this post, and hd-idle indeed put the drive to sleep, without generating I/O access (I also left fatrace running and did not log anything)

    OMV BUILD - MY NAS KILLER - OMV 5.x + omvextrasorg

    i3 8300 - ASRock H370M-ITX/ac - 8GB RAM - Sandisk Ultra Flair 32GB (OMV), 256GB NVME SSD (Docker), 3x4TB HDD (Data) - Fractal Design Node 304 - Be quiet! Pure Power 11 350W

    Edited 2 times, last by thedarkness ().

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!