Lots of errors

  • Ok first post and its' going to be a long one so I apologize in advance.


    I wanted a simple NAS build mostly for SMB share over my local network. It would consolidate all the externals HDDS, let me rip my dvds and put them in long term storage, and make it so I could access files from any of the 4 different OS I have running. Something with RAID and maybe play with some network stuff so I can learn about it, included a media server. Played around with some really old hardware until I decided on what would fit my needs. I consider myself a Linux novice despite using it for quiet awhile. I can navigate UIs fine but struggle when it comes to terminal. That being said I had it running fine for 2 months.


    Current Hardware:

    Ancient 500gb HDD as OS drive, 2 new 8tb HDD in RAID Mirror, AMD Phenom 2 x4 955, 4gb ram, random scavenged 10 year old video card

    The old hdd was fine but the other ones I had the same age were showing bad sectors. I wanted to replace it before it became a problem.

    100 mbps router. If this works well I'll replace it with something that can do at least gbps but my ISP is so slow it doesn't make sense without a local network


    Software

    Fresh OMV4.1.31-1 installed from USB created with etcher.

    Linux 4.19.0-0.bpo.6-amd64

    OMV-Extras

    Docker

    Emby and Jellyfin containers but only run jellyfin

    Shellinabox

    Flash memory plugin (was thinking about using USB as the new OS drive until I read about how quickly they die)

    Hadn't messed with permissions or users really because I don't really understand it

    I couldn't figure out how to get a backup of the OS drive as it was when everything was working like I wanted.


    I hadn't accessed it in about a week and when I went to open the SMB it threw an error. So I tried to log in to the web gui. No luck. It wasn't even showing in the IP list. It lives in a closet and I had to do a hard shutdown so I could carry it to a monitor to see what was going on.


    On startup I had a fsck issue and told it to autofix it. Yes I know... old hard drive, continuously on, and hard shut down... totally my fault

    So now the system was at least willing to start OMV

    That brought the IP back but still no web access.

    Then I followed this guide to try and fix it. https://www.reddit.com/r/OpenM…b_interface_after_update/

    That got the web ui working again and access to shellinabox. But the SMB and jellyfin are still broken.

    Now I have issues with lots of things

    Its hit or miss if the web gui actually wants to show after I log in

    Just clicking on plugins gives

    Error #0:
    OMV\Exception: File '/var/lib/openmediavault/apt/pluginsindex.json' contains invalid JSON: No error in /usr/share/php/openmediavault/json/file.inc:226
    Stack trace:
    #0 /usr/share/openmediavault/engined/rpc/pluginmgmt.inc(73): OMV\Json\File->read()
    #1 [internal function]: OMVRpcServicePluginMgmt->enumeratePlugins(Array, Array)
    #2 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
    #3 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('enumeratePlugin...', Array, Array)
    #4 /usr/sbin/omv-engined(537): OMV\Rpc\Rpc::call('Plugin', 'enumeratePlugin...', Array, Array, 1)
    #5 {main}


    I tried to remove the flash plugin via apt-get but it just gave me an error so I decided to try every apt-get command I could and they all resulted in:

    root@openmediavault:~# apt-get remove openmediavault-flashmemory

    Reading package lists... Error!

    E: Unable to parse package file /var/lib/apt/lists/security.debian.org_debian-security_dists_stretch_updates_InRelease (1)

    E: The package lists or status file could not be parsed or opened.


    My best guess is that I ruined the entire var/lib considering I get similar errors with Update Management


    I went with OMV4 because it was better documented and not a beta hoping to avoid these kinds of problems. I wouldn't mind them as much if they had at least waited until I finished creating the off site backup drive but I stand to loose a lot of time from all the data ripping I've done. Plus moving 4.5 tb at 100 mbps is a little more than my router wants to do while handling all the other internet traffic.


    I did a lot of reading but I can't tell what is actually pertinent for me. Examples:

    OMV 4 on Debian 9 problem install

    Error when checking for updates


    Typically at this point I would have a backup of what I've done or just clean install the OS to save the head ache. As far as I can tell that isn't an option at the moment because I never successfully learned how to create a copy of the OS and my RAID drives would be wiped when I went to create it the next go around.


    So now I'm officially over my head and asking for help. What are my options and how can I fix it?


    Thanks for any insight you may have


    PS How do you make the pretty little boxes around the commands on the forum. It makes everything so much cleaner and easier to follow

  • I guess it is impossible to say in which state your system is. So I would opt for a fresh install.

    If you reinstall you will not loose your RAID (unless you do something really stupid).


    • get a new drive for the OS (could be a small SSD or a USB thumb drive)
    • disconnect your data drives
    • install OMV on the new OS drive
    • update and shutdown
    • connect your data drives
    • during next boot your RAID should be autodetected
    • mount the filesystem, it should be there (do NOT wipe the drive or try to create a new filesystem)
    • reconfigure your system (yes, you have to do it all again, there is currently no way to copy the configuration from one system to another)

    I would go for OMV5 as OMV4 is based on Debian 9 which will be EOL within this year.

  • Thanks for the help. It looks like its working. Changed it to OMV5 running from USB. As soon as I plugged it in OMV mounted the RAID like it was no big deal.


    I still get the "watchdog module" warning but it doesn't seem to cause any issues.


    Is clonezilla able to basically create an iso of the entire USB stick? I like having an option for a really quick backup.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!