[Solved] Can't connect container to host network

  • Hi

    I need some help setting up a containter with tvheadend. I use linuxservers/tvheadend and they state that if one needs multicast (I do) the container needs to connect to host network (and P flags needs to be removed).

    I didn't manage to do so in OMV 5 with portainer.

    Every time I try to join the container to host network, it says: container cannot be disconnected from host network or connected to host network.

    As I'm new to docker/portainer,any help is highly welcome.

    Kind regards


  • I tried this and it worked roughly (as macvlan does have issues with multicasts). I have it solved by stopping the container and create a copy with newly assigned host network. Seems as if I can't change network on deployed containers.

  • ne20002

    Added the Label resolved
  • ne20002

    Changed the title of the thread from “Can't connect container to host network” to “[Solved] Can't connect container to host network”.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!