[Backup Plugin] create a single img backup image for use with win32 disk imager / etcher, etc.

  • I'm not good at being overly verbose

    ... no, actually the problem was my stupidity: the timestamps of the files were clearly different, a clear indication that these files were different backups.


    With that said, I ordered the exact same SD card. Shipping took some time but I can now test whether it is possible to restore the full-disk backup to a new SD card. The outcome:

    - I cannot restore the backup with etcher (failed three times)

    - (I haven't tested w32 diskimager)

    - I manged to restore the backup with usbimager on the first try. Can boot from the restored SD card without any problems any everything looks fine


    (formated the SD card with SD Card Formater between each try).


    I don't know why I could not restore the backup with Etcher. The error message was not really revealing ("failed device / write error"). No idea what the problem was.


    I can write a guide if this is helpful.


    M

  • salgem

    Added the Label OMV 5.x
  • salgem

    Added the Label resolved
  • can write a guide if this is helpful.

    I think that would be good. Not sure why etcher failed but I think usbimager is the only thing people need. etcher is so bloated now.

    omv 6.0.8-1 Shaitan | 64 bit | 5.15 proxmox kernel | omvextrasorg 6.0.5 | kvm plugin 6.0.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • For some reasons I still do not fully understand, my OMV set-up neither could be reached over LAN nor was booting properly.


    I therefore ...

    • connected the SDD with the backups to a laptop running Ubuntu,
    • downloaded the newest version of etcher (since I was on an Ubuntu machine, I used Linux 64Bit appimage),
    • flashed the latest full backup (ddfull) to my spare sd card,
    • removed the power cable from my pi,
    • swapped the sd card with the one with the newly flashed backup,
    • powered up the pi and volia: everything is back to normal!!!

    I'm not sure why etcher now worked flawlessly compared to my dry-run in April 2020. Last try, I was using etcher on a Windows PC and now on Ubuntu. Not sure whether that was the reason. Anyways, usbimager is available on various systems (Windows, Linux, etc.).


    Many many thanks for the backup plugin: it definitely saved my say.


    Best Markus

  • not sure why etcher now worked flawlessly compared to my dry-run in April 2020.

    etcher (as every software & hardware) has defects, sometimes defects get fixed

    omv 6.0.8 (Shaitan) on RPi CM4/4GB with 64bit Kernel 5.10.63

    2x 6TB 3.5'' HDDs formatted with ext4 via 2port PCIe SATA card with ASM1061R chipset providing hardware supported RAID1


    omv 5.6.21-1 (usul) on RPi4/4GB with Kernel 5.10.63 and WittyPi 3 V2 RTC HAT

    2x 3TB 3.5'' HDDs formatted with ext4 in Icy Box IB-RD3662-C31 / hardware supported RAID1

    For Read/Write performance of SMB shares hosted on this hardware see forum here

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!