Requesting help in setting up Traefik on OMV5 + Portainer + Cloudflare

  • Hi

    I am trying to set up a way to let all my subdomains communicate via 443 and 80 externally ( exposed ), so that, all the redirecting and routing happens on the NAS.

    Thanks to DBTech, I found a nice tutorial with video. (https://dbtechreviews.com/2020…ing-your-own-domain-name/)
    But I got stuck, where I am not able to get the traefik dashboard running on the domain, It runs fine via local ip ( 192.168.x.x:8080 ), I have made sure the ports are open, and within Cloudflare SSL is set to Flexible with HTTPS on.

    Few observations,

    When I try the domain it fails with Error 522, Connection Timed Out.

    When I checked the server status of the traefik application within dashboard, it shows as if there is an error, I am not sure if that is causing it to not work correctly. And I am unaware on how to resolve it.(https://prnt.sc/rpfmnx)


    Please suggest.


    Thanks.

  • gengines

    Changed the title of the thread from “Requesting help in setting up Traefik on OMV5 + Portainer + Cloudfare” to “Requesting help in setting up Traefik on OMV5 + Portainer + Cloudflare”.
  • If you followed DBTech tutorial, even though the tutorial was done 18th March 2020, it is outdated already.

    Traefik is in fast developement, so things change frequently.


    Edit /root/traefik/docker-compose.yml

    Change image: traefik:v2.0

    to

    image: traefik:v2.2

    also a good idea to change api.insecure=false and use the domain entry point (monitor.domainname.com) instead of the local entry point (192.168.x.x:8080)

    and then restart Traefik.


    Restart vis cli

    cd traefik

    docker-compose down

    docker-compose up -d


    Restart via Portainer

    go to Containers, select (tick checkbox) traefik

    click Restart

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!