Logging in WebGUI wakes up hard drives

  • Hi,


    By simply logging in OMV's WebGUI, hard drives are woken from standby. I heavily rely on HHD standby via hd-idle to save energy and preserve drive life.


    Is this an intended behavior? I can always reproduce it, I'm running the latest version of OMV 5. Just log in, you don't have to browse anywhere or do anything else.


    I would like to avoid this. Sometimes I log in just to check logs or change shutdown/wake up configs.

    If drives are sleeping, it's because nothing is accessing them. I understand the GUI may need drives spinning, so why not wake them only when the access is really needed?

    OMV BUILD - MY NAS KILLER - OMV 5.x + omvextrasorg


    Core i3-8300 - ASRock H370M-ITX/ac - 8GB RAM - Sandisk Ultra Flair 32GB (OMV), 256GB NVME SSD (Docker), 3x4TB HDD (Data) - Fractal Design Node 304 - Be quiet! Pure Power 11 350W

  • I have a similar problem, however its only opening the File Systems tab that wakes them up.

    I also want to keep my drives spundown by default and I'm trying to figure out what wakes them.

    If I send an hdparm -Y /dev/sd[abcdefghi] command, I can set them to idle, but it dosnt last, even though Im not accessing them.


    I've also noticed that even though Ive set the drives to minimum power usage in the GUI, /etc/hdparm.conf  still has the default apm settings.

    The file comment says -


    "# This file is auto-generated by openmediavault (https://www.openmediavault.org)

    # WARNING: Do not edit this file, your changes will get lost."


    but I've yet to find out the correct place to edit to make the change permanent. (OMV5)

  • That's because collecting statistics or information displayed in the UI requieres the execution of various Linux CLI commands which might wake up the drives. To prevent that don't visit the filesystem, SMART and physical devices pages. Also remove all widgets from the dashboard.

  • If happens when you open the FIle System tab I guess it's normal. The GUI has to access that information. My complain is that happens even if I don't access hardware related information, but votdev has provided a response.


    I don't recommend using the options you see in the GUI (APM and Spindown time) as hdparm may not work with some drives. Try using hd-idle instead, here's a guide: read all comments since hd-idle is not perfect either. If you use it, disable these settings in the GUI.

    That's because collecting statistics or information displayed in the UI requieres the execution of various Linux CLI commands which might wake up the drives. To prevent that don't visit the filesystem, SMART and physical devices pages. Also remove all widgets from the dashboard.

    Thanks votdev, that's exactly what I wanted to know!
    It's totally understandable to wake up drives by visiting filesystem and other hardware related pages.

    Yeah I guess the issue is caused by the widgets because drives are woken up even if I say on the dashboard.
    I will make the change and keep you posted.

    OMV BUILD - MY NAS KILLER - OMV 5.x + omvextrasorg


    Core i3-8300 - ASRock H370M-ITX/ac - 8GB RAM - Sandisk Ultra Flair 32GB (OMV), 256GB NVME SSD (Docker), 3x4TB HDD (Data) - Fractal Design Node 304 - Be quiet! Pure Power 11 350W

  • I've some testing and I'm posting results here as might be helpful to others.

    The issue is caused by adding the widget that shows the amount of free space on drives.


    If you are using the default widgets (system information and service status) your drives will not be waken! Use the feature "Restore GUI to Defaults" to get back default widgets


    Thanks thedarkness,

    I've disabled the drive apm settings in the GUI, removed the dashboard widgets, setup hd-idle and rebooted.

    Finders crossed.

    Cool! Bear in mind that hd-idle is not super reliable because it's very very very old, in particular has one issue with standby. If you put your system in standby, when it's resumed hd-idle will not eventually resume (it will for some time then stops), meaning it won't put to sleep your drives.


    I am currently testing a hd-idle rewrite which has some improvements and fixes (including this standby issue), but I can't tell yet if really fixes the issue. In my case I've seen the issue after 10 days with the original version. I will post updates in the hd-idle thread in some days!

    OMV BUILD - MY NAS KILLER - OMV 5.x + omvextrasorg


    Core i3-8300 - ASRock H370M-ITX/ac - 8GB RAM - Sandisk Ultra Flair 32GB (OMV), 256GB NVME SSD (Docker), 3x4TB HDD (Data) - Fractal Design Node 304 - Be quiet! Pure Power 11 350W

  • Cool! Bear in mind that hd-idle is not super reliable because it's very very very old, in particular has one issue with standby. If you put your system in standby, when it's resumed hd-idle will not eventually resume (it will for some time then stops), meaning it won't put to sleep your drives.

    Cheers. My OMV server runs 24/7 so the stanby issue doesnt worry me.

    Thanks again.

  • That's because collecting statistics or information displayed in the UI requieres the execution of various Linux CLI commands which might wake up the drives. To prevent that don't visit the filesystem, SMART and physical devices pages. Also remove all widgets from the dashboard.

    I've done further testing and seems that removing widgets didn't really help.

    As soon as I hit enter when logging in, I can see my drives are waking up from standby, even If I remove widgets.

    Are there any logs I can check?

    OMV BUILD - MY NAS KILLER - OMV 5.x + omvextrasorg


    Core i3-8300 - ASRock H370M-ITX/ac - 8GB RAM - Sandisk Ultra Flair 32GB (OMV), 256GB NVME SSD (Docker), 3x4TB HDD (Data) - Fractal Design Node 304 - Be quiet! Pure Power 11 350W

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!