Fehlende Verzeichnisse/Dateien /var/spool/

  • Hallo guten Abend,


    als absoluter Linuxanfänger bin ich über ein Problem im Systemprotokoll gestolpert.

    Es scheinen Verzeichnisse zu fehlen. /var/spool/...

    Habe mittels Konsole versucht die Verzeichnisse aufzurufen, dort gibt es sie auch nicht.

    Unter /var befindet sich nur ein Verzeichnis cron.


    Sollen die Verzeichnisse manuell angelegt werden?

    Wie kann man das Reparieren?


    Schon mal vielen Dank für die Antworten!


    Gruß

    Alexander


    Anbei das Protokoll:


    Apr 4 18:15:01 omv CRON[10351]: (root) CMD (/usr/sbin/omv-mkrrdgraph >/dev/null 2>&1)
    Apr 4 18:15:01 omv CRON[10353]: (root) CMD (command -v debian-sa1 > /dev/null && debian-sa1 1 1)
    Apr 4 18:17:01 omv CRON[10869]: (root) CMD ( cd / && run-parts --report /etc/cron.hourly)
    Apr 4 18:17:01 omv postfix/postsuper[10872]: fatal: chdir /var/spool/postfix: No such file or directory
    Apr 4 18:17:02 omv cron[653]: sendmail: fatal: chdir /var/spool/postfix: No such file or directory
    Apr 4 18:17:02 omv postfix/sendmail[10873]: fatal: chdir /var/spool/postfix: No such file or directory
    Apr 4 18:17:02 omv CRON[10868]: (root) MAIL (mailed 194 bytes of output but got status 0x004b from MTA#012)
    Apr 4 18:25:02 omv CRON[11704]: (root) CMD (command -v debian-sa1 > /dev/null && debian-sa1 1 1)
    Apr 4 18:30:01 omv CRON[11751]: (root) CMD (/usr/sbin/omv-mkrrdgraph >/dev/null 2>&1)
    Apr 4 18:30:01 omv CRON[11753]: (root) CMD ([ -x /etc/init.d/anacron ] && if [ ! -d /run/systemd/system ]; then /usr/sbin/invoke-rc.d anacron start >/dev/null; fi)
    Apr 4 18:34:54 omv systemd[1]: Started Run anacron jobs.
    Apr 4 18:34:54 omv anacron[13121]: Can't chdir to /var/spool/anacron: No such file or directory
    Apr 4 18:34:54 omv anacron[13121]: anacron: Can't chdir to /var/spool/anacron: No such file or directory
    Apr 4 18:34:54 omv systemd[1]: anacron.service: Main process exited, code=exited, status=1/FAILURE
    Apr 4 18:34:54 omv systemd[1]: anacron.service: Failed with result 'exit-code'.

  • Unter /var befindet sich nur ein Verzeichnis cron.

    Unter /var befinden sich normalerweise einige Verzeichnisse, aber cron gehört nicht dazu.


    Vielleicht schaust du nochmal nach, ob das wirklich so ist.

  • Hallo macom,


    danke für die Antwort.


    Es sollte /var/spool/ sein, sorry.

    Da gabs nur ein Unterverzeichnis cron.

    Habe jetzt mal die beiden fehlenden angelegt, um zu sehen, ob er weiter meckert.

    Scheint noch etwas zu fehlen:


    Wie sollte denn die Verzeichnisstruktur richtig aussehen?

  • Bei mir sieht es so aus:


    Code
    19:52:39 root@hawk:/var/spool# ls -al
    total 0
    drwxr-xr-x 7 root root 160 Dec 21 20:49 .
    drwxr-xr-x 1 root root 152 Dec 27 18:56 ..
    drwxr-xr-x 2 root root 140 Dec 25 19:33 anacron
    drwxr-xr-x 3 root root 60 Dec 21 20:29 cron
    lrwxrwxrwx 1 root root 7 Dec 21 20:28 mail -> ../mail
    drwxr-xr-x 20 root root 400 Feb 8 19:41 postfix
    drwx------ 2 root root 40 Feb 26 2019 rsyslog
    drwxrwxrwt 2 root root 40 Sep 2 2019 samba
  • Danke.

    Habe jetzt einige Folder.

    Testversand der Mail funktioniert.

    Herzlichen Dank! :thumbup:


  • 12345

    Added the Label resolved
  • Die einzige Erklärung könnte ein defekter RAM-Riegel sein.

    Der kam allerdings erst ein paar Tage nach der Installation rein.

    Da gab es dadurch zweimal einen unerwünschten Reboot. Habe dann nochmal mit MEMTEST geprüft.

    Aber dass deswegen zwei ganze Verzeichnise auf der SSD weg ist?

    Seltsam.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!