SMB is very slow - I've tried the recommended tunnings

  • Hello

    I'm running OMV 5 on Raspbian (Raspberry Pi 4, 2GB RAM, USB3.0 dock with WD BLUE 7200 RPM) Linux raspberrypi 4.19.97-v7l+ #1294 SMP Thu Jan 30 13:21:14 GMT 2020 armv7l GNU/Linux

    My SMB speed is very bad: ~2 MiB/s up and ~22 MiB/s down... :( (My Synology's speed: average 45 MiB/s up and 75 MiB/s down.)

    How can I speed it up? I bought this setup to make a second NAS at home, with better performance...

    Have a nice day,

    Matt

  • I've done some research.

    I installed iperf3 on my Windows (client machine) and on my Raspberry (server). After running F:\iperf-3.1.3-win64>iperf3.exe -c 192.168.0.78 -t 10 -p 5201 on client, I got this: (upload speed)

    And with F:\iperf-3.1.3-win64>iperf3.exe -c 192.168.0.78 -t 10 -p 5201 -R I got this: (download speed)

    I don't know why, because I use the same switch and the same computer to connect to Synology, and that is not this slow.

  • THANK YOU!


    Yes, connecting ethernet cable to another port of the switch solved the problem...

    Gigabit connection is avaliable now! 8)


    If you would not have mentioned that, I would have never done that.

    iperf outputs:

    download

    upload

  • matefon

    Added the Label resolved
  • (Fun fact: my older NAS is getting full speed (100Mbit/s up and down) at that switch port. Maybe some compatibility problem.)

    That would still suggest that port is not capable at running at 1000, which if it's a 10/100/1000 switch would suggest the switch could be breaking down, been there before :)

  • Update: the problem cause was not the switch.

    I replaced the switch and it is doing it again.

    With my old NAS iperf3 to the Raspberry gets the maximum up and download (100 up and down).

    It seems to be an issue of my PC's ethernet.


    After a wake-up (Windows 10) the ethernet speed drops down, even without any power saving options and limitations.

    Now I'm investigating this.

  • More than in the driver i would point to the ethernet cable first and as last possibility to the NIC in your pc or, why not, in the Raspberry's NIC...


    Maybe at 100 Mbits it work because it use only 4 cables when at 1000 it must use all the 8...

  • After a wake-up (Windows 10) the ethernet speed drops down, even without any power saving options and limitations.

    Now I'm investigating this.

    This is a Windows wake up problem, have you already clicked the Ethernet card in the Device Manager, select the Power Management tab and the hack away from "Allow the computer to turn off this device to save power"?


    power_managementxgkgc.png

    [LibreELEC @ 2x RPi3, CoreELEC @ S12 Octa Core]

    [ NAS OMV 5.xx (Usul) @ NanoPI M4 ]

    [ Nextcloud 18.0.4 @ ODROID C2 ]

    [ Motioneye @ RPi4]

  • Yes, I've unchecked that and any other power management or saving settings in Device Manager (I don't know the English name of that panel).

    Also enabled only 1Gbps with full duplex...

    That should be okay

    [LibreELEC @ 2x RPi3, CoreELEC @ S12 Octa Core]

    [ NAS OMV 5.xx (Usul) @ NanoPI M4 ]

    [ Nextcloud 18.0.4 @ ODROID C2 ]

    [ Motioneye @ RPi4]

  • Yeah...

    And it is after an hour or so, but not immediately.

    For example, when I waked my PC up the connection was slow but now:

  • Maybe the Ethernet card has something, get a 1Gbit USB-Lan adapter like this and try if it gets better.

    Such an adapter is always handy to have in reserve.

    [LibreELEC @ 2x RPi3, CoreELEC @ S12 Octa Core]

    [ NAS OMV 5.xx (Usul) @ NanoPI M4 ]

    [ Nextcloud 18.0.4 @ ODROID C2 ]

    [ Motioneye @ RPi4]

  • I'll have a look at the cables then...

    But I don't get it: it works fine after boot/reboot, or after about half an hour (sometimes), but not after a sleep then wake up.

    Well, told that the cable is good and that you don't have any power saving setting enabled, then you could try to reset your network (start-settings-network and Internet-(at the bottom) reset network-reset-then reboot).

    Other possibilities if you don't resolve could be something on Windows like a virus or something corrupted on the filesystem, so, maybe you could clean your pc and check again, if nothing work then trying a new NIC is a test to do.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!