WebGUI error

  • Hello,

    I have a problem when login to the GUI :

    Thanks for help !


    PS : I'm french

  • Ah i see, the problem is you upgraded your system from OMV4 to OMV5. Please use the tags when creating the post or mention it somewhere in the text, this will safe us time.


    To fix your problem simply delete the file /var/www/openmediavault/js/omv/PluginManager.js.

  • Hi,

    I have exactly the same issue and try the same steps with the same result. But i manage to resolve it by removing the "openmediavault-omvextrasorg" and "openmediavault-openvpn" packages that i have installed and were not part of the official openmediavault repository.

    Once a removed this packages the problem got away for me.

    For removing the "openmediavault-omvextrasorg" package a had to modify the file:

    /var/lib/dpkg/info/openmediavault-omvextrasorg.postrm

    and comment the "omv-mkconf" command in line 35 as this command is not anymore in OMV5.


    Hope that this helps

  • Hello.


    Same problem here.

    Before upgrading, i took care that almost all plugins were removed (only forgot minidlna...)

    So, experienced the same messages.

    I found the problem this way:
    - connected thru SSH / root
    - lanched aptitude
    - looked for anything starting with "openmediavault-"

    That's how I tracked down the forgotten culprit :)


    To be complete. My mistake came from the fact that I had confused MiniDLNA (Extras) that i used and ForkedDAAP (main) that i didnt need anymodre. Also, I hadn't reinstalled OMV-Extras for version 5 which would have certainly saved me these inconveniences.


    Maybe it'll help.


    Regards.

  • Hi S3B,


    Why should you do ? If you have a SSH access to your OMV box, you can log into and uninstall extra plugins using aptitude for example.
    My OMV is a RAID too, and nothing went wrong this way (as long as you remove only the right packages)


    Regards

  • Ok, for me the following steps helped me to solve the error:


    apt-get purge openmediavault-omvextrasorg resolvconf

    wget -O - https://github.com/OpenMediaVault-Plugin-Developers/packages/raw/master/install | bash

    apt-get update

    apt-get upgrade

    omv-salt deploy run nginx

    omv-salt deploy run phpfpm


    I hope they are helping the others too

  • Code
    WARNING: apt does not have a stable CLI interface. Use with caution in scripts.
    openmediavault-omvextrasorg/buster,now 5.2.6 all [installed]
    openmediavault/usul,usul,now 5.3.10-1 all [installed]

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!