WebGUI error

  • Thank's but that don't work...

  • humm, i did a mistake...


    does apt list --installed |grep openmedia outputs something ?


    Regards

    I seem to have exact same issue.


    result


    openmediavault-apttool/buster,now 3.6 all [installed]

    openmediavault-diskstats/usul,usul,now 5.0.4-1 all [installed]

    openmediavault-dnsmasq/now 3.1.5 all [installed,local]

    openmediavault-downloader/buster,now 5.0 all [installed]

    openmediavault-duplicati/now 4.0 all [installed,local]

    openmediavault-keyring/usul,usul,now 1.0 all [installed]

    openmediavault-letsencrypt/now 3.4.5 all [installed,local]

    openmediavault-omvextrasorg/buster,now 5.2.6 all [installed]

    openmediavault-route/now 4.0.4-1 all [installed,local]

    openmediavault-shellinabox/now 3.4 all [installed,local]

    openmediavault/usul,usul,now 5.3.10-1 all [installed]


    I removed shellinabox - read about it else where.

    Any one else need to be removed?

  • Wow, so many plugins. I cant say which are critical or not...

    Do you really need all that stuff ? If so, I think you're a more advanced user than me.

    I wont be able to help you more. My way is to keep my systems as simple as possible, a KISS NAS :-). That was why i chose OMV.

    As you understand, i'd uninstall almost all plugins after having saved configurations. I cant say more.

  • Wow, so many plugins. I cant say which are critical or not...

    Do you really need all that stuff ? If so, I think you're a more advanced user than me.

    I wont be able to help you more. My way is to keep my systems as simple as possible, a KISS NAS :-). That was why i chose OMV.

    As you understand, i'd uninstall almost all plugins after having saved configurations. I cant say more.

    Got it solved -removed e few more and ran apt remove openmediavault-omvextrasorg


    Now it turned into another issue - No filesystem backend exists for 'zfs'. and my data raid disapeared.

  • I have the same problem


    openmediavault-anacron/buster,now 5.0.2 all [installed]

    openmediavault-apttool/buster,now 3.6 all [installed]

    openmediavault-cups/now 3.1.2 all [installed,local]

    openmediavault-diskstats/usul,usul,now 5.0.5-1 all [installed]

    openmediavault-dnsmasq/now 3.1.5 all [installed,local]

    openmediavault-downloader/buster,now 5.1 all [installed]

    openmediavault-fail2ban/buster,now 5.0.4 all [installed]

    openmediavault-forkeddaapd/usul,usul,now 5.0.1-1 all [installed]

    openmediavault-keyring/usul,usul,now 1.0 all [installed]

    openmediavault-ldap/now 4.0.6-1 all [installed,local]

    openmediavault-letsencrypt/now 3.4.5 all [installed,local]

    openmediavault-mysql/now 4.1.1 all [installed,local]

    openmediavault-nginx/now 4.0.4 all [installed,local]

    openmediavault-nut/usul,usul,now 5.1.0-1 all [installed]

    openmediavault-omvextrasorg/buster,now 5.3.3 all [installed]

    openmediavault-plexmediaserver/now 3.8.2 all [installed,local]

    openmediavault-remotedesktop/now 4.0.1 all [installed,local]

    openmediavault-shairport/usul,usul,now 5.0.1-1 all [installed]

    openmediavault-shellinabox/now 3.4 all [installed,local]

    openmediavault-teamviewerhost/buster,now 5.0 all [installed]

    openmediavault-usbbackup/usul,usul,now 5.0.4-1 all [installed]

    openmediavault-webdav/now 4.0 all [installed,local]

    openmediavault-wol/buster,now 3.4.2 all [installed]

    openmediavault/usul,usul,now 5.5.2-1 all [installed]

  • Did you run the script from the post?

    wget -O - https://github.com/OpenMediaVault-Plugin-Developers/installScript/raw/master/upgrade4to5 | sudo bash

    On a test OMV 4.x system with the flashmemory plugin installed, this is all I did to upgrade it to OMV 5.x (as root):


    I changed this to a script (no changes but eliminates the cut&paste issues:

    wget -O - https://github.com/OpenMediaVault-Plugin-Developers/installScript/raw/master/upgrade4to5 | sudo bash


    reboot


    apt-get purge openmediavault-omvextrasorg resolvconf

    wget -O - https://github.com/OpenMediaVault-Plugin-Developers/packages/raw/master/install | bash

    apt-get update

    apt-get dist-upgrade

    omv-salt deploy run nginx

    omv-salt deploy run phpfpm

    apt-get install usrmerge



    Clear your browser cache after upgrading!



    I use this one to upgrade.and the error is


    ============

    Error #0:

    OMV\Exception: Failed to open include file 'js/omv/PluginManager.js'. in /usr/share/php/openmediavault/controlpanel/controlpanelabstract.inc:42

    Stack trace:

    #0 /usr/share/php/openmediavault/controlpanel/controlpanelabstract.inc(70): OMV\ControlPanel\ControlPanelAbstract->scanFiles('js/omv/PluginMa...', Array)

    #1 /usr/share/php/openmediavault/controlpanel/controlpanelabstract.inc(87): OMV\ControlPanel\ControlPanelAbstract->scanFiles('js/omv/PluginMa...', Array)

    #2 /usr/share/php/openmediavault/controlpanel/controlpanelabstract.inc(90): OMV\ControlPanel\ControlPanelAbstract->scanDir('js/omv/module/a...', Array, true)

    #3 /usr/share/php/openmediavault/controlpanel/controlpanelabstract.inc(90): OMV\ControlPanel\ControlPanelAbstract->scanDir('js/omv/module/a...', Array, true)

    #4 /usr/share/php/openmediavault/controlpanel/controlpanelabstract.inc(90): OMV\ControlPanel\ControlPanelAbstract->scanDir('js/omv/module/a...', Array, true)

    #5 /usr/share/php/openmediavault/controlpanel/administration.inc(54): OMV\ControlPanel\ControlPanelAbstract->scanDir('js/omv/module/a...', Array, true)

    #6 /usr/share/php/openmediavault/controlpanel/controlpanelabstract.inc(206): OMV\ControlPanel\Administration->getJavascriptIncludes()

    #7 /var/www/openmediavault/index.php(41): OMV\ControlPanel\ControlPanelAbstract->render()

    #8 {main}

    ===================

  • Folks, I managed to get this fixed more or less reasonably. Everyone telling its incompatible plugins and mine was omv-cups.


    I fount it doing


    grep -rli PluginManager.js /var/www


    It will point you to the .js that incluses the inexistent PluginManager.js - so is just remove this plugin. To check what is installed, just:


    dpkg -l | grep openmediavault


    Also, most of plugins will fail when you do apt purge openmediavault-<plugin>. Just edit the postrm (apt tells you the file failed) and comment the omv-makeconf (Or something like this - another user told this before in this post).



    For me, this fixed the issue.

  • Think you !

    but the new problem is "NGINX and MySQL Plugins in OMV5" like NGINX and MySQL Plugins in OMV5

    ;(

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!