Raspberry Pi Webdav OMV5

  • Hi All,


    I am very new to this and found OMV amazing.


    I have been using OMV4 for some time with WebDav.


    I migrated to OMV5 and tried using docker to install WebDav with no success. Spent many hours Googlingand trying different dockers.


    OMV4 worked like a dream.


    I erased my image of OMV4 and replaced with OMV5.


    Now I have now way to go back as OMV4 images for rpi have been removed.


    can any one help with instalaltion of working Webdav on OMV5?


    Or point me to an image of OMV4.


    Can the producers of OMV5 please consider putting WEbdav plugins back?


    Regards

  • Have you tried this image?

    https://hub.docker.com/r/ugeek/webdav


    Code
    docker run --name webdav --restart=unless-stopped -p 88:80 -v /srv/dev-disk-by-label-label/webdav:/media -e USERNAME=webdav -e PASSWORD=webdav -d ugeek/webdav:arm


    Change the "/srv/dev-disk-by-label-label/webdav" part to the actual absolute path on your server.


    I have no RPi, but works fine on my HC2.

  • Can the producers of OMV5 please consider putting WEbdav plugins back?

    Nope. That is a terrible plugin (code-wise ). Docker is a much better choice. macom's tip should work well.

    omv 5.5.0 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Sorry about the delay in coming back.


    I tried a few other dockers (node-red, grafana, cloud-commander) and they worked OK. My experience so far, I think Docker is a great concept but it is very technical and it is not easy to find a working image.


    Found an old version of omv4 and using plugin Webdav installed in less than 5 minutes. I am reasonably capable but so far I have, spent many hours trying to make Webdav work on OMV5 with a rpi 4, but I do want to move to latest version of OMV5 so keep trying.


    Hopefully if I can get it working my experience will help others.


    So I have done a complete fresh install of OMV 5 to test Webdav to ensure nothing is broken. Only one shared folder. No other file share services running.


    Having followed the advice and change to point to my shared folder I get the same failure.


    Regards


    Details below:


    Command used:

    docker run --name webdav --restart=unless-stopped -p 88:80 -v /srv/dev-disk-by-label-WEBDAV/webdav:/media -e USERNAME=webdav -e PASSWORD=webdav -d ugeek/webdav:arm


    Absolute path to local drive:

    /srv/dev-disk-by-label-WEBDAV/webdav


    Error message:

    OCR runtime failure create failed container linux.go:349

    continer process caused "exec:\"docker\":

    docker exec file not found in $path": unknown


    Logs:

    Device:

    2020-04-12 10:03:21containerContainer Webdav deleted
    2020-04-12 10:03:21volumeVolume 3cabab4f8bbce59eececb00fb3b5009b37f936617b116c29dfb1e690172834e8 deleted
    2020-04-12 10:03:21volumeVolume 3cabab4f8bbce59eececb00fb3b5009b37f936617b116c29dfb1e690172834e8 unmounted
    2020-04-12 10:03:21networkContainer disconnected from bridge network
    2020-04-12 10:03:19volumeVolume 3cabab4f8bbce59eececb00fb3b5009b37f936617b116c29dfb1e690172834e8 mounted
    2020-04-12 10:03:19networkContainer connected to bridge network
    2020-04-12 10:03:19containerContainer Webdav created
    2020-04-12 10:03:19volumeVolume 3cabab4f8bbce59eececb00fb3b5009b37f936617b116c29dfb1e690172834e8 created
    2020-04-12 10:03:19imageImage ugeek/webdav:arm pulled
    HostnameOMV5
    OS Informationlinux armv7l Raspbian GNU/Linux 10 (buster)
    Kernel Version4.19.97-v7l+
    Total CPU4
    Total memory2 GB
  • Puoi pubblicare l'output completo?

    Hai modificato il percorso che inizia con / srv / ...?

    Salve Macon, ho aperto questo post perchè ho lo stesso problema di piuseralan ma poi non avete completato la discussione, siete riusciti a risolvere? Come?

    Ad esempio, io ho OMV5 con docker, portainer, nextcloudpi, e tutto funziona ma non riesco a trovare un aiuto per utilizzare webdav. Qualcuno riesce a darmi un consiglio?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!