OMV 5.0 installation on RPI 2 !

  • Hello,


    First of all, many thanks for the job done on OMV 5.0 ;)


    I followed the guide here: https://github.com/OpenMediaVa…ing_OMV5_on_an%20R-PI.pdf


    It works and I can logged on the web gui.


    After that, I tried to update and OMV found 4 updates:

    binutils rpi2

    binutils-arm-linux-gnueabihf rpi2

    binutils-common rpi2

    libbinutils rpi2


    I started the update but the following message at the end:


    Reading package lists...

    Building dependency tree...

    Reading state information...

    Calculating upgrade...

    The following packages have been kept back:

    binutils binutils-arm-linux-gnueabihf binutils-common libbinutils

    0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.

    Terminé...


    I cannot update. What can I do ?


    The system information board on the main screen is empty too.


    Thanks

    csev

  • Try the apt clean button in omv extras. I just kicked off an upgrade on my rpi2b running omv 5 and nothing was held back.

    omv 5.5.1 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Try the apt clean button in omv extras. I just kicked off an upgrade on my rpi2b running omv 5 and nothing was held back.

    Thanks reyecoaaron.

    I tried 2 times. First one = FAILED but second one it works after an APT-GET UPDATE too.


    I cannot activate SAMBA: "internal server error"


    {"response":null,"error":{"code":0,"message":"The property 'localmaster' does not exist in the model 'conf.service.smb'.","trace":"OMV\\AssertException: The property 'localmaster' does not exist in the model 'conf.service.smb'. in \/usr\/share\/php\/openmediavault\/config\/configobject.inc:71\nStack trace:\n#0 \/usr\/share\/php\/openmediavault\/config\/configobject.inc(186): OMV\\Config\\ConfigObject->assertExists('localmaster')\n#1 \/usr\/share\/php\/openmediavault\/config\/configobject.inc(271): OMV\\Config\\ConfigObject->set('localmaster', true, true)\n#2 \/usr\/share\/php\/openmediavault\/config\/configobject.inc(233): OMV\\Config\\ConfigObject->setFlatAssoc(Array, true, false)\n#3 \/usr\/share\/openmediavault\/engined\/rpc\/smb.inc(81): OMV\\Config\\ConfigObject->setAssoc(Array)\n#4 [internal function]: Engined\\Rpc\\Smb->setSettings(Array, Array)\n#5 \/usr\/share\/php\/openmediavault\/rpc\/serviceabstract.inc(123): call_user_func_array(Array, Array)\n#6 \/usr\/share\/php\/openmediavault\/rpc\/rpc.inc(86): OMV\\Rpc\\ServiceAbstract->callMethod('setSettings', Array, Array)\n#7 \/usr\/sbin\/omv-engined(537): OMV\\Rpc\\Rpc::call('SMB', 'setSettings', Array, Array, 1)\n#8 {main}"}}


    Thanks

  • When I click on NOTIFICATION section I had the following error:



    details are:


    {"response":null,"error":{"code":0,"message":": The value [] is not an object.","trace":"OMV\\Json\\SchemaValidationException: : The value [] is not an object. in \/usr\/share\/php\/openmediavault\/json\/schema.inc:391\nStack trace:\n#0 \/usr\/share\/php\/openmediavault\/json\/schema.inc(285): OMV\\Json\\Schema->validateObject(Array, Array, '')\n#1 \/usr\/share\/php\/openmediavault\/json\/schema.inc(257): OMV\\Json\\Schema->validateType(Array, Array, '')\n#2 \/usr\/share\/php\/openmediavault\/rpc\/paramsvalidator.inc(59): OMV\\Json\\Schema->validate(Array)\n#3 \/usr\/share\/php\/openmediavault\/rpc\/serviceabstract.inc(179): OMV\\Rpc\\ParamsValidator->validate('[]')\n#4 \/usr\/share\/openmediavault\/engined\/rpc\/notification.inc(149): OMV\\Rpc\\ServiceAbstract->validateMethodParams(Array, 'rpc.common.obje...')\n#5 [internal function]: Engined\\Rpc\\Notification->get(Array, Array)\n#6 \/usr\/share\/php\/openmediavault\/rpc\/serviceabstract.inc(123): call_user_func_array(Array, Array)\n#7 \/usr\/share\/php\/openmediavault\/rpc\/rpc.inc(86): OMV\\Rpc\\ServiceAbstract->callMethod('get', Array, Array)\n#8 \/usr\/sbin\/omv-engined(537): OMV\\Rpc\\Rpc::call('Notification', 'get', Array, Array, 1)\n#9 {main}"}}


    thanks

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!