HDD Failure with UnionFS, Emergency Plan preparation.

  • Dear all,


    I'm making some tryout before migrating my old Linux server to OMV 5 + UnionFS.


    Config : Proxmox VM OMV5 with latest build, UnionFS plugin. System is cold backuped thanks to Proxmox everyday within 5minutes. One UnionFS named 75015001500 built with x3 old test HDD 750GB and 2x 1500GB (total 3750GB). The config works well and access within SAMBA works in minutes.


    Now comes the test: I removed one HDD, the 750Go one physically and detach the reference from the OMV VM.

    Of course OMV won't work anymore.


    My goal is to make OMV works again without the 750go hdd, as my use case is that the 750GB is totally dead.



    What is to be done to recover the unionfs share with only the data stored on the 2x remaining 1500GB drives please ?

  • yakelkun

    Changed the title of the thread from “HDD Failure with UnionFS” to “HDD Failure with UnionFS, Emergency Plan preparation.”.
  • Some directions TO BE CONFIRMED:


    WARNING : BACKUP BACKUP and TEST your BACKUP, meaning do some restore to validate and train.

    Using virtualization is a great help to have baremetalrestore solution !! I backup the OMV System disk and the HDD containing userdirectory. Both are virtual HDD.



    in/etc/fstab :

    Remove reference to the missing disk


    in /srv

    Removing directory reference to the missing disk /dev-disk-by-label-HDD.name



    in config.xml :

    Paragraphs

    Mount begining with <mntent> ........ </mntent> containing HDD name, NOTE the corresponding UUID !!!

    Sharefolder begining <sharefolder> ........ </sharefolder>

    Unionfilesystem begining <unionfilesystems> ........ </unionfilesystems>

    Usermanagement, if you use the HDD to store userdirectory <usermanagement> ....... <usermanagement/>


    The first x2 are easy fix, I just remove the prargraphs refering to the missing HDD,

    For the unionfs, you have to remove reference to the UUID above, and I'm not sure it'll work.


    Usermanagement the user directory to default :

    <homedirectory>

    <enable>0</enable>

    <sharedfolderref></sharedfolderref>

    </homedirectory>


    Your help and suggestion will be highly appreciated.


    To be continued.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!