haugene/transmission-openvpn keeps restarting infinitely

  • I ordered the following kit to get a simple NAS/torrent downloading machine working. It's a nanoPi with a custom NAS dock.


    https://www.friendlyarm.com/in…ct&path=85&product_id=222





    I have installed docker on it and I am trying to build a container transmission with VPN using the following but the container keeps restarting:


    docker run --cap-add=NET_ADMIN --device=/dev/net/tun --name=trans-vpn --network=mynet -d \

    -v /sharedfolders/appdata/trans-vpn/data:/data:rw \

    -v /sharedfolders/appdata/trans-vpn/config:/config:rw \

    -v /sharedfolders/appdata/trans-vpn/completed:/completed \

    -v /etc/localtime:/etc/localtime:ro \

    -e CREATE_TUN_DEVICE=true \

    -e OPENVPN_PROVIDER=PIA \

    -e OPENVPN_CONFIG=CA\ Toronto \

    -e OPENVPN_USERNAME=username \

    -e OPENVPN_PASSWORD=password \

    -e WEBPROXY_ENABLED=false \

    -e LOCAL_NETWORK=192.168.1.0/24 \

    -e PUID=998 \

    -e PGID=100 \

    -e TRANSMISSION_WEB_UI=transmission-web-control \

    -e OPENVPN_OPTS="--inactive 3600 --ping 10 --ping-exit 60" \

    -e TRANSMISSION_RPC_HOST_WHITELIST="127.0.0.1,192.168.*.*" \

    -e DOCKER_LOG=true \

    --log-driver json-file \

    --log-opt max-size=10m \

    --restart=always \

    -p 9091:9091 \

    haugene/transmission-openvpn:latest-armhf



    Also, I can't see any logs. I have also tried docker logs but from what I read, it only outputs during execution. I have been bouncing from forum to forum without any luck. Any help would be great!

  • muata

    Changed the title of the thread from “haugene/transmission-openvpn keeps restarting on” to “haugene/transmission-openvpn keeps restarting infinitely”.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!