Greyhole Manual Install Not Playing Nice - May not require a plugin

  • In my opinion Greyhole is a wonderful storage pooling and drive level local redundancy tool. OMV, I gather, used to have a Greyhole plugin that is no longer developed or compatible with the latest versions of OMV.


    Not to worry. GH has a manual install option and works very well on Debian.


    Over the last few days getting to know OMV (which I love, and want to migrate to from Amahi). I got it working, but have noticed a few things that conflict. I wonder, rather than maintaining the plugin, if there was some way to address these issues, so at least a manual install of Greyhole persists in the background without getting its config borked.


    I logged an issue here for Greyhole:

    https://github.com/gboudreau/Greyhole/issues/228


    The main issue is OMV is overwriting the samba config that GH requires to work. Namely...


    [global]

    unix extensions = no

    wide links = yes


    [share_name]

    dfree command = /usr/bin/greyhole-dfree

    vfs objects = greyhole


    And since symlinks are not displaying on my samba shares after Greyhole distributes copies of files across different physical drives in the pool (i.e. Greyhole runs and files become unavailable over the network). Possibly some combination of...


    [global]

    allow insecure wide links = yes


    [share]

    follow symlinks = yes

    wide links = yes


    If OMV could have areas of samba config that don't get overwritten (I noticed it happens when creating or editing samba shares) a manual install of Greyhole may play nice, and not require plugin development. Alternatively, OMV might have a section for parameters that rewrite custom samba config back in should the config file have to be rewritten. Then custom GH config lines could be managed through the OMV GUI.

  • square_eyes

    Changed the title of the thread from “Greyhole Manual Install Not Playing Nice” to “Greyhole Manual Install Not Playing Nice - May not require a plugin”.
  • So in that section I set the below. But none of that exists in /etc/samba/smb.conf even after saving/applying and rebooting the machine...


    [global]

    unix extensions = no

    wide links = yes


    [photos]

    dfree command = /usr/bin/greyhole-dfree

    vfs objects = greyhole

    allow insecure wide links = yes


    [videos]

    dfree command = /usr/bin/greyhole-dfree

    vfs objects = greyhole

    allow insecure wide links = yes

  • I pasted your stuff into mine, hit save and apply, and it all wound up in my /etc/samba/smb.conf file.

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • Never mind. Figured out you don't need the tags/headers.


    Global extra options go in Settings, Extra Options. Share specific extra options go in Extra Options in the settings for each share.


    Edit: Gah! The folder/share level extra option


    vfs objects = greyhole


    Breaks the share :/


    They are inaccessible over the network until I remove those options in the GUI.

    My whole samba config is here: https://github.com/gboudreau/G…28#issuecomment-613814693

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!