Virtualisierung mit KVM oder virtualbox

  • Hallo ich habe seit Jahren OMV mit virtualbox installiert. Jetzt habe ich mir überlegt den Server neu zu machen, mit der aktuellen Version aber da wird virtualbox nicht mehr unterstützt sondern Cockpit mit KVM. Ich habe jetzt eine neue VM erstellt aber leider komme ich nicht ins eigene Netzwerk, die Schaltflächen sind ausgergraut. Kann mir vielleicht auf die Sprünge helfen, wie ich das configurieren muss, Danke. In einem Forum Beitrag Guide: Virtualbox 6.x on OMV5 and Debian 10.x habe ich gelesen das man Virtualbox auch noch installieren könnte, macht das Sinn oder wird das bei Updates in der Zukunft Probleme machen? Danke für eure Hilfe und einen schönen Samstag.


    ----------------------------------


    Hello I have been installing OMV with virtualbox for years. Now I thought about rebuilding the server, but with the current version virtualbox is no longer supported but Cockpit with KVM. I have now created a new VM but unfortunately I can't access my own network, the buttons are greyed out. Maybe this can help me to find out how to configure it, thanks. In a forum post Guide: Virtualbox 6.x on OMV5 and Debian 10.x I read that Virtualbox can be installed, does that make sense or will it cause problems with updates in the future? Thanks for your help and have a nice Saturday.

  • same here.


    Ich würde mich über ein Lösung sehr freuen. Ich kann auf Buster kein dnsmasq installieren, da Port 53 durch systemd-resolved belegt wird.


    I would be very happy about a solution. I can't install dnsmasq on Buster because port 53 is occupied by systemd-resolved.

  • In a forum post Guide: Virtualbox 6.x on OMV5 and Debian 10.x I read that Virtualbox can be installed, does that make sense or will it cause problems with updates in the future? Thanks for your help and have a nice Saturday.

    Virtualbox is not longer supported in Debian 10 buster and so in omv 5. Without a support in the future you have to update virtualbox and maybe phpvirtualbox manuelly and that can be a problem with Debian package dependecies. I have installed Virtualbox with the guide, but ist don‘t work. I hat a problem with the webfrontend and phpvirtualbox. At the end I have new installed omv.

  • Hi,


    I wrote the guide for installing Virtualbox 6 on OMV5, and I had no problems installing it using the guide. I'm curious what went wrong, if there is something missing in the guide i would like to add it offcourse.


    Oracle supports Virtualbox on Debian 10 Buster so i don't think that there will be any problem. When installed, the OMV updater wil recognise that and updates are shown and installable. I just updated from 6.1.2 to 6.14 without any problems.


    PHP-Virtualbox has to be updated manually indeed, but that is nothing more than stopping the service, updating the files and starting the service again.


    When i installed Virtualbox 5 on OMV 4 with the plugin it gave me al sorts of problems. The one I wanted to resolve is when I shutdown OMV, the virtualmachines have to be in Saved State before OMV shuts down. This was not the case in OMV4 with the Virtualbox plugin. With Virtualbox 6 and OMV 5 installed according to the guide, the machines are all in saved state before OMV shuts down, and get started when OMV boots again.


    Again, if you have a problem installing Virtualbox 6 or PHPVirtualbox please let me know, I am happy to assist.


    Regards,


    Roru69

  • I have updated from omv4 to omv 5 and try to install Virtualbox and phpvirtualbox. Maybe that cut be the problem. In the near future I will try it again with the fresh omv 5 Installation. I will keep you informed.

  • I cannot install shared folders in phpvirtualbox. Everything else runs flawlessly

    VBoxGuestAdditions_6.1.6.iso is installed on the guest.


    Everytime i try, i get:

    Code
    There was an error obtaining the list of registered virtual machines from VirtualBox. Make sure vboxwebsrv is running and that the settings in config.php are correct.
    The list of virtual machines will not begin auto-refreshing again until this page is reloaded.
    HTTP error: 500 Internal Server Error
    Details

    The Details are:


    readyState: "4"

    responseText: ""

    status: "500"

    statusText: "Internal Server Error"


    The nginx error is:

    Code
    2020/04/22 21:31:36 [error] 1457#1457: *288 FastCGI sent in stderr: "PHP message: PHP Fatal error: Uncaught ArgumentCountError: Too few arguments to function IMachine::createSharedFolder(), 4 passed in /var/www/phpvirtualbox/endpoints/lib/vboxconnector.php on line 2244 and exactly 5 expected in /var/www/phpvirtualbox/endpoints/lib/vboxServiceWrappers.php:4524
    Stack trace:
    #0 /var/www/phpvirtualbox/endpoints/lib/vboxconnector.php(2244): IMachine->createSharedFolder('sharedfolders', '/sharedfolders', true, false)
    #1 /var/www/phpvirtualbox/endpoints/lib/vboxconnector.php(951): vboxconnector->remote_machineSave(Array)
    #2 /var/www/phpvirtualbox/endpoints/api.php(316): vboxconnector->__call('machineSave', Array)
    #3 {main}
    thrown in /var/www/phpvirtualbox/endpoints/lib/vboxServiceWrappers.php on line 4524" while reading response header from upstream, client: ::ffff:192.168.1.8, server: phpvirtualbox-webgui, request: "POST /endpoints/api.php HTTP/1.1", upstream: "fastcgi://unix:/run/php/php7.3-fpm-phpvirtualbox-webgui.sock:", host: "192.168.1.20:8080", referrer: "http://192.168.1.20:8080/"
  • I had the same problem where NETWORK was greyed out - and the resolution for me was in here:
    RE: About the version of Cockpit

    I updated cockpit and all cockpit related from here manually:
    http://ftp.us.debian.org/debian/pool/main/c/cockpit/

    to get installed version of cockpit , use cmd:
    dpkg -l | grep cockpit

    and here is the output:


    dpkg -l | grep cockpit

    ii cockpit 188-1 all Web Console for Linux servers

    ii cockpit-bridge 217-1~bpo10+1 amd64 Cockpit bridge server-side component

    ii cockpit-docker 214-1 all Cockpit user interface for Docker containers

    ii cockpit-machines 215-1 all Cockpit user interface for virtual machines

    ii cockpit-packagekit 215-1 all Cockpit user interface for packages

    ii cockpit-storaged 215-1 all Cockpit user interface for storage

    ii cockpit-system 188-1 all Cockpit admin interface for a system

    ii cockpit-ws 217-1~bpo10+1 amd64 Cockpit Web Service

  • At he moment I get another error. After installation of a debian 10 in VirtualBox I can't login in the phpvirtualbox web. After login with username and Password, this error message appears:

    Could not connect to host (http://127.0.0.1:18083/)

    Details:

    Exception Object

    (

    [message:protected] => Could not connect to host (http://127.0.0.1:18083/)

    [string:Exception:private] =>

    [code:protected] => 64

    [file:protected] => /var/www/phpvirtualbox/endpoints/api.php

    [line:protected] => 134

    [trace:Exception:private] => Array

    (

    )


    [previous:Exception:private] =>

    )


    Edit:

    phpvirtualbox web is running again. Portainer is running on the OMV 5 box and use port 9100. I changed in /var/www/phpvirtualbox/config.php the remote server ports from 9000 - 9100 to 9100 - 9200.

      var $vrdeports = '9100-9200';    

    and the login is possible again.


    Nice to hear it is working! Do you also use the backup script which I Posted in the second post?

    I will test it and will give you a feedback in the next few days.

  • Jupp. still the same problem ... :-(

  • Question: Did you setup portainer before installing virtualbox? I did't experience these errors during install. Just the fact that i couldn't connect to the VRDE's. I always could login to PHPVirtualbox, just remote desktopping to a virtual machine didn't work.


    I wil add your findings in the Guide, So if other people run into it they are aware that this could happen..

  • Question: Did you setup portainer before installing virtualbox? I did't experience these errors during install. Just the fact that i couldn't connect to the VRDE's. I always could login to PHPVirtualbox, just remote desktopping to a virtual machine didn't work.


    I wil add your findings in the Guide, So if other people run into it they are aware that this could happen..

    I set up OMV 5 and then Portainer. After that I follow your installation instructions and everything works fine with Virtualbox and PHPVirtualbox. Then I install a virtual machine and change the Remote Display Port to 9100 - 9200 for this virtual machine in the settings before starting the installation. Then I started the installation via the remote display port without any problems. After the installation I log off from the PHPVirtualbox website. The next time I log in I get the error described in post #13. After changing the port to 9100 -9200 in the config.php the login works again.


    Remote desktop works for me after change the Net Address from 127.0.0.1 to the IP of the OMV 5 Server.

  • Question: Did you setup portainer before installing virtualbox? I did't experience these errors during install. Just the fact that i couldn't connect to the VRDE's. I always could login to PHPVirtualbox, just remote desktopping to a virtual machine didn't work.


    I wil add your findings in the Guide, So if other people run into it they are aware that this could happen..

    Hey, I also had Portainer installed before running through the Virtualbox installation.

    For me the process worked fine and I can access PHPVirtualBox + I can also create VMs, however I cannot connect via RDP nor the Console.


    I just found out, that even the "vboxmanage list vms" does not show any of the VMs that I created using PHPVirtualBox.... why is there any disconnect?


    I'm now about to create a new VM completely from scratch via vboxmanage CLI to see what difference it makes... also the VM created via CLI does not show up in PHPVirtualBox....


    Any ideas?

  • For RDP to work you will have to change the port range in PHPVirtualbox -> Settings of the virtualboxmachine -> Display and choose the Remote Display tab. change the port range to 9100 - 9200. The machine has to be powered down to do this.


    For the console to work: Change the Net Address in the Remote Display tab from 127.0.0.1 to the real IP Address of the Hostmachine, then you can use the Console.


    To use the "vboxmanage list vms" command in CLI you first have to change user to vbox. eg. "su vbox". Then use the command "vboxmanage list vms". You should be able to see the machines that you have added in PHPVirtualbox. Virtualbox is running under user "vbox"


    Regards, Roru69

  • ***Did an installation from scratch after I tried around 15 times without success (OMV upgrade and VB6 installation) and now everything is working.***


    ---- obsolete -->

    Hi,


    I tried to install VBOX 6 on OMV5 following your guide BUT I came from an OMV4 installation with VBOX 5 already installed.

    Now I am stuck with an error which breaks my OMV installation (502 bad gateway, no way to fix it, although clis is still working) which is:

    Job for php7.3-fpm.service failed because the control process exited with error code.


    Cannot get it to work. Do you have any advise?


    Best Regards,

    suprstar


    PS: I tried twice already as I have an image which I can restore


    <--- obsolete ---

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!