OMV5 on Proxmox memory detection problem

  • Hi!

    I've OMV5 fresh installation on Proxmox VE VM with 4Gb of ram assigned.

    The problem is that OMV5 only detects or run with 1Gb.

    I've changed the memory configuration on Proxmox VE but it don't show changes on OMV5.

    I've also tried disabling ballooning but it ir equal.

    ¿any suggestions to try?


  • Hi!

    After try some things i found the problem.

    I've activates hot-plug memory and cpu on Proxmox VE and not configured on OMV5.

    Also i try activate on OMV5 but i can't because required modules are not compiled.

    Here Proxmox VE requirements for future features if OMV developers want ;).


    Linux Guests notes

    kernel modules needed

    you need to have 2 modules loaded in your linux guest

    #modprobe acpiphp
    #modprobe pci_hotplug

    cpu && memory hotplug

    you need a recent kernel > 3.10

    and a udev rules, to auto enable cpus or memory hotplugged

    you can add a file:


    SUBSYSTEM=="cpu", ACTION=="add", TEST=="online", ATTR{online}=="0", ATTR{online}="1"
    SUBSYSTEM=="memory", ACTION=="add", TEST=="state", ATTR{state}=="offline", ATTR{state}="online"

    for linux kernel >= 4.7,

    you don't need the udev rule for memory hotplug, you only need to add this kernel parameter at boot:



    Thank you for your work.

    Best regards.

  • rolling

    Added the Label resolved

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!