Login Screen Keeps Reloading

  • This morning I started having issues with my windows computers and I think I tracked it down to my OMV server needing a reboot, so I rebooted my OMV server. I have had OMV up and running reliably for many months. At the moment I can SSH into my OMV server, but now when I try to login using the web gui OMV keeps looping back to the login screen. My login is correct, when I enter an incorrect login I get the error message.

    Any ideas on how I can access the web gui on my windows computer? Is there anything I can do through the SSH? If I recall it's not possible to access the web gui on the server itself.

  • I hope I didn't screw things up. I used omv-firstaid and removed the cache and now when I login I get an error #0 with an exception.


    Code
    OMV\Exception: Failed to read file '/var/cache/openmediavault/cache.omv\controlpanel\login_js.json' (size=0). in /usr/share/php/openmediavault/json/file.inc:207
    Stack trace:
    #0 /usr/share/php/openmediavault/json/file.inc(223): OMV\Json\File->getContents()
    #1 /usr/share/php/openmediavault/controlpanel/controlpanelabstract.inc(173): OMV\Json\File->read()
    #2 /var/www/openmediavault/index.php(46): OMV\ControlPanel\ControlPanelAbstract->render()
    #3 {main}
  • I think I found the problem, no disk space (line 5 of code below). Any recommendations on how to clean drive space?? This shouldnt happen, I have ample disk space and all my dockers save their data on a /srv folder. Is there any way to list the sizes of folders on a given drive so that I can hunt for the heavy usage??


    Found out it was the /var/log folder, specifically clamav and another one which I failed to write down.


    So now I'm back to post #2 above. How do I fix the login error that I'm getting by using omv-firstaid apparently incorrectly??


  • find the problems in the /var/log/ folder and delete them myself.

    Next time you need to check what is filling those log files. There must be something wrong.



    So now I'm back to post #2 above.

    Clear your browser cache.

  • I have been a user of OMV for a long time. I built a new server last winter so that I could store more files on it. I downloaded version 4.X and then upgraded to version 5. I recently updated to 5.2.2. At that time I had no problems accessing the Web ui. Last week one of my older media server ,Using OMV 2, stop working. So i decided to move the media to my new server. That when I found that I had a problem login to the Web ui. Everything else is still working. i can access the media from the server using SMB to my TV boxes. I can log in the the server thru the console terminal in to linux and I can access the the server via SSH. I have tried to fix the problem using omv-startaid. I have clean out the apt folder. I found that my root drive was full due to all the old log files that the server was keeping, deleting all of the old logs. After several reboots I am still having the looping problem. I notice that when I try to login that the display show a message of waiting for the server to respond before it goes back to the login screen. checking the logs I have found from mail.err what looks to be an email that it is trying to send. in setting you the server i didn't enable the sending of message outside of the server. in one of your conversation with another user about a similar problem, they fixed it by editing the session file. which I can't find. So I need help! I could just reload the whole thing and start fresh, but that a lot of work. Any idea would be welcome.

    :(:(.

  • after deleting all the old logs from the root drive it is on 2% full. I had left debug on from the time shortly after building this net box with downloading the extra tools, that I later found to be a network problem.


    I have look at the MTA configuration stored in /etc/postfix/main.cf. I notice that some of the information is missing.


    compatibility_level = 2

    mydomain = ALLHIGHTECH

    mydestination =

    inet_interfaces = localhost

    relayhost = :25


    The file /etc/postfix/recipient_cononical in empty.


    Where can I find OMV_NOTIFICATION_FROM and OMV_NOTIFICATION_RECIPIENT to check who is sending the message and who is it going to. I know that I didn't fill in all the information. Figured I get back to it someday, really don't want to receive a lot of email, would prefer to send it to the server terminal. What happens if OMV has a notification and can't send it if not all the information is not there but notification is enabled?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!