Complete OMV 5 and docker going nuts

  • Hello community,


    first time on the forum, first post, requesting for some help.

    I am running an OMV setup on a HP Proliant DL380 G6 with a dual Xeon L5640 2.27Ghz, 36GB of RAM, with 3 volumes :

    - 4 x 2.5" SAS 15K RPM 300GB in hardware RAID6 for the system as /dev/sda1 (HP RAID P420 couldn't be setup as JBOD)

    - 4 x 2.5" SAS 10K RPM 600GB in hardware RAID10 for a data storage as /dev/sdb1 (Still the HP RAID P420 without JBOD)

    - 12 x 3.5" SAS 7.2K RPM 2TB in software RAID6 for an additional data storage as /dev/md0 (using one drive as a spare) running through a HP P822 in JBOD and an external HP StorageWorks connected with a SAS cable to the main server. (by the way, a second one is ready to get installed and extend the current /dev/md0)


    I was running a OMV4 setup without any issue and when i saw the end of support in June, decided to move to OMV 5 using the video from technodadlife and the useful links he provided to the forum as guide, and so :

    - i removed some plugins (urbackup, nuts-ups, openvpn, shellinabox, and maybe some other i forgot) manually from the web interface first, and then went through the procedure described here : RE: OMV 5.0 - finally out! :-) and all was working after the update with OMV 5 shown in the web interface.

    Then i started to look to my config and restart some old stuff i had, and notice some issues in some menu of the WebUI, like the "SMART" menu for the hard drives, throwing me an error each time i go into and the same kind of issue with the nuts UPS plugin i reinstalled and never were able to get work.

    Besides that, i installed docker and portainer without a hickup, and i have access to the Portainer WebUI.

    From there on, i restarted to install all my docker containers i am using :

    - pihole (pihole/pihole)

    - cloudflare DNS over HTTPS (crazymax/cloudflared)

    - plex (linuxserver/plex)

    - heimdall (linuxserver/heimdall)

    - letsencrypt (linuxserver/letsencrypt)

    - deluge (linuxserver/deluge)

    - mariadb (linuxserver/mariadb)

    - nextcloud (linuxserver/nextcloud)


    all dockers running smoothly, without any issue, starting in a blink of an eye ... except for pihole. It was running without a problem at the beginning of my OMV 5 switch, but while searching a solution for the "SMART" and Nuts UPS menu issue i has in the web page, i found a post on a forum saying that we shouldn't use "/sharedfolders/..." as volume bind for a docker, but "/srv/dev-disk-by-label-...." and this fixed the issue for the guy having a similar problem to access the OMV web interface share page in his case. I said ok, let's change this and see what happens ... and since i did it, my pihole gives me headhache. Sometimes it starts, sometimes not, when it does start, randomly it slows down the server like hell without i see any CPU consumption or huge RAM usage. I tried to delete the image, restart from scratch, load an older image, delete the config files and folder, restart from scratch, nothing works, that's the most common log output i see in portainer when it is completely failing to start :

    [s6-init] making user provided files available at /var/run/s6/etc...exited 0.,


    [s6-init] ensuring user provided files have correct perms...exited 0.,

    [fix-attrs.d] applying ownership & permissions fixes...,

    [fix-attrs.d] 01-resolver-resolv: applying... ,

    [fix-attrs.d] 01-resolver-resolv: exited 0.,

    [fix-attrs.d] done.,

    [cont-init.d] executing container initialization scripts...,

    [cont-init.d] 20-start.sh: executing... ,

    ::: Starting docker specific checks & setup for docker pihole/pihole,

    WARNING Misconfigured DNS in /etc/resolv.conf: Two DNS servers are recommended, 127.0.0.1 and any backup server,

    WARNING Misconfigured DNS in /etc/resolv.conf: Primary DNS should be 127.0.0.1 (found 127.0.0.11),

    ,

    search *********.be,

    nameserver 127.0.0.11,

    options ndots:0,

    [i] Existing PHP installation detected : PHP version 7.0.33-0+deb9u7,

    ,

    [i] Installing configs from /etc/.pihole...,

    [i] Existing dnsmasq.conf found... it is not a Pi-hole file, leaving alone!,



    and then, nothing happens.

    Sometimes (especially if i restart the complete server), it comes up, i can access the web interface, but it is slow like hell, all DNS queries aren't resolved, well, it is a mess. even in the folder where the files are stored, i see everything going slow like hell in updating the files. And when the failure happens (most of the time if i do any change in the web interface), it starts to run slow and even slow down my network shares and so on, and the only thing i can do is restart the whole server.

    The point is, i don't know where to start look at and some help would be appreciated.

    My OMV 5 DNS configuration is set to the router, so i don't run into issue while the docker isn't started yet. Only my DHCP pool is giving the DNS IP of the pihole docker to all the clients.

    I also tried without cloudflare DNS over HTTPS method, doesn't change anything.

    There is my current config.


    1587747418.png

    thank you all for your help.

  • And i know it isn't related to the pihole docker issue i am having, but this is the output i get when trying to access the "SMART" menu of the HDD in the webgui, in case it gives some hint :

    Erreur #0:
    OMV\ExecException: Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; smartctl -x '/dev/sdc' 2>&1' with exit code '1': smartctl 6.6 2017-11-05 r4594 [x86_64-linux-5.4.0-0.bpo.4-amd64] (local build)
    Copyright (C) 2002-17, Bruce Allen, Christian Franke, http://www.smartmontools.org

    /dev/sdc: requires option '-d cciss,N'
    Please specify device type with the -d option.

    Use smartctl -h to get a usage summary in /usr/share/php/openmediavault/system/storage/smartinformation.inc:166
    Stack trace:
    #0 /usr/share/php/openmediavault/system/storage/smartinformation.inc(198): OMV\System\Storage\SmartInformation->getData()
    #1 /usr/share/php/openmediavault/system/storage/smartinformation.inc(383): OMV\System\Storage\SmartInformation->getAttributes()
    #2 /usr/share/openmediavault/engined/rpc/smart.inc(91): OMV\System\Storage\SmartInformation->getTemperature()
    #3 /usr/share/php/openmediavault/rpc/serviceabstract.inc(635): Engined\Rpc\Smart->Engined\Rpc\{closure}()
    #4 /usr/share/openmediavault/engined/rpc/smart.inc(107): OMV\Rpc\ServiceAbstract->asyncProc(Object(Closure))
    #5 [internal function]: Engined\Rpc\Smart->enumerateDevices(NULL, Array)
    #6 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
    #7 /usr/share/openmediavault/engined/rpc/smart.inc(174): OMV\Rpc\ServiceAbstract->callMethod('enumerateDevice...', NULL, Array)
    #8 [internal function]: Engined\Rpc\Smart->getList(Array, Array)
    #9 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
    #10 /usr/share/php/openmediavault/rpc/serviceabstract.inc(149): OMV\Rpc\ServiceAbstract->callMethod('getList', Array, Array)
    #11 /usr/share/php/openmediavault/rpc/serviceabstract.inc(588): OMV\Rpc\ServiceAbstract->OMV\Rpc\{closure}('/tmp/bgstatusGz...', '/tmp/bgoutputUA...')
    #12 /usr/share/php/openmediavault/rpc/serviceabstract.inc(159): OMV\Rpc\ServiceAbstract->execBgProc(Object(Closure))
    #13 /usr/share/openmediavault/engined/rpc/smart.inc(209): OMV\Rpc\ServiceAbstract->callMethodBg('getList', Array, Array)
    #14 [internal function]: Engined\Rpc\Smart->getListBg(Array, Array)
    #15 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
    #16 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('getListBg', Array, Array)
    #17 /usr/sbin/omv-engined(537): OMV\Rpc\Rpc::call('Smart', 'getListBg', Array, Array, 1)
    #18 {main}

  • change DNS1 for 127.0.0.1 you use 192.168.200.106#5053 that I useme that are your NAS IP.



    And please edit your uploaded screen capture to DO NOT SHOW your password

  • Oups, you are right, i forgot that one, thanks, i will change it anyway then.

    However, i already tried that one, doesn't change a thing. Basically, as you can notice at the beginning of the log output from the pihole docker, it tries to resolve from IP i never entered anywhere in my configuration :

    WARNING Misconfigured DNS in /etc/resolv.conf: Two DNS servers are recommended, 127.0.0.1 and any backup server,

    WARNING Misconfigured DNS in /etc/resolv.conf: Primary DNS should be 127.0.0.1 (found 127.0.0.11),


    This 127.0.0.11 is according to this exchange the loopback for the docker itself, but i am not sure what i should do to solve this. From the post from diginc, there is some command line to execute, but i am not sure where i should do it : https://github.com/pi-hole/docker-pi-hole/issues/410

  • Ok, now i am even getting such kind of email :


    The system monitoring needs your attention.


    Host: \media

    Date: Fri, 24 Apr 2020 21:44:12

    Service: \media.pronetworking.be

    Event: Resource limit succeeded

    Description: loadavg (5min) check succeeded [current loadavg (5min) = 23.1]


    This triggered the monitoring system to: alert



    Not really sure what it means, CPU load and RAM consumption are not high at all when looking at the OMV dashboard, however, all my dockers looks fine now, i went into almost none of them working 30 minutes ago, and without restarting a thing, i know have all services working. don't know what the issue is ...

  • Hello again all,


    back with my problem on which i found the cause, but not the solution. It is activating ClamAV which really kills completely my nas, it starts with dockers slowing down like hell to end up with a non working system anymore. I don't see any high CPU usage, and i don't really know where to start looking. ClamAV was used with OMV 4 without an issue, i uninstalled it before migrating to OMV 5 and reinstalled it, same parameters (the default one) and "on access scans" to my volumes. Where should i start to look ?

  • delpiero3

    Added the Label OMV 5.x
  • delpiero3

    Changed the title of the thread from “pihole docker going nuts” to “Complete OMV 5 and docker going nuts”.
  • Hello, Any thoughts about the last input ? Could an admin move my thread to another more appropriate section of the forum, since after investigation, it appears that it is clamav that kills my setup (maybe in plugins ?)?

    thanks.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!