Virtualbox on OMV5 has blank page

  • Hi,


    I'm using this guide for the VBox installation, but got a blank page: http://omv-ip:7000

    Guide: Virtualbox 6.x on OMV5 and Debian 10.x



    error code:




    /etc/nginx/sites-available/phpvirtualbox-webgui



    /etc/php/7.3/fpm/pool.d/phpvirtualbox-webgui.conf




    /etc/default/virtualbox

    Code
    VBOXWEB_USER=vbox
    VBOXAUTOSTART_DB=/etc/vbox
    VBOXAUTOSTART_CONFIG=/etc/vbox/autostart.cfg

    OMV v5.0
    Asus Z97-A/3.1; i3-4370
    32GB RAM Corsair Vengeance Pro

    Edited once, last by tinh_x7 ().

  • Hi,


    Try:


    chown -R 998:996 /var/www/phpvirtualbox

    chmod -R 755 /var/www/phpvirtualbox/


    I forgot to make the chmod recursive, I already changed the guide. After doing above everything should work.


    Regards,


    Roru69

  • I can log into the Vbox menu with that password, but can’t connect to the vm machine.

    Tried with authentication: none, external, guest

    OMV v5.0
    Asus Z97-A/3.1; i3-4370
    32GB RAM Corsair Vengeance Pro

  • What do you mean by the "vm machine". The machine you have created in Virtualbox?

    Yes.

    After I created the machine, I get an ip like this: 127.0.0.1:9200.

    I then use MSRDP to remote in with that Ip, it prompted for username and password.

    Can't figure out the username/password. I've tried the network adapter in NAT, and Bridge modes.



    forum.openmediavault.org/wsc/index.php?attachment/15536/


    Update: I made a few changes for the RDP to work.

    - change $vrdeadress to: var $vrdeaddress = '0.0.0.0';

    - connect to vm as: omv-ip:port


    The VM resolution still small for me.

  • This is how it is configured in my case:


    As you can see I selected a Virtual Machine. I can change the resolution and have set the IP address to the machine Virtualbox is installed on.



    Changed the resolution to 1024x768



    Clicked the Connect button and my login screen appears. (Had to click once in the black window to wake the machine)



    I Logged in as root and I'm in.



    These are my Remote Display settings (You can only change some of the settings when the machine is in Powered Off state).



    These are my network settings.


    If I understand correctly your Ubuntu virtual machine is asking for credentials. When you installed Ubuntu on the VM you had to supply a new username and password. These are the credentials you must use to gain access to that machine.


    Regards, Roru69

  • By using your tutorial, the Net Address is 127.0.0.1, not like your screenshot.


    I’m aware about the username/password creation of the vm. I can connect to it now.


    Thanks for the screenshots.

    OMV v5.0
    Asus Z97-A/3.1; i3-4370
    32GB RAM Corsair Vengeance Pro

  • Just experienced this when upgrading to the 5.6 kernel. For anyone that comes across this the answer is to install the

    linux-headers-amd64 package. This will automatically install the new headers needed when a new kernel is installed. This way you don't have to manually install the linux headers for your specific kernel every time.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!