omv-backup BORG error on running [Resolved]

  • Hello, this is my first post here.


    First, thank you to everybody who contribute to this project, who worked on the programming, who create the tutorials, who answer on this forum, and so on... <3<3<3 Thank you.


    I'm using a raspberry pi4, with a microSD 32Gb.

    I have installed OMV v.5.4.2 and raspian buster, i'm using openmediavault-backup 5.2 plugin., everything is up to date right now (checked).


    At start, it worked fine and I have some backups on my "Recover Partition" on a usb harddisk.

    But today I tried to do a manual backup from OMV web, and it showed:



    So I was wondering, maybe the lock was there even when no other process was doing a backup, so I looked up and see a report on his github issue pointing to break-lock

    https://borgbackup.readthedocs…lock.html#borg-break-lock


    I did on a console by ssh:

    borg break-lock /root/

    But didnt work, nor with SUDO


    So I was searching more and see another command to clean this:

    borg delete --cache-only /root

    And that really cleaned the directory /root/.cache completely

    BUT that doesn't fix this either.


    So, i'm still receiving the same error and I have no clue about how it could be fixed.


    I also tried to unistall / reinstall the plugin but still the same.


    I have read the man omv-backup borg but i don't know if create a new repo and run on a command line will break more the plugin.


    Any clue about whats is happening?


    Other question is, when I set an schedule, and then SAVE, if I click on schedule again, it' s sets the default again (daily backup) so I was wondering if is still getting my weekly backup set or it doesnt saved at all : /


    Thanks.

  • Any clue about whats is happening?

    Did you use a new shared folder for the backup? I just created a new shared folder and ran it three times with no issues.


    Other question is, when I set an schedule, and then SAVE, if I click on schedule again, it' s sets the default again (daily backup) so I was wondering if is still getting my weekly backup set or it doesnt saved at all : /

    The schedule button is just a helper button to create an entry in Scheduled Jobs. If you want to edit it, you should go to the Scheduled Jobs tab. This might be why you are having issues as well - you have multiple scheduled jobs running at the same time.

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Hello,

    Thank for that information.


    I didn't know, that feature creates a Scheduled Job, maybe a feedback popup should be better info.

    And yes, I have like 10 Jobs... hahah I have removed everything on it, I have removed the /root/.cache/borg directory and then, seems it's working again.

    So, thank you!!


    Anyway, I see the schedule jobs creates, but it's not clear if will run omv-backup with actual config or with the config started on that moment.

    I will try to explain:

    I set on tab Backup the backup done with DD (f. ex) and create a Job (Job1).

    I change the backup config to use Rsync and create a Job (Job2).


    Job1 says it will run omv-backup command, OK, but it will run DD backup? or it will actual config (Rsync)?

    The same apply to Job2.

    In case Job1 runs on DD, then in my opinion, will be better to set on comments or even on "command column" the params on the command line, not only "omv-backup".


    I will create a issue on his repo if this issue seems correct. To improve even more this wonderfool tool.

    Thank you again ryecoaaron

  • All jobs will run omv-backup which pulls the current backup method stored in the database. You can't have one job use dd and another use rsync. That is why the command has no arguments in the Scheduled Job.

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • sshk5

    Added the Label resolved
  • sshk5

    Changed the title of the thread from “omv-backup BORG error on running” to “omv-backup BORG error on running [Resolved]”.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!