Gigabit LAN running at 100 Mbits/sec - what am I missing?

  • My home network runs on TOTOLINK A2004NS (Firmware V1.0.0) WiFi router which is capable of Gigabit wifi speeds. 100 Mbps internet comes from fibre optic modem through a cat5 cable [100 Mbps] to the router. Nodes include a MacBook Air early 2015; 2 windows 10 laptops - both with Gigabit Wireless; a Raspberry Pi4 with OMV 5 in it [connected through WiFi]; an iPhone SE, mi4i phone, Amazon Fire stick, Amazon Echodot and an HP wireless printer. Except the printer and mi4i phone, rest all devices are capable of connecting to 5 Ghz Wifi. The transfer speed of the RPi4 OMV NAS setup maxes out at 12 MByte/s. Basis my research in forums & google, tried the below tests to see if the transfer speed increases - all tests resulted in a max of 12 MByte/s. Used Wifi in RPi4 as I don't have a Cat5e/Cat6 cable handy - unable to get one due to the lockdown

    1. Removed the cat5 cable from router and ran the LAN network w/o internet - results are the same

    2. Turned off 2.4 Ghz band of the router - results are the same [in this setup, the printer and mi phone are not able to connect to LAN - rest of the devices functions as usual]

    3. Shared a folder on the windows laptop and copied files to Mac and tried visa versa [OMV and RPi4 are not in the equation of this setup] - still the transfer speed caps at 12 Mbyte/s

    4. Made one of the Win 10 laptop a hotspot and connected Macbook to its Wifi and tested transfer speed between the Laptops - still the transfer speed caps at 12 MBytes/sec [Router is out of the equation here]


    LAN connection speed on windows Laptop reads 433 Mbps range [Fluctuates] and Macbook reads 300 Mbps range [fluctuates]


    I'm not able to figure out what is stopping the network from operating at a better speed, if not Gigabit speeds. I know this is not related to OMV as the above tests rules that out - but desperately looking for help - Also not sure if the above tests makes any sense.

  • Regarding RaspberryPi (for Windows-hotspot and MAc only I don't know)


    What I'm writing, is just based on my experience with a Nanopi, moreover connected through ethernet. However this method should apply to wifi as well.


    I would check if ethernet autonegotiation is on.


    ifconfig -a shows all interfaces, then try following this method here using your interface instead of eth0

    duffr


    OMV 5.x & OMV extras on NanoPi Neo 2

    OMV 5.x & OMV extras on x64 (AMD) custom build

  • duffr Thank you for the response. I managed to get couple of Cat6 ethernet cables and did some iperf3 tests between the nodes. Apparently the router was the culprit - though product documentation says 877 Mbps speed, the speed is much lower even at 3 meters away, that too in line of sight. I got upto 30 MBps [Bytes/sec] speed by keeping the laptop within 30 cms from the router [after connecting Pi 4 to router using Cat6 cable]. eth0 interface in OMV now shows 1000 Mbps [gigabit] link speed. 30 MBps transfer speed is definitely higher than 10/100 mbps LAN; which essentially narrows the bottle neck down to the WiFi router.


    Waiting for the Covid-19 lockdown to get over - will buy a USB 3.0 to Gigabit ethernet adapter to confirm the finding; before I go for a better router.


    Anyone have any suggestions on the router? I can't afford high end ones - need to stick with something below $100

  • Keep the router, get a Gbit switch. And a WiFi mesh.


    Connect everything in the LAN to the switch, including at least one of the Wi-Fi mesh units. And then connect the switch to the router. And the router to the internet.

    Be smart - be lazy. Clone your rootfs.
    OMV 5: 9 x Odroid HC2 + 1 x Odroid HC1 + 1 x Raspberry Pi 4

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!