Failed to hibernate system via logind: Not enough swap space for hibernation

  • Hi all,


    I have trouble with autoshutdown since I upgraded from OMV 4.x to 5.x


    Syslog:

    autoshutdown.sh[7155]: Failed to hibernate system via logind: Not enough swap space for hibernation


    Anybody else has this problem after upgrading?


    Thank you for your help

  • Did you change the shutdown command in the plugin? I don't shutdown my systems but from reading, systems that couldn't suspend to ram on OMV 4.x seem to be able to on OMV 5.x.

    omv 5.5.12 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • I know there are couple of other threads about this and what people did to fix. Unfortunately, I don't know much to help.

    omv 5.5.12 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Flash memory plugin isn't working well.

    The flashmemory plugin doesn't do anything with swap. There may be additional tweaks to the swap instructions that the plugin displays but that is why they are optional.

    omv 5.5.12 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Since flashmemory isn't configuring swap at all, I don't understand how reconfiguring flashmemory can help hibernation issues.

    omv 5.5.12 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Now i'm confused... After upgrade to OMV5 i reconfigure flash memory and fstab. I remember that i fix it with comment out swap line...

    But i do reverse. I kill # in front of the line. Thereafter hibernate works.

    So i must check this again. It's better that i not tell more wrong things... sorry for that. I think there is an issue with flash memory plugin.

  • Code
    Aug 3 16:53:00 networknas kernel: [ 76.926964] PM: Cannot find swap device, try swapon -a
    Aug 3 16:53:00 networknas kernel: [ 76.926974] PM: Cannot get swap writer
    Aug 3 16:53:00 networknas kernel: [ 77.017377] PM: Basic memory bitmaps freed
    Aug 3 16:53:00 networknas kernel: [ 77.017380] OOM killer enabled.
    Aug 3 16:53:00 networknas kernel: [ 77.017380] Restarting tasks ... done.
    Aug 3 16:53:00 networknas kernel: [ 77.083339] video LNXVIDEO:00: Restoring backlight state
    Aug 3 16:53:00 networknas kernel: [ 77.083345] PM: hibernation exit

    Via fstab you comment out with # swap line for flash memory. SYSlog give me this error after typing pm-hibernate via terminal. Nothing happens and you get back normal prompt... I read many logs and found this issue in syslog file. Cannot find swap device.


    Thereafter i delete # in swap line and get swap back and hibernate working! So i don't know now how to fix this really if there is an issue with flash memory.

  • After upgrade to OMV5 i reconfigure flash memory and fstab. I remember that i fix it with comment out swap line...

    But i do reverse. I kill # in front of the line. Thereafter hibernate works.

    So i must check this again. It's better that i not tell more wrong things... sorry for that. I think there is an issue with flash memory plugin.

    Disabling swap isn't configuring flashmemory. It is disabling swap to reduce writes a bit more. Yes, the instructions are on the plugin but it seemed the most appropriate place for people to see them. But they are completely optional and shouldn't be done if you hibernate your system. I don't hibernate my systems and don't worry about disabling swap. The instructions are just a guide. They can't cover every situation.

    omv 5.5.12 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Ok, but fact is if you want hibernate system you must check if there is a swap. If not hibernate doesn't work as aspected.

    Obviously since hibernating writes the contents of ram to the swap file. I guess I don't understand what you want the plugin to do? It doesn't disable swap and OMV creates a swap file the same size as ram by default. If someone chooses to change something about that, then it is their fault that hibernate doesn't work.

    omv 5.5.12 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • You will have more experience, yes. But if there more guys like i am, they will follow stupid this steps and will run in trouble. So its nice to know that guys will not switch off swap for hibernate. I understand that this is not a fault by plugin. Now its time for thread opener to tell us if he use swap or not and run in this trouble as i.

  • But if there more guys like i am, they will follow stupid this steps and will run in trouble

    Most people don't hibernate a server. So, that is why the instructions have been around a long time but not many people had problems.

    omv 5.5.12 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!