No filesystem backend exists for 'cifs'.

  • Hi Guys,

    i played a little bit around with mounting my external nas. so far now it worked and i can reach my shared on the remote nas. but since i get this strange error in omv:

    No filesystem backend exists for 'cifs'.

    Fehler #0:
    OMV\Exception: No filesystem backend exists for 'cifs'. in /usr/share/openmediavault/engined/rpc/
    Stack trace:
    #0 [internal function]: Engined\Rpc\OMVRpcServiceFileSystemMgmt->getList(Array, Array)
    #1 /usr/share/php/openmediavault/rpc/ call_user_func_array(Array, Array)
    #2 /usr/share/php/openmediavault/rpc/ OMV\Rpc\ServiceAbstract->callMethod('getList', Array, Array)
    #3 /usr/share/php/openmediavault/rpc/ OMV\Rpc\ServiceAbstract->OMV\Rpc\{closure}('/tmp/bgstatusSH...', '/tmp/bgoutputKx...')
    #4 /usr/share/php/openmediavault/rpc/ OMV\Rpc\ServiceAbstract->execBgProc(Object(Closure))
    #5 /usr/share/openmediavault/engined/rpc/ OMV\Rpc\ServiceAbstract->callMethodBg('getList', Array, Array)
    #6 [internal function]: Engined\Rpc\OMVRpcServiceFileSystemMgmt->getListBg(Array, Array)
    #7 /usr/share/php/openmediavault/rpc/ call_user_func_array(Array, Array)
    #8 /usr/share/php/openmediavault/rpc/ OMV\Rpc\ServiceAbstract->callMethod('getListBg', Array, Array)
    #9 /usr/sbin/omv-engined(537): OMV\Rpc\Rpc::call('FileSystemMgmt', 'getListBg', Array, Array, 1)
    #10 {main}

    any ideas?

  • how can i get rid of this error message ?

    You can't, because the backend that processes the filesystem information simply does not know about the cifs filesystem. If there is an unsupported filesystem it will always behave like this.

    To get rid of this you have the following options:

    • Do not use and mount cifs filesystems.
    • Do not use the filesystem page in the UI.
    • Someone has to implement the backend for cifs to let OMV handle this filesystem correct.
  • yeah its okay. i just mounted my synology nas now with nfs but i think it is a little bit slower than the cifs.

    i was thinking that something like cifs is allready in omv.

    but anyway thanks for you good job volker all the years....and i'm a fan since you start with freebsd somewhere around 2003 or so ;)

  • After some research I came to the conclusion that a backend support for cifs does not fix the problem because you can only create shared folders on mount points that are created via webui, and mounting an remote smb share via cifs is not possible without providing credentials and network address which is not supported in the UI.

  • I am going through the same if not similar situation. I have a pre-existing NAS on my network sharing a folder. Need OMV 5 server to be able to access said folder on my other NAS. CIFS is the only option really as NFS isn't working, not saying it isn't working on OMV just that the other NAS isn't exporting the folder VIA NFS (don't know if it doesn't support it or I just need to set up NFS on that server or what, rather not go tinkering on it as there's a lot of data already in place and well rankly it's not broke so I I don't want to fix it, or is it it's not fixed so I don't want to broke it?) The problem I ran into was how to setup a mount point on my OMV that accessed the folder on my other NAS. Enter stage right remote mount plugin. Now I'll admit I only found that remote mount plugin was the way to do this via another post here on the forums. One thing I'll say is, and this was also noted on the post (don't ask me which one I've been doing way to much lately and my brain is a bit frazzled) is that connection problems existed with the default settings created when doing a new remote mount. It was the vers=3.0 down under the options, in order for me, and for the person in the other post that had the same problems of OMV not connecting to the share of their other NAS, it needed to be changed to vers=2.0 This is a SAMBA version issue I believe. Ok I know it says for SAMBA / CIFS options see the man page. And I'll admit that was my next step but sometimes the man pages can be as confusing as anything else. Just putting this all here in case OP from this post comes back and has the same problem of the connection issues.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!