Raid Mirror wieder herstellen

  • Hallo,


    eine meiner Festplatten aus meinem Raid Mirror ist ausgefallen. Ich habe sie jetzt gegen eine neue getauscht.


    Wie bekomme ich sie jetzt mit meiner noch vorhandenen Festplatte wieder zum Raid verbunden, ohne das die Daten verloren gehen? Gibt es keine Reparaturfunktion?


    Gruß

    Kutsche

  • Die Basis für die Beantwortung deiner Frage ist das Einstellen folgender Infomationen hier: Degraded or missing raid array questions


    BTW: Diese Art von Frage wurde schon oft hier im Forum gestellt. Eigentlich sollten sich dazu jede Menge Threads finden lassen.

    OMV 3.0.100 (Gray style)

    ASRock Rack C2550D4I C0-stepping - 16GB ECC - 6x WD RED 3TB (ZFS 2x3 Striped RaidZ1) - Fractal Design Node 304 -

    3x WD80EMAZ Snapraid / MergerFS-pool via eSATA - 4-Bay ICYCube MB561U3S-4S with fan-mod

  • Leider habe ich hier nichts gefunden. Wahrscheinlich, weil ich auf deutsch gesucht habe. Ich wäre aber dankbar, wenn du mir entsprechende posts (gern auch englisch) nennen kannst.


    Hier noch die fejhlenden Informationen. Danke für den Hinweis.

  • Probier den Link mal hier: https://raid.wiki.kernel.org/index.php/RAID_Recovery. Ist zwar kein Beitrag aus dem Forum hier, sollte dir aber weiterhelfen. Der hier gehört da auch noch dazu: Replacing a failed drive


    Hier im Forum musst du einfach nach Threads suchen, wo geaves aktiv ist. Er hat hier schon vielen geholfen.

    OMV 3.0.100 (Gray style)

    ASRock Rack C2550D4I C0-stepping - 16GB ECC - 6x WD RED 3TB (ZFS 2x3 Striped RaidZ1) - Fractal Design Node 304 -

    3x WD80EMAZ Snapraid / MergerFS-pool via eSATA - 4-Bay ICYCube MB561U3S-4S with fan-mod

  • Danke für die Links. Ich muss nur leider feststellen, dass ich da jetzt doch mit überfordert bin. Da reicht mein Englisch nicht mehr aus. ;-(


    Hier im Forum habe ich diesen Beitrag gefunden. Daraus habe ich diese Befehle ausgeführt:


    Code
    mdadm --stop /dev/md8
    und
    mdadm --assemble --force --verbose /dev/md8 /dev/sd[cd]

    danach bekam ich dann dies:


    Code
    mdadm: looking for devices for /dev/md127
    mdadm: No super block found on /dev/sdd (Expected magic a92b4efc, got 00000000)
    mdadm: no RAID superblock on /dev/sdd
    mdadm: /dev/sdd has no superblock - assembly aborted

    Vielleicht kann mir noch jemand auf deutsch oder Schritt für Schritt in Englisch weiter helfen.


    Sorry für mein Unwissen.

  • Eigentlich heißt dein inaktives RAID ja /dev/md127 und nicht /dev/md8. Vielleicht solltest du die Befehle mal damit versuchen. Obwohl der mdadm das offensichtlich schon gerafft hat, welches das inaktive RAID ist.


    Ich gehe davon aus, dass du eine aktuelle Datensicherung hast, auf die du im Notfall zurückgreifen kannst, falls hier etwas schiefläuft. Wenn nicht, dann bitte aktualisieren, bevor du hier weitere Versuche unternimmst.


    Und bitte keine Befehle einfach abtippen. Das könnte schnell ins Auge gehen;)


    Das mit dem Superblock hatten wir hier schon öfter. Mal sehen, ob ich dazu was finde.

    OMV 3.0.100 (Gray style)

    ASRock Rack C2550D4I C0-stepping - 16GB ECC - 6x WD RED 3TB (ZFS 2x3 Striped RaidZ1) - Fractal Design Node 304 -

    3x WD80EMAZ Snapraid / MergerFS-pool via eSATA - 4-Bay ICYCube MB561U3S-4S with fan-mod

  • Danke für deine Hilfe. Ich habe natürlich MD8 in MD127 geändert.


    Habe aber jetzt alles wieder am laufen. Ein Kollege hat mir eben diesen Artikel per Mail geschickt. Sogar auf deutsch. :-) Zwar etwas älter aber er hat geholfen. Ich habe die dort genannten Befehle über SSH ausgeführt (copy and past). Jetzt ist das RAID im Backand wieder da und ich habe die Wiederherstellung dort gestartet.


    Zugriff über ftp ist auch schon da.


    Trotzdem vielen Dank für deine Geduld.

  • Ok, dass sollte der geeignete Einstiegspunkt in diesen Thread hier sein: RAID 5 failure. All drives missing

    Dort betrifft es /dev/sde. Bei dir /dev/sdd. Das ist doch das Ersatzlaufwerk, oder?

    Die Lösung solltest du im Post #16 finden, nur eben auf die sdd anwenden.


    Edit: Überschneidung. Schön, wenn jetzt alles wieder läuft.

    OMV 3.0.100 (Gray style)

    ASRock Rack C2550D4I C0-stepping - 16GB ECC - 6x WD RED 3TB (ZFS 2x3 Striped RaidZ1) - Fractal Design Node 304 -

    3x WD80EMAZ Snapraid / MergerFS-pool via eSATA - 4-Bay ICYCube MB561U3S-4S with fan-mod

  • Kutsche

    Added the Label resolved

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!