NEWBIE - upgrade 4-->5 problems

  • Hi all!


    I am a newbie, slowly learning the basics of Linux and OMV.

    After successfully upgrading OMV4 to 5 and following techdadlife instructions and other threads (newest installation script version) OMV is up and running but I have a few problems.

    I can't log in on the admin page, I get this error:


    Error #0:
    OMV\Rpc\Exception: Failed to connect to socket: No such file or directory in /usr/share/php/openmediavault/rpc/rpc.inc:141
    Stack trace:
    #0 /var/www/openmediavault/rpc/session.inc(56): OMV\Rpc\Rpc::call('UserMgmt', 'authUser', Array, Array, 2, true)
    #1 [internal function]: OMVRpcServiceSession->login(Array, Array)
    #2 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
    #3 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('login', Array, Array)
    #4 /usr/share/php/openmediavault/rpc/proxy/json.inc(97): OMV\Rpc\Rpc::call('Session', 'login', Array, Array, 3)
    #5 /var/www/openmediavault/rpc.php(45): OMV\Rpc\Proxy\Json->handle()
    #6 {main}


    Apart from these two issues, ALL my dockers, share and services are functioning as normal. I run Pi-hole, privoxy, Syncthing, folding@home and backups and more on my OMV.

    Login to the admin page and the issue to update the OMV installation fom Cockpit-docker is no longer functioning.


    I should say that the last part of the upgrade process gave me this error:


    Updating configuration database ...

    /usr/share/openmediavault/confdb/create.d/conf.system.omvextras.sh: line 46: omv -mkconf: command not found

    ERROR: Failed to create the default configuration: Command '['/usr/share/openmed iavault/confdb/create.d/conf.system.omvextras.sh']' returned non-zero exit statu s 127.

    dpkg: error processing package openmediavault-omvextrasorg (--configure):

    installed openmediavault-omvextrasorg package post-installation script subproce ss returned error exit status 1

    Processing triggers for ca-certificates (20190110) ...

    Updating certificates in /etc/ssl/certs...

    0 added, 0 removed; done.

    Running hooks in /etc/ca-certificates/update.d...

    done.

    Processing triggers for php7.3-fpm (7.3.14-1~deb10u1) ...

    Processing triggers for initramfs-tools (0.133+deb10u1) ...

    update-initramfs: Generating /boot/initrd.img-4.19.0-8-amd64

    Processing triggers for dbus (1.12.16-1) ...

    Processing triggers for libc-bin (2.28-10) ...

    Processing triggers for openmediavault (5.4.3-1) ...

    Updating locale files ...

    Updating file permissions ...

    Purging internal cache ...

    Restarting engine daemon ...

    Errors were encountered while processing:

    openmediavault-omvextrasorg

    E: Sub-process /usr/bin/dpkg returned an error code (1)



    THANKS TO ALL CONTRIBUTORS in the excellent OMV forum! It means a lot for people like myself. <3

  • Gnarf

    Added the Label OMV 5.x
  • Gnarf

    Added the Label Upgrade 4.x -> 5.x
  • I should say that the last part of the upgrade process gave me this error:

    Something didn't upgrade omv-extras. Remove it and apt-get -f install.

    omv 5.6.0 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.5.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Hi and thanks for your answer.

    Seems something broke the internet access, only from command prompt though. I tried restoring it with omv-firstaid but that didn't help.


    "W: Failed to fetch http://ftp.se.debian.org/debian/dists/buster/InRelease Could not resolve 'ftp.se.debian.org' " and so on


    But..shouldn't the login work nonetheless?


    This is the error I get after reconfig in omv-firstaid:


    Configuring network interface. Please wait ...

    ERROR: Failed to connect /var/lib/openmediavault/engined.sock: [Errno 2] No such file or directory

  • I found a thread with the similiar problem and followed the guide but after:


    systemctl start openmediavault-engined.service


    I get this error:


    Job for openmediavault-engined.service failed because the control process exited with error code.

    See "systemctl status openmediavault-engined.service" and "journalctl -xe" for details.


    The engined.service is running but "journalctl -xe" gives me an aoutput with losts af connection errors.

    No idea what to do now...

  • *UPDATE* After a powershortage due to a storm last night the server now boots up in emergency mode so I reckon I have to reinstall it.

    I can't even start OMV-firstaid "command not found".

    Anyone got ideas?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!