Using archive mirror

  • Hi,


    I have an old OMV server (version 2.2.3) that I installed years ago.

    It does what it needs to so it wasn't updated or upgraded.

    Recently I installed a APC UPS in the rack where the server is located and I wanted to install the UPS plugin. This failed because the mirror I am using does not have the old packages that are required.

    I looked around and found that the packages are still available on archive.debian.org.

    Is there a way to change the mirror I am using to the archive one?

    At the moment I don't want to update or mess around with this system too much...


    Thanks.

  • Update:

    I added archive.debian.org wheezy to the sources.list and was able to install the ups plugin.

    However: when starting the service I get the following error:

    Code
    upsdrvctl start frodo_ups
    Network UPS Tools - UPS driver controller 2.6.4
    Network UPS Tools - Generic HID driver 0.37 (2.6.4)
    USB communication driver 0.32
    Can't claim USB device [051d:0002]: could not detach kernel driver from interface 0: Operation not permitted

    I found a thread from someone who had the same problem and he solved it by installing the backport kernel.

    I am running 3.16.0-0.bpo.4-amd64 which looks like a backport kernel to me. Are there any other backport kernels?

  • Did you connect the UPS to the OMV box while you have tried to start the service?

    I remember that in my configuration the UPS must be connected and switched on in order to enable / configure the service.

    OMV 3.0.99 (Gray style)
    ASRock Rack C2550D4I C0-stepping - 16GB ECC - 6x WD RED 3TB (ZFS 2x3 Striped RaidZ1)- Fractal Design Node 304

  • Did you connect the UPS to the OMV box while you have tried to start the service?

    I remember that in my configuration the UPS must be connected and switched on in order to enable / configure the service.

    Yes, it was connected.

    I am waiting for a good occasion to restart OMV just in case that might help.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!