Spindown Problem

  • Hello to everything!

    I installed some weeks ago (from clean) the latest version of omv 5.0 (i come from the old 4) and i can use it normally.

    I have only one problem ... i can't spindown the disks automatically (3 disks).

    In previous build, i used the power management from web interface (hdparam) (with 127 for APM and 60 minutes for spin down value) and it worked all normally.

    I tried to disable all value and install hd-idle (also the modified version of adelolmo) how it was suggested in the guide of forum ... but i can't have poweroff of disks.

    I put the simplest value for hd-idle (HD_IDLE_OPTS="-i 3600"), but without success!

    If i put for try, a low value (60 second), the disks spindown after restart of hd-idle services.

    When disks doesn't spindown, if i lauch command "hd-idle -t sda" (and others sdx) , disks spindown and they doesn't wake up ... so it isn't something that access disks and prevent for standby

    Is strange that initially, after the installation, hd-idle worked... but now not!)


    I read all posts in forum, but nothing help!


    What i can watch for understand what happens?


    P.S. The disks are 2 WD red and 1 seagate disk

    P.P.S. Of course service of hd-idle is active and running (i can see status with systemctl status hd-idle)


    Thank you very much



    Marco

  • What is the complete output of systemctl status hd-idle after boot?


    Also try to execute hdparm -B255 /dev/sdX for each drive. Just to be sure hdparm is turned off.

    After boot, this is the status (is the original hd-idle, not the forked version)


    ● hd-idle.service - hd-idle - spin down idle hard disks

    Loaded: loaded (/lib/systemd/system/hd-idle.service; enabled; vendor preset:

    Active: active (running) since Fri 2020-05-15 08:04:25 CEST; 34s ago

    Docs: man:hd-idle(1)

    Process: 638 ExecStart=/usr/sbin/hd-idle $HD_IDLE_OPTS (code=exited, status=0/

    Main PID: 640 (hd-idle)

    Tasks: 1 (limit: 4915)

    Memory: 416.0K

    CGroup: /system.slice/hd-idle.service

    └─640 /usr/sbin/hd-idle -i 3600


    mag 15 08:04:25 nas-casa.lan.casa.it systemd[1]: Starting hd-idle - spin down idle hard disks...

    mag 15 08:04:25 nas-casa.lan.casa.it systemd[1]: Started hd-idle - spin down idle hard disks.


    when i make hdparm -B255 /dev/sdX:


    /dev/sda:

    setting Advanced Power Management level to disabled

    APM_level = off


    /dev/sdb:

    setting Advanced Power Management level to disabled

    SG_IO: bad/missing sense data, sb[]: 70 00 05 00 00 00 00 0a 04 51 40 00 21 04 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

    APM_level = not supported


    /dev/sdc:

    setting Advanced Power Management level to disabled

    SG_IO: bad/missing sense data, sb[]: 70 00 05 00 00 00 00 0a 04 51 40 00 21 04 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

    APM_level = not supported


    /dev/sdd:

    setting Advanced Power Management level to disabled

    SG_IO: bad/missing sense data, sb[]: 70 00 05 00 00 00 00 0a 04 51 40 00 21 04 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

    APM_level = not supported




    is normal the message not supported and bad/missing sense data? The /dev/sda is the SSD disk

  • I tried also to purge hd-idle and reinstall the version of github ... but it sill doesen't work


    but the service is running



    root@nas-casa:/home# systemctl status hd-idle.service

    ● hd-idle.service - hd-idle - spin down idle hard disks

    Loaded: loaded (/lib/systemd/system/hd-idle.service; enabled; vendor preset:

    Active: active (running) since Fri 2020-05-15 10:12:40 CEST; 1h 39min ago

    Docs: man:hd-idle(8)

    Main PID: 11262 (hd-idle)

    Tasks: 6 (limit: 4915)

    Memory: 9.0M

    CGroup: /system.slice/hd-idle.service

    └─11262 /usr/sbin/hd-idle -i 3600


    mag 15 10:12:40 nas-casa.lan.casa.it systemd[1]: Started hd-idle - spin down idle hard disks.

    mag 15 10:12:40 nas-casa.lan.casa.it hd-idle[11262]: symlinkPolicy=0, defaultIdle=3600, defaultCommand=scsi, debug=false, logFile=, devices=




    I also tried to disable SMART (but it was configured for keep device in standby and i remember it worked before), but it doesn't work nothing

  • i think i found the problem, it was cockpit that prevent hd-idle to spin down.

    I remove it from OMV extras and now disk spindown!


    The strange things was that if i put them in standby mannualy, they never spin up until i use!

  • Did you correctly configure the file in /etc/default/hd-idle


    Here a example:


    # defaults file for hd-idle

    # start hd-idle automatically?

    START_HD_IDLE=true

    HD_IDLE_OPTS="-i 0 -a /dev/disk/by-label/RAID5 -i 600 -a /dev/disk/by-label/Backups -i 900 -l /var/log/hd-idle.log"

    [LibreELEC @ 2x RPi3, CoreELEC @ S12 Octa Core]

    [ NAS OMV 5.xx (Usul) @ NanoPI M4 ]

    [ Nextcloud 18.0.4 @ ODROID C2 ]

    [ Motioneye @ RPi4]

  • Ciao Marco! (I guess you're italian by reading your server name)
    Please note that if you're using standby/hibernation on your server, hd-idle will stop working after a while. Check the hd-idle thread where I have linked a new version which does work correctly.

    OMV BUILD - MY NAS KILLER - OMV 5.x + omvextrasorg


    Core i3-8300 - ASRock H370M-ITX/ac - 8GB RAM - Sandisk Ultra Flair 32GB (OMV), 256GB NVME SSD (Docker), 3x4TB HDD (Data) - Fractal Design Node 304 - Be quiet! Pure Power 11 350W

  • thanks to all !!! now it works !

    The main problem it was cockpit ! I removed it since i didn't use so much. I think he check something to disk and prevent hd-idle to spindown disks


    Thanks, i put some simple config HD_IDLE_OPTS="-i 3600" and it works only with cockpit unistalled.




    Ciao Marco! (I guess you're italian by reading your server name)
    Please note that if you're using standby/hibernation on your server, hd-idle will stop working after a while. Check the hd-idle thread where I have linked a new version which does work correctly.

    Si sono Italiano :)


    i used your thread for understand how works, and, how i said, the problem was something of cockpit that use disk and prevent to spindown ... but if i spindown them manually, they not wakeup (very strange things).


    In any case, i also saw that if i enabled smart (from omv web interface) with options that prevent wakeup disk, the disks involved in smart check never spindown with hd-idle (i remember it worked with hdparam). I think this function works only with the omv default's power saving (hdparam).

  • Apparently hdparm does not work with some WD drives (and possibly others?)


    I started using hd-idle following the guidein this forum, then discovered all those issues I've talked aboud, but finally fixed them so I'm happy to use it. The github version also logs in syslog when disks spindown and spinup, which makes it great for troubleshooting.

    OMV BUILD - MY NAS KILLER - OMV 5.x + omvextrasorg


    Core i3-8300 - ASRock H370M-ITX/ac - 8GB RAM - Sandisk Ultra Flair 32GB (OMV), 256GB NVME SSD (Docker), 3x4TB HDD (Data) - Fractal Design Node 304 - Be quiet! Pure Power 11 350W

  • Ok!! whith wd red, in omv 4 it worked. Now i want understand if work hdparm with smart (now that understand wich process made the problem).

    After, i'll try your suggestion with hd-idle and smart!


    i'll write the results :)

  • Apparently hdparm does not work with some WD drives (and possibly others?)


    I started using hd-idle following the guidein this forum, then discovered all those issues I've talked aboud, but finally fixed them so I'm happy to use it. The github version also logs in syslog when disks spindown and spinup, which makes it great for troubleshooting.

    I confirm that work also for me hd-idle with smart.

    In my case, works all with hdparm and with hd-idle


    I noticed Only one minus of using hd-idle. If hdparm put disk in standby and i browse a folder of the standby disk, i can see contents without the wakeup of disk (of course only names, if i want see inside of a file, disk will wake up)

    With hd-idle, the same operation wakeup disk instantly also for a "ls" command.


    is like hdparm use some cache, i think because is configured with APM level 127

  • marco88

    Added the Label OMV 5.x
  • marco88

    Added the Label resolved
  • Got a little late to the party...

    i think i found the problem, it was cockpit that prevent hd-idle to spin down.

    I remove it from OMV extras and now disk spindown!


    The strange things was that if i put them in standby mannualy, they never spin up until i use!

    How did you find out that cockpit was the one preventing idling? I have the same exact issue, but I don't have cockpit installed

  • Got a little late to the party...

    How did you find out that cockpit was the one preventing idling? I have the same exact issue, but I don't have cockpit installed

    Hello,


    the problem is udisks2 package that is installed as dependency of cockpit and when its daemon start, overwrite ata settings of hdparm used by openmediavault.

    Furthermore it pool s.m.a.r.t. data from drives regularly.


    Hard drives with a longer standby timeout than the polling interval (udisks default to 10 min) may fail to enter standby.


    Info at:

    https://wiki.archlinux.org/index.php/Udisks


    Problem is described in section:

    Broken standby timer (udisks2)


    Possible solution in section:

    Apply ATA settings (udisks2)


    I hope I was helpful


    Carlo

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!