OMV 5 - can’t update Kernel

  • Hello everyone,


    I tried to update the kernel from my Rpi4. First I tried it with „rpi-update“ with putty but no luck.

    Then I tried it with OMV Webif over the update tab. And I received the following error and it keeps repeating all over.

    I need to update the kernel because I won’t to install pihole with docker and Portainer.


    It would be very nice if someone could help me.


    Here my specs:

    OMV 5.3.2-1

    Rpi4

    Kernel Linux 4.19.97-v7l+

  • And I received the following error and it keeps repeating all over

    Did you try running the command it tells you to run? apt-get -f install


    need to update the kernel because I won’t to install pihole with docker and Portainer.

    You don't need a newer kernel to install those. You do need to fix the apt errors with the command above to install docker though.

    omv 5.5.1 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • I tried „apt -fix-broken install“ but no luck.


    I will also try your suggestion later.


    I installed pihole with this video:



    And i have the same problem at the an as the guy in the video, so I thought a kernel update should be good. But as I said, I will try your suggestion.

  • tried „apt -fix-broken install“ but no luck.

    My suggestion does the same thing.

    nd i have the same problem at the an as the guy in the video,

    I don't have time to watch the video but I will have to try rpi-update. Not sure why that part is necessary.

    omv 5.5.1 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • My suggestion does the same thing.

    I don't have time to watch the video but I will have to try rpi-update. Not sure why that part is necessary.

    Okay I tried your command "apt-get -f install" and it worked, I could install all the updates from OMV. After that I tried pihole via portioner but no luck. Then I did the kernel update with rpi-update and pihole worked.


    Thank you for your help!

  • I have install pi-hole in a container on an RPi quite a few times and I never updated the kernel with rpi-update. Not sure why the update "fixed" it.

    omv 5.5.1 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!