linux-image-amd64 held back

  • I just reinstalled OMV5 & omv-extras, enabled backports from web ui & now apt upgrade gives me the following:

    Code
    The following packages have been kept back: linux-image-amd64 0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.The following packages have been kept back: linux-image-amd64 0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

    How do I troubleshoot. Preliminary googling shows nothing useful.

  • What is the output of:


    omv-aptclean

    apt-cache policy linux-image-amd64

    omv 5.6.6 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.1
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Code
    sudo apt-cache policy linux-image-amd64
    linux-image-amd64:
    Installed: 4.19+105+deb10u4
    Candidate: 5.5.17-1~bpo10+1
    Version table:
    5.5.17-1~bpo10+1 500
    100 http://httpredir.debian.org/debian buster-backports/main amd64 Packages
    *** 4.19+105+deb10u4 500
    500 http://deb.debian.org/debian buster/main amd64 Packages
    100 /var/lib/dpkg/status
  • I have seen this problem from time to time. It clears itself eventually and I never found out what causes it. I didn't do anything to try to fix it.

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • I think the omv-aptclean fixed it because it says 5.5 is a candidate. If it still won't install, apt-mark unhold linux-image-amd64 should do it.

    omv 5.6.6 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.1
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Not a problem for me just a related observation.


    I have linux-image-amd64 5.5.17-1~bpo10+1 installed.


    But what is shown in the kernel list in OMV-Extras kernel tab in the drop down box is Debian GNU/Linux, with Linux 5.5.0-0.bpo.2-amd64.

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • I think the omv-aptclean fixed it because it says 5.5 is a candidate. If it still won't install, apt-mark unhold linux-image-amd64 should do it.

    Sadly, still a problem.

    Code
    sudo apt upgrade Reading package lists... Done Building dependency tree Reading state information... Done Calculating upgrade... Done The following packages have been kept back: linux-image-amd64 0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.sudo apt upgrade Reading package lists... Done Building dependency tree Reading state information... Done Calculating upgrade... Done The following packages have been kept back: linux-image-amd64 0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
  • Only read, never post .. sorry if I don't follow correct posting etiquette.


    Was having the same problem, so tried to force the install


    Told me there was unmet dependencies .. so installed linux-image-5.5.0-0.bpo.2-amd64


    I'm very much a Debian beginner .. and potentially have broken something .. but things now appear to be working


    Code
    ~# apt-cache policy linux-image-amd64
    linux-image-amd64:
    Installed: 5.5.17-1~bpo10+1
    Candidate: 5.5.17-1~bpo10+1
    Version table:
    *** 5.5.17-1~bpo10+1 500
    100 http://httpredir.debian.org/debian buster-backports/main amd64 Packages
    100 /var/lib/dpkg/status
    4.19+105+deb10u4 500
    500 http://mirror.aarnet.edu.au/debian buster/main amd64 Packages
  • Funny thing but I had two files held back a couple of days ago when upgrading a Debian 10 desktop. I’m almost sure one of them was linux-image-amd64. Can’t remember if I just restarted and tried apt-get update and upgrade again, or what, but all went well. Wish I had paid better attention.

    Simple and sure backup and restore: In a Scheduled Job: rsync -av --delete /srv/dev-disk-by-label-SOURCE/ /srv/dev-disk-by-label-DESTINATION/ (HT: Getting Started with OMV5)
    OMV 5 (current) - Hardware: Thinkserver TS140, Nextcloud, Plex, Airsonic, Navidrome, Ubooquity, Digikam, & Heimdall - NanoPi M4 (v.1), backup - Odroid XU4, Pi-Hole (DietPi) - Testing/Playing: hc2, xu4, Pi 3B+, Odroid H2. Mac user trying to convert to Linux on a HP dx2400, Debian 10 XFCE.

  • I think the omv-aptclean fixed it because it says 5.5 is a candidate. If it still won't install, apt-mark unhold linux-image-amd64 should do it.

    Says "linux-image-amd64 was already not hold" so still will not install. Reinstalled debian from scratch twice with same problem. :/

  • Reinstalled debian from scratch twice with same problem

    I think this is the repo you are using. The linux-image-amd64 might not be pointing at the 5.5.0-0.bpo.2 package yet. I just installed debian 10 and it worked fine.

    omv 5.6.6 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.1
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Hi


    I've just had two NMI faults (reboots) after OMV apt installed 5.5.6


    I've just rebooted into 5.5.0 to see if that stops being stupid, but I'm aware that I saw linux-image-amd64 was 'held' when it went to 5.6 I nudged it and marked it as auto installed - should I (or can I?) downgrade that as well as potentially uninstall 5.5.6?

  • BitBuck solution to run:

    Code
    apt-get install linux-image-5.5.0-0.bpo.2-amd64

    Helped me install missing drivers for my N40L micro server.

    HP N40L (4GB RAM, 2x 4TB RAID1)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!