SMART doesn't work

  • Hello,


    SAMRT does not work. I have a Raspberry Pi 4 and a Seagate M3 Portable on USB.


    I Enabled SMART in Storage / SMART / Settings.

    In Devices I have activated SMART Monitoring on my Seagate M3 Portable /dev/sda.

    When I click on Information, I get the following message in Extended information :

    Code
    smartctl 6.6 2017-11-05 r4594 [armv7l-linux-4.19.97-v7l+] (local build)
    Copyright (C) 2002-17, Bruce Allen, Christian Franke, www.smartmontools.org
    Read Device Identity failed: scsi error unsupported field in scsi command
    A mandatory SMART command failed: exiting. To continue, add one or more '-T permissive' options.


    If I type this in SSH, this is what it looks like

    Code
    pi@NAS:~ $ smartctl -T permissive /dev/sda
    smartctl 6.6 2017-11-05 r4594 [armv7l-linux-4.19.97-v7l+] (local build)
    Copyright (C) 2002-17, Bruce Allen, Christian Franke, www.smartmontools.org
    Smartctl open device: /dev/sda [SAT] failed: Permission denied

    I'm a beginner. Any suggestion to help me out?

  • It is the external box which would be in question?

    Yes, it depends of the USB2SATA-bridge which is used in the case.

    #1: smart not supported on external hdd maxtor m3 ?


    You could try to disable UAS for that device and make a second trial:

    #2: USB devices and smartmontools This fits to your posted error message:

    Read Device Identity failed: scsi error unsupported field in scsi command

    How to disable UAS should be mentioned several times here in the forum.

    OMV 3.0.99 (Gray style)
    ASRock Rack C2550D4I C0-stepping - 16GB ECC - 6x WD RED 3TB (ZFS 2x3 Striped RaidZ1)- Fractal Design Node 304

  • Hi, thanks for your help. Sorry to not have answered right away, I was taking advantage of the good weather to do work outside. It's getting too technical for me, I'm just going to deactivate SMART :(

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!