OMV backup/restore on Odroid HC2

  • I would like some advice on how to save the system on Odroid HC2.

    I installed Armbian on the SD and then with the nand-sata-install utility I transferred it to a partition of the hard disk where are OVM data files.

    The HD has been partitioned: sda1 -> system (OMV 5 + Docker applications) , sda2 -> system backup, sda3 -> data.

    My goal is to save the system software and then restore it if necessary.

    I used the OVM backup plugin choosing the fsarchiver mode to save the system image on the disk (sda2). Everything worked without errors.

    So today, to return to yesterday's situation, I removed the disk from HC2, inserted into an external HD reader and working on another PC, I restored the system partition with with the command:

    Code
    fsarchiver restfs backup-omv-21-May-2020_00-57-31.fsa id=0,dest=/dev/sdb1 (the image of the SD was saved on id=1)
    * files successfully processed: .... regfiles = 129874, directories = 17743, symlinks = 16882, hardlinks = 64, specials = 89
    * files with errors: ............... regfiles = 0, directories = 0, symlinks = 0, hardlinks = 0, specials = 0

    So also the restore worked without errors and very fast. But when I put the disk back on HC2, the computer no longer started. Everything to be redone.

    Probably the backup/restore done in this way has "left out" some files or directories.

    Do you see any errors in this procedure ?

    If I had used the dd mode would the result have been the same? May be.

    How can it be done correctly ?

    Thanks.

    BTW, I have also tried to use the command rsync -aAXv /* /media/backup/ --exclude={.......} but I don't know why on Armbian I couldn't to get working the option to exclude directories, so rsync went in loop filling up the destination directory.

  • ginsa

    Changed the title of the thread from “OVM backup/restore on Odroid HC2” to “OMV backup/restore on Odroid HC2”.
  • Your link refers, as you said, to a SD cloning.

    With nand-sata-install HC2 boots from SD the system that is on SATA disk.

    The SD at the boot, as requested, was plugged, and it was unmodified from the next one installations of components on HD.

    On SD /boot/boot.ini there is:

    .......

    setenv rootdev "UUID=9e9cb295-db23-4ca5-8584-d262e80c3f13"

    setenv rootfstype "ext4"

    ........

    the same parameters of the SATA disk sda1, where is located the system.

    Instead the sda1 directory /boot looks as empty.

    Looking by UART console I see the boot correctly starts but it crashes when reading the kernel module.

  • Resolved.... I noticed in SD /boot/armbianEnv.txt, that modifies the values boot.ini, there was an incorrect parameter (roofstype "btrfs") due to a previous old update of file system type.

    Editing that file with the right value the system boots correctly.

    So now I know I can have a live system backup on a HD partition with the OVM pluging and I can restore from it with fsarchiver command.

    The only drawback is having to physically remove and put back the HD, but I believe there is no alternative, and I hope not to do it daily.

  • ginsa

    Added the Label resolved

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!