OMV5: JDownloader Docker downloading to SD Card

  • Hello everyone!

    First things first: I normally had OMV 4 running on my Odroid HC2 (with a WD RED in it) to use it as a media streaming server and as a download station. That worked well, after some plugin messed up my setup and I had to flash a new OS anyway.

    That's why I upgraded to OMV 5 (which is newly recommended in the guides).

    My Setup includes: Pi-Hole and ioBroker through the Armbian-Installer, Docker installed through the OMV-extras section and Cockpit installed there as well. My first problem: Portainer can't be installed. It always gives me a cryptic error message, but without Portainer (attachment 1) would be totally fine and just use Cockpit. Edit: Trying to launch Portainer through Cockpit gives the error in Attachment 4.

    OK, now to my second and main error: If I setup JDownloader2 using jaymoulin's image, I always get to the point, where JDownloader only sees the boot SD drive as a download drive (attachment 2). It's an old and well discussed problem, that's normally attached to wrong volume mounts, but I double checked and did it this way: I set up JDownloader pretty much exactly according to jaymoulins instructions that worked with my old setup, but with new mounting folder paths, of course. On armbian, my /sharedfolders/xyz tree does not work anymore and I mount the volumes to /srv/dev-disk-by-label-omv/xyz (see attachment 3). Is this the wrong way? UID and GID are the normal 1000 and 100.

    OK, that's pretty much it. I hope someone knows their way around my problems. I actually miss the old way OMV was structured in V4. (And: The tried and true docker-gui as well. :-D)

    Thanks in advance for your help!

  • att2 shows a different path for the downloads than att3.

    You got my hopes really high up that fixing that would directly fix my problem. :-D But I tried, and well: Things got weird! As you see in attachment A, switching the wrong section in the docker mounting command, changes it the other way around: JDownloader now shows /root/Downloads as its target directory. What? In attachment B you see that I changed the volume mounts to the way it should have been.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!