Will this oldtimer do it?

  • Guys, I have an ancient Windows XP tower (built in 2005) standing here, which has one main advantage: it fits eight SATA hard disks, and it just so happens that I have eight here, and they are all not too old, but they each have 1 TB.


    The question before tinkering is: is it worth it, and can I do it?I'm not a tinkerer or a software expert, I'm a user. At some point I (I think) managed to install a gigabit network card and one for USB3 in this PC.


    "The device" has a DFI Lanparty nF4 motherboard, ample 4 GB RAM. There is also a raid controller on board, but it was always a mess. The highly advanced AMD X2 processor is probably overshadowed by my smartphone. A gigabit card is on board. And the box works.


    I'm from the Mac corner, have a little user experience with Windows XP and 7 and a little bit of Ubuntu. At this time this machine works with Ubuntu 20.


    What do you think, is this a game I can win? If so, where is the one for dummys among the many instructions?

  • On addon: I have a small Synology NAS for my home office. I would also love to backup that machine to my oldtimer using rsync - Synology's operating system can only backup to other Synologys, to USB, esata and rsync but not to a network share. But I am too stupid to setup an rsync server (or Samba).

  • You'll need a drive to install OMV to (or a flash drive if you use the flash memory plugin). It would appear the machine meets minimum specs.

  • definitely worth it! OMV is very resource efficient. Your CPU should not be a bottel neck.

    If the HDs are reasonable and 1TB suggests they cannot be too old, then it should turn out to be a nice NAS or Media server

    OMV4 on ProLiant N54L + 5 x 3.5'' WD/Seagate HDs

    OMV5 on Raspberry Pi4 + 7x 2.5'' WD /Seagate HDs

  • So, I did it.


    In this PC I had installed Ubuntu 20, and it worked. As I am not a Linux expert, I decided to kill it, and this is how it went:


    Installed 2 more HDs, each 1 TB, all SMART-tested. So there are 3 HDs on board. I downloaded and burnt the OMV ISO, let the installer do its work, gave it all the settings it wanted. I was warned a few times that this would overwrite everything on my old HD.


    Then I rebooted.


    Ubuntu started.


    WTF? Why does it boot an OS that I thought had been overwritten? I don't get it. How can this happen?

  • How can this happen?

    Can only imagine you installed on one of the other drives but did not change the boot order.

    Try to install with only one drive attached. And as Marc mentioned, for OMV a USB thumb drive is enough.

  • A 32gig SanDisk ultra is perfect. About 7 US dollars. Get two and you will have one for a backup. You can’t loose.

    RAID is NOT a backup and not useful for most home users. Rsync makes true backup and restoration stupid easy, and it's built right in to OMV. Use this command in a Scheduled Job: rsync -av --delete /srv/dev-disk-by-label-NAMEofSOURCEdisk/ /srv/dev-disk-by-label-NAMEofDESTINATIONdisk/

    Hardware: OMV 5 (current) - NanoPi M4: Nextcloud, Plex, & Heimdall - Acer Aspire T180: backup - Odroid XU4: Pi-Hole (DietPi) - Odroid HC2, Raspberry Pi 3B+, and HP dx2400: testing.

  • OMV is best installed to boot from a USB stick and then use all 3 HDs for data.

    I have never installed it on a HD.

    I disagree. Installing to a hard drive is just fine (and actually how it was designed... USB installs were an after thought).


    Installing it properly is the key, which this user did not.

  • Can only imagine you installed on one of the other drives but did not change the boot order.

    Try to install with only one drive attached. And as Marc mentioned, for OMV a USB thumb drive is enough.


    I'm gonna take a WAG and say he probably installed OMV to another one of his drives, and if he boots that drive, it will boot.

  • I guess I am a simple mind, so I took out the first HD from the computer, and it boots from USB. Next step: I am gonna format that HD and put it back in ("It's not stupid if it works.")


    Thanks, guys, I will do more setup work tonight. At first glance, OMV is already much better for me than Ubuntu :-)

  • Unexpected next step:


    Today, the system does boot anymore. I did not change the USB stick, it's still in place. But the oldtimer tells me "Disk boot failure, insert system disk". I checked in the BIOS: Removable is still the first boot medium.


    Alright, I repeated the whole installation with a new USB stick, just to be sure. Everything looks fine. I boot without CD, just with the new stick.


    Result:



    How do I deserve this? Should I trash the whole PC and buy a ready-made NAS? I am really close to throwing this shit out of the window.

  • Hi,


    I am a beginner too with OMV and linux. I had same problem and fixed it with this post.


    RE: Unable to boot after installation (Dropping to a shell!)


    I advice to read the post where it's explained with further detail. Anyway, this is basically what I did:


    You have to press esc during grub boot to enter in grub setup, then press e to edit the boot script, and then carefully edit your boot partition in the line beginning with linux. In my case I changed sda1 to sdb1 (it is the partition where the system is installed) saved and boot and voilá it worked.


    To fix it permanently you have to use update-grub from command line once you've managed to boot. This way I think a unique id is assigned to each disk and no a random letter that can be confusing for the system specially using external usb.


    Hope this helps.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!