OMV not recognizing disks on HPE H240 HBA

  • Hello,

    I have a HPE H240 HBA and connected 5 SATA HDDs to it. (I have confirmed that the cable is the correct one) My problem is, that as the title suggests, the drives are not recognized by omv at all. All other drives that are connected to the mainboard directly are working fine.

    Do I need a special plugin or something for the drives to show up in omv?

    The HBA seems to be working fine, as it has a green LED that is slowly flashing and on boot it also had a message on screen saying that the HBA was initializing.

    Can someone help me with this?

  • I got the drives to show up now!

    The controller was in raid mode. I needed to download and install the hpssacli command line tool and then change the configuration using it.

    Only problem now is, that I can no longer see the SMART status of any of the drives in the system.

    When I go to the SMART page I always get the error message below.

    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; smartctl -x '/dev/sda' 2>&1' with exit code '1': smartctl 6.6 2017-11-05 r4594 [x86_64-linux-4.19.0-5-amd64] (local build)
    Copyright (C) 2002-17, Bruce Allen, Christian Franke,

    /dev/sda: requires option '-d cciss,N'
    Please specify device type with the -d option.

    Use smartctl -h to get a usage summary

    How do I solve that problem now?

  • I think you are running into the same problem as another user here: RE: Trying to access SMART menu in the WebUI throw an error message

    IMO this is a bug in smartctl because if every disk of the HBA has a dedicated device file then there is no need to use the -d cciss,N command line argument, because this is only needed if there is only ONE device file for the whole HBA and you want to request the SMART info for a specific disk behind that 'wall'.

    Please execute the Python code mentioned in the link above, i'm interested in the result. But i bet that the result is None because the HBA is using the generic sd driver.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!