ftp server disconnects during upload

  • I have enabled the ftp server and till about a week ago everything worked fine.

    Now i have issues with connections being disconnected.


    When restarting my omv server i get 3 email system notifications (in sequence of appearing)


    1.

    Host: \openmediavault.local

    Date: Tue, 26 May 2020 15:09:13

    Service: proftpd

    Event: Does not exist

    Description: process is not running


    This triggered the monitoring system to: restart


    2.

    Host: \openmediavault.local

    Date: Tue, 26 May 2020 15:09:44

    Service: proftpd

    Event: Exists

    Description: process is running with pid 3530


    This triggered the monitoring system to: alert


    3.

    Host: \openmediavault.local

    Date: Tue, 26 May 2020 15:10:44

    Service: proftpd

    Event: Connection failed

    Description: failed protocol test [FTP] at [localhost]:21 [TCP/IP] -- FTP: error receiving data -- Resource temporarily unavailable


    This triggered the monitoring system to: restart



    Then no notifications, the indicators are green but as i said connections are interrupted. In the log files is hardly any information:

    Tue May 26 15:16:53 2020 23 185.94.230.101 645463840 /neostrada/www.leukgevonden.com/www.leukgevonden.com-20200526-131135-4c4ojt.wpress b _ i r ftpuser ftp 1 * i

    Tue May 26 15:17:28 2020 26 185.94.230.101 726804016 /neostrada/www.leukgevonden.com/www.leukgevonden.com-20200526-131135-4c4ojt.wpress b _ i r ftpuser ftp 1 * i

    Tue May 26 15:17:57 2020 25 185.94.230.101 756887848 /neostrada/www.leukgevonden.com/www.leukgevonden.com-20200526-131135-4c4ojt.wpress b _ i r ftpuser ftp 1 * i

    Tue May 26 15:18:29 2020 26 185.94.230.101 740735640 /neostrada/www.leukgevonden.com/www.leukgevonden.com-20200526-131135-4c4ojt.wpress b _ i r ftpuser ftp 1 * i

  • Noboby else has this issue? It looks like connetion is disconnect after certain amount of time. Then the client tries again. Smaller files are transferred ok.

  • I switched to the pve kernel and the issue has gone. When restarting the omv server i now get only the first 2 email system notifications.

  • Unfortunately the error returned. I updated OMV to 5.5.2, but i do not know if that caused it.


    Here is a part of the filezilla log maybe someone can give advice? It is in Dutch but i translated the most important parts


    2020-06-09 09:02:34 6036 4 Antwoord: 227 Entering Passive Mode (192,168,1,4,168,69).

    2020-06-09 09:02:34 6036 4 Opdracht: STOR leukgevonden.com-20200511-140033-h5tg2u.wpress

    2020-06-09 09:02:34 6036 4 Antwoord: 150 Opening BINARY mode data connection for leukgevonden.com-20200511-140033-h5tg2u.wpress

    2020-06-09 09:03:00 6036 3 Status: Connection closed by server

    2020-06-09 09:03:02 6036 4 Fout: Could not write to transfer socket: ECONNRESET - Connection reset by server

    2020-06-09 09:03:02 6036 4 Fout: Connection closed by server

    2020-06-09 09:03:02 6036 4 Fout: File transfer fails after the transfer of 434,7 MB inr 28 seconden

    2020-06-09 09:03:02 6036 4 Status: Connection with server lost

    2020-06-09 09:03:02 6036 4 Status: Verbinden met 192.168.1.4:21...

    2020-06-09 09:03:02 6036 4 Status: Verbinding gemaakt, welkomstbericht afwachten...

    2020-06-09 09:03:02 6036 4 Antwoord: 220 ProFTPD Server ready.

    2020-06-09 09:03:02 6036 4 Opdracht: AUTH TLS

    2020-06-09 09:03:02 6036 4 Antwoord: 500 AUTH not understood

    2020-06-09 09:03:02 6036 4 Opdracht: AUTH SSL

    2020-06-09 09:03:02 6036 4 Antwoord: 500 AUTH not understood

    2020-06-09 09:03:02 6036 4 Status: Onveilige server, die geen FTP over TLS ondersteunt.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!